Welcome to TalkGraphics.com
Results 1 to 9 of 9
  1. #1

    Default Changing links issue.

    I recently upgraded to the latest version and it appears that the programme has changed virtually all the hyperlinks to different pages on at least three of my websites. I think links to external sites are unchanged but apart from being really annoying as it will take me hours to check the whole sites, it will make me look really stupid if I don't spot any more.
    I don't know if anyone else has experienced this but it's definately not me going senile as some of the links have been changed to ./block.htm which is a page name I've never used.

  2. #2
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    17,611

    Default Re: Changing links issue.

    Quote Originally Posted by kilo View Post
    I recently upgraded to the latest version and it appears that the programme has changed virtually all the hyperlinks to different pages on at least three of my websites. I think links to external sites are unchanged but apart from being really annoying as it will take me hours to check the whole sites, it will make me look really stupid if I don't spot any more.
    I don't know if anyone else has experienced this but it's definately not me going senile as some of the links have been changed to ./block.htm which is a page name I've never used.
    kilo, you'll need to be more specific.

    How are these Links inputted?
    Are they Link to web address?
    Are your internal Link to links unchanged?
    Are your sites Conventional builds?

    If you have a backup built with an older version still, can you ZIP that up with an 'updated' copy and upload here?

    Acorn
    Acorn - installed & active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Xara Cloud+/Pro+/Magix Legacy; Xara KB & Chat

  3. #3
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1,693

    Default Re: Changing links issue.

    That looks more like a security measure than a Xara error.

    You don't say whether the links changed after you upload changes, or they just happened on their own. Too weird to be Xara.

  4. #4

    Default Re: Changing links issue.

    They were all links created in Xara's 'Web Properties' using the 'Link to:' different pages on the site.
    I have made some additions to these pages but not changed the internal links and only found out as I'm currently adding an additional page to a charity page as I have a Trustee's meeting tonight.
    It's made even worse in that I've just spent two hours correcting all the links and found that this hasn't corrected them in the mobile version so I have another two hours work ahead of me.
    I'm not sure when the changes have occurred as it wouldn't be normal for me to periodically check to see if something else has changed the links. There's nobody else who has access to the programme or PC apart from Freddie - but at 14 weeks old I don't think my Golden Retriever know's owt about computers yet.

  5. #5
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    17,611

    Default Re: Changing links issue.

    Quote Originally Posted by kilo View Post
    They were all links created in Xara's 'Web Properties' using the 'Link to:' different pages on the site.
    I have made some additions to these pages but not changed the internal links and only found out as I'm currently adding an additional page to a charity page as I have a Trustee's meeting tonight.
    It's made even worse in that I've just spent two hours correcting all the links and found that this hasn't corrected them in the mobile version so I have another two hours work ahead of me.
    I'm not sure when the changes have occurred as it wouldn't be normal for me to periodically check to see if something else has changed the links. There's nobody else who has access to the programme or PC apart from Freddie - but at 14 weeks old I don't think my Golden Retriever know's owt about computers yet.
    Link tos don't just change.

    They are a drop down list of your site's Page filename. Change one of them and all prior links are updated by the application and this includes all Variants.
    The only fields that are or can be manual input are 'Link to Web or Email address' (manual) & 'Link to File (PDF, AVI, etc)' [dropdown and, at a stretch, manual).

    Your Xara application will blindly use whatever is there. So if you are using the first field for a link to an internal page then this is wrong.
    The field also need to have the complete filename and extension unless you use it as I do for javascript: calls.
    You indicated one field was './block.htm'. './' is a pointer to the current directory of the calling page so it is totally spurious if you are linking to a web page of the same site.
    Even ticking Correct automatically would not create this.

    Either Freddie hit your keyboard or you typed it or Xara broke it.
    You seem to be the filling or an interesting sandwich.

    Acorn
    Acorn - installed & active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Xara Cloud+/Pro+/Magix Legacy; Xara KB & Chat

  6. #6

    Default Re: Changing links issue.

    Quote Originally Posted by Acorn View Post
    Link tos don't just change.

    They are a drop down list of your site's Page filename. Change one of them and all prior links are updated by the application and this includes all Variants.
    The only fields that are or can be manual input are 'Link to Web or Email address' (manual) & 'Link to File (PDF, AVI, etc)' [dropdown and, at a stretch, manual).

    Your Xara application will blindly use whatever is there. So if you are using the first field for a link to an internal page then this is wrong.
    The field also need to have the complete filename and extension unless you use it as I do for javascript: calls.
    You indicated one field was './block.htm'. './' is a pointer to the current directory of the calling page so it is totally spurious if you are linking to a web page of the same site.
    Even ticking Correct automatically would not create this.

    Either Freddie hit your keyboard or you typed it or Xara broke it.
    You seem to be the filling or an interesting sandwich.

    Acorn
    I understand weblinks, I've been building websites since 1992 the './block.htm' had been added to the 'Link to Web or Email address:' field not by me or by Freddie as his paws are too big to type words. So either the programme has a glitch in it or my whole pc has some sort of wierd virus that makes very minor changes to it.
    I made the changes and yet some have reverted back to incorrect page links so I have to go throuygh the whole process again.

    It's very weird and I've not experienced anything like it until upgrading to the latest version which is why I was asking if anybody else has experienced anything similar.

    Kilo

  7. #7
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    17,611

    Default Re: Changing links issue.

    kilo, we are of a similar vintage. I probably have a few years on you.

    In the past, I have used Xenu Link Sleuth. It is quite old but probably still works.
    Nowadays, I just use the browser Console and the following:
    Code:
      var x = document.querySelectorAll('a');
      var table = '<table><thead><th>Name</th><th>Links</th></thead><tbody>';
      for (var i=0; i<x.length; i++){
        var nametext = x[i].textContent;
        var cleantext = nametext.replace(/\s+/g, ' ').trim();
        var cleanlink = x[i].href;
        if (cleantext == "") cleantext = 'Link';
          table += '<tr><td><a href="'+ cleanlink + '" target="_blank">' + cleantext + '</a></td><td>' + cleanlink +'</td></tr>';
      };
      table += '</table>'
      var w = window.open('', 'Link Lister');
      w.document.write(table);
    It works on a page by page basis, which usually suits.
    I have just changed a Conventional website to a Scroll and it lists the links on all pages.
    Easy enough to eyeball or page search for '.block.htm'.

    In all my Xara years, I have never had such an encounter.
    My gut suggests a corrupt file if it is reverting.

    never great when under time pressure too.

    Acorn
    Acorn - installed & active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Xara Cloud+/Pro+/Magix Legacy; Xara KB & Chat

  8. #8

    Default Re: Changing links issue.

    Quote Originally Posted by Acorn View Post
    kilo, we are of a similar vintage. I probably have a few years on you.

    In the past, I have used Xenu Link Sleuth. It is quite old but probably still works.
    Nowadays, I just use the browser Console and the following:
    Code:
      var x = document.querySelectorAll('a');
      var table = '<table><thead><th>Name</th><th>Links</th></thead><tbody>';
      for (var i=0; i<x.length; i++){
        var nametext = x[i].textContent;
        var cleantext = nametext.replace(/\s+/g, ' ').trim();
        var cleanlink = x[i].href;
        if (cleantext == "") cleantext = 'Link';
          table += '<tr><td><a href="'+ cleanlink + '" target="_blank">' + cleantext + '</a></td><td>' + cleanlink +'</td></tr>';
      };
      table += '</table>'
      var w = window.open('', 'Link Lister');
      w.document.write(table);
    It works on a page by page basis, which usually suits.
    I have just changed a Conventional website to a Scroll and it lists the links on all pages.
    Easy enough to eyeball or page search for '.block.htm'.

    In all my Xara years, I have never had such an encounter.
    My gut suggests a corrupt file if it is reverting.

    never great when under time pressure too.

    Acorn
    Errors
    The following errors occurred with your submission

    Your submission could not be processed because the token has expired.

    Please reload the window.

  9. #9

    Default Re: Changing links issue.

    Quote Originally Posted by Acorn View Post
    kilo, we are of a similar vintage. I probably have a few years on you.

    In the past, I have used Xenu Link Sleuth. It is quite old but probably still works.
    Nowadays, I just use the browser Console and the following:
    Code:
      var x = document.querySelectorAll('a');
      var table = '<table><thead><th>Name</th><th>Links</th></thead><tbody>';
      for (var i=0; i<x.length; i++){
        var nametext = x[i].textContent;
        var cleantext = nametext.replace(/\s+/g, ' ').trim();
        var cleanlink = x[i].href;
        if (cleantext == "") cleantext = 'Link';
          table += '<tr><td><a href="'+ cleanlink + '" target="_blank">' + cleantext + '</a></td><td>' + cleanlink +'</td></tr>';
      };
      table += '</table>'
      var w = window.open('', 'Link Lister');
      w.document.write(table);
    It works on a page by page basis, which usually suits.
    I have just changed a Conventional website to a Scroll and it lists the links on all pages.
    Easy enough to eyeball or page search for '.block.htm'.

    In all my Xara years, I have never had such an encounter.
    My gut suggests a corrupt file if it is reverting.

    never great when under time pressure too.

    Acorn
    Thanks Acorn, that's quite a useful programme!

    About 80% of the links in the navigation menu had changed as well so I changed as much as I could before the meeting and am back on it this morning. Luckily it is only a charity and I'm one of the trustees and not a major client but I did make sure I saved the changes, closed the programme and re-booted before re-opening and all the changes appear to be good. It's a strange one as I know it's nothing I did but hopefully the glitch has now gone.
    I will be testing my own sites to see if I have any broken links.
    Kilo

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •