Welcome to TalkGraphics.com
Results 1 to 10 of 10
  1. #1
    Join Date
    Oct 2021
    Posts
    24

    Default sticky image link not working?

    Hi Everyone

    So I was updating my website today and wanted an existing menu system (I have a main menu title bar with menu items, one of which, when clicked on, causes a pop-up sub menu to appear beneath with all the products in it) to be sticky and stay at the top of the page regardless of scroll position. So all that worked perfectly ok. The problem is now that I can't get any of the product images that appear in the now sticky pop-up sub-menu, to work??? They worked perfectly ok before I made them sticky, but I don't understand why this would be an issue as sticky menus are pretty common?

    Any help to resolve this is greatly appreciated ...

  2. #2
    Join Date
    Apr 2018
    Location
    Barnes, London
    Posts
    856

    Default Re: sticky image link not working?

    Quote Originally Posted by wwdileie View Post
    Hi Everyone

    So I was updating my website today and wanted an existing menu system (I have a main menu title bar with menu items, one of which, when clicked on, causes a pop-up sub menu to appear beneath with all the products in it) to be sticky and stay at the top of the page regardless of scroll position. So all that worked perfectly ok. The problem is now that I can't get any of the product images that appear in the now sticky pop-up sub-menu, to work??? They worked perfectly ok before I made them sticky, but I don't understand why this would be an issue as sticky menus are pretty common?

    Any help to resolve this is greatly appreciated ...
    Wouldn't want to start guessing what you might have done; maybe post a document here with the menu bar and it should be easier to help.
    Gary
    www.initiostar.co.uk


    Xara Pro X 19.0.0.64291 May 3 2022

  3. #3
    Join Date
    Oct 2021
    Posts
    24

    Default Re: sticky image link not working?

    Quote Originally Posted by Initiostar View Post
    Wouldn't want to start guessing what you might have done; maybe post a document here with the menu bar and it should be easier to help.
    Hi, thanks for replying. Ok, have made a test file, attached, which gives this example. So the main menu has a bunch of menu items, but products is the only active one. When clicked, it brings up a sticky sub menu (so it can be accessed from any point on a scrolled page) that when the image in it is clicked, it should go to the products page, but it does nothing... Can't figure out why?

    Any help is much appreciated!
    Attached Files Attached Files

  4. #4
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1,414

    Default Re: sticky image link not working?

    You have the 'Products' link set to close the pop-up page automatically. Turn this off and it works as intended.
    Select 'Products', then:
    Utilities > Web Properties > Link (tab) > Pop-up Layer (radio button) - Settings. Remove the tick from Close Pop-Up Automatically.

  5. #5
    Join Date
    Oct 2021
    Posts
    24

    Default Re: sticky image link not working?

    Quote Originally Posted by Chris M View Post
    You have the 'Products' link set to close the pop-up page automatically. Turn this off and it works as intended.
    Select 'Products', then:
    Utilities > Web Properties > Link (tab) > Pop-up Layer (radio button) - Settings. Remove the tick from Close Pop-Up Automatically.
    Hi Chris!

    Thanks for your reply . It does link ok now, but the problem now is that the pop-up menu doesn't close when I click away from it, it just hangs around until a link is clicked (and if I click a link in the pop-up, and then click 'back' on my browser, it takes me back to the home page with the menu still up and active), so that's why I checked the close automatically option in the original. Any ideas are very much appreciated, as I would like the pop-up to close itself when the user clicks away from it, or clicks a pop-up menu item

  6. #6
    Join Date
    Apr 2018
    Location
    Barnes, London
    Posts
    856

    Default Re: sticky image link not working?

    The issue I don't think is related to whether the objects on your popup are sticky or not. Assuming you are repeating the product popup layer on all the pages, I would lock the layer by adding (lock) to the popup name. This ensures you don't close the popup until you move away from it, by either clicking on a link, or by closing the popup itself. You would add any icon of your choice with a link "popup:close" without the quotes to the popup. These are undocumented Xara features, but can be quite useful > https://help.xara.com/article/26-und...d-web-features.

    In the example, I made the assumption that you had one overall products page and that each of the product photos linked to that page, but the links could be anything you choose, individual product pages being an example.

    Here is the example: Sticky menu test_2.xar

    I would make sure too that the popup layer is above the MouseOff layer in the stack.
    Last edited by Initiostar; 22 June 2022 at 08:36 PM.
    Gary
    www.initiostar.co.uk


    Xara Pro X 19.0.0.64291 May 3 2022

  7. #7
    Join Date
    Oct 2021
    Posts
    24

    Default Re: sticky image link not working?

    Quote Originally Posted by Initiostar View Post
    The issue I don't think is related to whether the objects on your popup are sticky or not. Assuming you are repeating the product popup layer on all the pages, I would lock the layer by adding (lock) to the popup name. This ensures you don't close the popup until you move away from it, by either clicking on a link, or by closing the popup itself. You would add any icon of your choice with a link "popup:close" without the quotes to the popup. These are undocumented Xara features, but can be quite useful > https://help.xara.com/article/26-und...d-web-features.

    In the example, I made the assumption that you had one overall products page and that each of the product photos linked to that page, but the links could be anything you choose, individual product pages being an example.

    Here is the example: Sticky menu test_2.xar

    I would make sure too that the popup layer is above the MouseOff layer in the stack.
    Thanks for your reply, have tried everything suggested and read through the document you sent, nothing worked to resolve this. So I removed the sticky feature from the menu system and it works perfectly fine now. I'm more convinced now that Xara Web Designer is riddled with bugs - this is not the first time I've had issues like this that shouldn't be happening. As someone that develops in Visual C++, I'm putting it down to poor or sloppy coding, far to many niggles like this that should be simple to implement in such a designer . Even this morning, I did a simple copy and paste of the now sticky-removed menu layers. And without explanation, 2/3's of the pages worked properly, the others didn't. I then re-copied the layers to those pages again yet again, and then a third time, and finally it pasted them correctly. Highly annoying bugs in this program. It even keeps on saying that the update software needs updating, so I click yes, it seems to install, yet when I start the program again, it comes up and says the update I just installed is out of date and needs updating again! Heck, even windows is less buggy than this, and that's saying something!

  8. #8
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,478

    Default Re: sticky image link not working?

    When copying across designs, if you don't have the items on the required layers unlocked and visible, it is possible to achieve a partial copy that will cause a fail.
    I copy & paste all the time without any glitches.

    Past Threads have identified lots of bugs with the Xara NavBar but that is a different matter to your case.

    I looked at your set-up earlier and found a PNG for the Title Bar that fell off the page. The Products link is on a 99% Transparent Box. The Title Bar is set as Stick at Top when it is there already; Stick would do the job.
    Both the Title Bar and the Pop-up layer are under the MouseOver layer.

    I think the Sticky settings have changed the bubble order of actions (and z-index) and it is trying to close the pop-up first rather than follow the link.

    I would change the pop-up action to not close automatically.
    Then I would add some head CSS:
    Code:
    <style>
    img[src*='close.png'] {
      display: none;
    }
    </style>
    It is a kludge that might get to designing again.

    I cloned your Title Bar and added a box for index.htm.
    Following the links back and forth does not keep the pop-up open, if that helps.

    I still do not understand the Use Case of a pop-up to click a link to go to a Products page when this could have been done with a direct Link.
    What is supposed to happen when you are in the Product page and click the Products Link?

    Do you wish the Thread to be move to the Dear Xara Forum?

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Magix; Xara Cloud+/Pro+

  9. #9
    Join Date
    Oct 2021
    Posts
    24

    Default Re: sticky image link not working?

    Quote Originally Posted by Acorn View Post
    When copying across designs, if you don't have the items on the required layers unlocked and visible, it is possible to achieve a partial copy that will cause a fail.
    I copy & paste all the time without any glitches.

    Past Threads have identified lots of bugs with the Xara NavBar but that is a different matter to your case.

    I looked at your set-up earlier and found a PNG for the Title Bar that fell off the page. The Products link is on a 99% Transparent Box. The Title Bar is set as Stick at Top when it is there already; Stick would do the job.
    Both the Title Bar and the Pop-up layer are under the MouseOver layer.

    I think the Sticky settings have changed the bubble order of actions (and z-index) and it is trying to close the pop-up first rather than follow the link.

    I would change the pop-up action to not close automatically.
    Then I would add some head CSS:
    Code:
    <style>
    img[src*='close.png'] {
      display: none;
    }
    </style>
    It is a kludge that might get to designing again.

    I cloned your Title Bar and added a box for index.htm.
    Following the links back and forth does not keep the pop-up open, if that helps.

    I still do not understand the Use Case of a pop-up to click a link to go to a Products page when this could have been done with a direct Link.
    What is supposed to happen when you are in the Product page and click the Products Link?

    Do you wish the Thread to be move to the Dear Xara Forum?

    Acorn
    Hi Acorn, thanks for you input on this, I will try what you suggest, hopefully it works. I agree with what you're saying with regard to how the sticky is resulting in an order of action issue, as everything went back to normal after. With regard to your question on why design the menu system this way. The file I uploaded was a simple example to demonstrate the problem. But the actual menu system on the real website is more in depth.. The idea is to have a sub-menu for products and then the images for each product comes up for selection.

    Also, I agree with your copy and paste points, which is what I do also, very careful with layering and what is locked/not locked etc. None of those things were affected in the pasting of the menu/sub menu layers. In fact, all pages have identical structures in terms of what is locked, the order of layering and the visible/non-visible items. So this is why I flagged this as a possible issue as there really wasn't a good reason why it should not have behaved the same on all pages.

    But yes, please move this to the dear xara, as I have hunch some re-coding might be needed here to get this issue running smooth for others who want to do the same...

    Thanks again

  10. #10
    Join Date
    Apr 2018
    Location
    Barnes, London
    Posts
    856

    Default Re: sticky image link not working?

    I understood the 'use-of' a popup layer as a picture-based menu where each picture would link to a more detailed description of each object (product, service etc.) e.g. https://initiostar.co.uk/demo/photomenu/index.htm. It makes sense for that popup to be 'sticky' so it is always in view from whatever page the visitor happens to be on and independent of the position the visitor is on that page.

    Using the standard way of calling a popup through a link, it did not seem an issue whether the objects on the popup were 'sticky' or 'not-sticky'.

    But!! when I used the 'undocumented feature' whereby one uses a link > popup: "popup-name", if one of the objects were made 'sticky' it is not then visible on the popup: Popup Sticky Error.xar. It is however visible if you use the standard popup link. Not sure whether this is an error as such, but it is consistent.

    The better way, perhaps, to do any of this, is to create a product summary page (images as required) and to have each of the images link to more detailed pages as required. This avoids having a menu bar that mixes links to pages and popups, which personally does not seem a good idea anyway.
    Gary
    www.initiostar.co.uk


    Xara Pro X 19.0.0.64291 May 3 2022

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •