Welcome to TalkGraphics.com
Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1

    Default Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    Hello as already written in the title; I have created some sites with XD Pro+ 15 with embedded Google fonts which always worked without problems. Today I opened one of them with XD Pro+ 19 and made some minor changes. When exporting HTML it is now criticized that it is not possible to embed the Google fonts "Nuntio" or "Nuntio bold". This means that if you view the website on a PC that does not have these fonts installed, a substitute font is displayed. What I don't understand is that it used to work fine with v15 and now not with v19.

    Any ideas or workaround besider render all text as grahics or reformat all graphics?

    Thanks, TomTom

  2. #2
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,490

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    Nunito is a Google Font, which I have just added to my Fonts.
    It renders properly without complaint:
    Fonts
    Nunito Regular Installable
    Verdana Editable
    Verdana Bold Editableditable
    This means Xara generate a woff file (../index_htm_files/XaraWDGeneratedHTMLfont1.woff).
    It creates a CSS file (../index_htm_files/xr_fonts.css) with:@font-face {font-family: 'Nunito';font-weight:normal;font-style:normal;src: url("XaraWDGeneratedHTMLfont1.woff") format("woff"), url("XaraWDEmbeddedHTMLfont1.eot?") format("embedded-opentype"), local('Nunito');
    and another (../index_htm_files/xr_text.css) with: .xr_s0 {font-family:'Nunito';font-weight:normal;font-style:normal;font-size:24px;text-decoration:none;font-feature-settings:'kern','liga' 0,'clig' 0,'calt' 0,'titl' 0,'salt' 0,'swsh' 0,'cswh' 0;text-transform: none;color:#000000;background-color:Transparent;-webkit-text-stroke: 0px black;letter-spacing:0em;} or similar.

    I would go the the XDPXv19 Text tool > Google Fonts > Add and install Nunito (again).

    Never convert text to shapes, it immediately ruins what a site ought to be.
    If you had XPro+, which can handle Shapes as SVG then there may be some circumstances where this could be used; the main one at present is where Xara converts rotated text to an image(!)

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Magix; Xara Cloud+/Pro+

  3. #3

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    (Update info)


    Hello,

    As already described here in this community post, a quasi-same problem occurs with me as well. It is 1:1 reproducible.

    https://www.magix.info/us/forum/embe...hing--1298176/

    Steps:

    You create a new, empty website (e.g. 960px), make several text lines which is already enough. Now you install via Designer Pro (in my case) e.g. the Google font "Nunito" which is then imported/downloaded by Desogner Pro as the entire font family. As soon as you start formatting 2 of the several text lines that you have created in the document and formatted with "Nunito" with "Nunito Semibold" and "Nunito medium" the error occurs! When exporting as a website, the fonts "Nunito", "Nunito black", etc. "CANNOT be embedded". Even the wrong font names are displayed in the error! Nothing in the file was formatted with "Nunito black" also the name gallery (what showed that fon "Nunito black" is "used" did not mark anything = no red point when active selected. The after error message generated and uploaded website is displayed incorrectly when displayed on a computer without the "Nunito" fonts installed because the fonts are missing. Only when the text lines formatted differently in "Nunito" are removed with "Nunito Semibold" and "Nunito medium", the export works again without error message.

    This happened to me with a website created with Designer Pro 15, which I opened with the installed trial version of Designer Pro 19 and further edited to esport it. The export of the named XAR file worked perfectly fine in version 15. (Background: I want to buy the update). But as I said, it also happens when you create a completely new document in Designer Pro 19 as described.

    This is an extremely annoying error that should not occur. Has cost me almost an entire afternoon and evening of recherche, troubleshooting. In addition, I suspect that the exact same problem will be present on other pages that I will open and edit. For me the absolute reason NOT to buy this update to v19 before the error is not clearly fixed.

    OS: Win 8.1 (according to previous inquiry directly at Xara v19 runs on Win 8.1 - there was also no error message concerning this during the installation)

    The original font family "Nunito" was loaded direct from the Google website (either via Xara Designer Pro, or as ZIP) causes the export problems when using the font style "semibold" as well as "medium".

    Actually, it can't be Win 8.1 either, because the same (!) XAR file works fine in export with XD Pro v15, while in v19 exactly the named error message occurs.

    TomTom

  4. #4
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,490

    Exclamation Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    TomTom, Google Fonts does not install a 'Nunito Medium' and 'Nunito Black' so I suspect you got these from elsewhere previously.
    I cannot reproduce your fault following your instructions.
    I only have:

    • Nunito 200
    • Nunito 200 italic
    • Nunito 300
    • Nunito 300 italic
    • Nunito regular
    • Nunito italic
    • Nunito 600
    • Nunito 600 italic
    • Nunito 700
    • Nunito 700 italic
    • Nunito 800
    • Nunito 800 italic
    • Nunito 900
    • Nunito 900 italic

    In v19, Xara is probably now conforming to the licensing conditions more strictly. In v15, it is possible things slipped through.

    Even when you believe they are not in use, you eventually find there is something like a linefeed in that particular font variant.
    To "prove" you actually have the offending font variants in use, you need to select all on each page and then look at the Names Gallery.
    What i do is open the xr_text.css file and establish which ClassName is being used for any font variant.
    I then open the htm file and search for that ClassName.
    If it is found, I note where on the page it is and edit the design.

    Supply a design test page from v15 and v19 and we can check on our systems.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Magix; Xara Cloud+/Pro+

  5. #5
    Join Date
    Feb 2007
    Location
    UK
    Posts
    20,028

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    @acorn

    nunito is a nice font for more than just websites, which I do not do as you know

    here is my installed list, which includes nunito black, but not medium

    Click image for larger version. 

Name:	2022-06-14 18_18_43-.png 
Views:	24 
Size:	75.4 KB 
ID:	132207

    I just went to google fonts, and add, and then installed nunito

    I also did a barebones web [local] export - no issues
    Last edited by handrawn; 14 June 2022 at 05:30 PM. Reason: dyslex
    -------------------------------
    is it true that we stand on the very edge of an abyss?
    no,of couse not - we used to, but since then we have taken a great step forward...
    Wyrd bi ful ard

  6. #6
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,490

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    Quote Originally Posted by handrawn View Post
    @acorn
    nunito is a nice font for more than just websites, which I do not do as you know
    here is my installed list, which includes nunito black, but not medium

    Click image for larger version. 

Name:	2022-06-14 18_18_43-.png 
Views:	24 
Size:	75.4 KB 
ID:	132207

    I just went to google fonts, and add, and then installed nunito
    I also did a barebones web [local] export - no issues
    Cheers handrawn, I did the same and Google Fonts Library declared the variants by weight and not by appearance.

    I then found 'Nunito Black' so labelled (in Xara).
    Why it was not visible first time round, I don't know.
    'Nunito Medium' is still adrift.

    I still cannot find any clashes:

    Google Font Library Xara Fonts & MS Character Map UWP
    Nunito 200 Nunito ExtraLight Regular
    Nunito 200 italic Nunito ExtraLight Italic
    Nunito 300 Nunito Light Regular
    Nunito 300 italic Nunito Light Italic
    Nunito regular Nunito Regular
    Nunito italic Nunito Italic
    Nunito 600 Nunito Bold
    Nunito 600 italic Nunito Bold Italic
    Nunito 700 Nunito SemiBold Regular
    Nunito 700 italic Nunito SemiBold Italic
    Nunito 800 Nunito ExtraBold Regular
    Nunito 800 italic Nunito ExtraBold Italic
    Nunito 900 Nunito Black Regular
    Nunito 900 italic Nunito Black Italic

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPXv18 , XWDPv12/v15, XPGDv10, X3D7, Xara Xtreme 5, and others back through time (to CC's Artworks).
    Technical remediation and consultancy for your web designs. TG Nuggets you might like. Report faults: Magix; Xara Cloud+/Pro+

  7. #7

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    Hello to all,

    thanks first for all tips. Here's what it has now turned out to be: In the existing xar file of the website I have removed the formatting "bold" from all texts that were formatted in "Nunito medium" with "bold" or exchanged it for other font style such as "semibold" etc. After that the export problem was solved.

    However, immediately after that I encountered the next problem: Designer Pro 19 generates the first letter of the file name in capital letters when exporting ".eot" files, e.g. "XaraWDEmbeddedHTMLfont1.eot". Which my web server does NOT accept. This is also NO normal standard. Mean that because of this ccs files are not loaded and "wrong" fonts displayed. If for exampel a picture with uppercase file name used it is not shows, instead the placeholder only.

    But not only that with the .eot files, because additional inside the .css files xr_fonts.css, xr_fontsie.css and xr_fontsrep.css are also capitalized with initial letter in the code. So you have to change not only the first letter of all .eot files but also the code of the 3 .css files. Only after that the fonts will be displayed correctly on the web server. This is all very annoying, as there were never such problems with v15.

    Maybe there is a reason why Xara does not offer to load the font "Nunito medium" in the program itself. I had downloaded the whole font family directly from Google and installed it manually so "medium" was included. I tried to reproduce this in a document but it did not work. So when I create a new document (website) in v15, format lines with text in "Nunito medium", save it and open it with v19 and export it, there is no error message. So the problem seems to be that either some font name got mixed up or was "forgotten" in my website xar file. In any case, for example, "Nunito bold" is also displayed in the name gallery as "present" in the document - but it is not markable (and after not formatted in the document with it).

    TomTom

  8. #8
    Join Date
    Feb 2007
    Location
    UK
    Posts
    20,028

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    I went to google and manually downloaded nunito mendium [ 2 variants] and installed by right click in windows - they then showed up in xara version 19, so I don't see a problem there [other than the xara internal google font install apparently not picking them up by default, but there were options]

    Click image for larger version. 

Name:	2022-06-15 08_18_12-Xara Designer Pro X - [Untitled1 _].png 
Views:	12 
Size:	101.4 KB 
ID:	132211

    did you install the fonts manually one by one, or batch; batch does not always work as it should

    can't help with the capitalisation as I don't do web servers, but hopefully acorn can; you never know it might just be a setting you need to change...

    an important point: there appear to be only the two varients for nunito medium: regular and italic, no bold variant - it seems that both xara ver 15.1 and 19 will allow you to enhance [format] the regular and italic variants to bold using the infobar, but whereas ver 15.1 will allow you to publish, ver 19 will not, I get this message:

    Click image for larger version. 

Name:	2022-06-15 08_34_59-Xara Designer Pro X - [Untitled1 _].png 
Views:	12 
Size:	7.5 KB 
ID:	132212

    which may be ver 19 saying in effect: ' there is no nunito medium bold variant installed that can be embeded' - not sure why ver 15.1 does not do this, but I know it's publishing routine is different; again maybe acorn or another member can shed some light...
    -------------------------------
    is it true that we stand on the very edge of an abyss?
    no,of couse not - we used to, but since then we have taken a great step forward...
    Wyrd bi ful ard

  9. #9

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    Quote Originally Posted by handrawn View Post
    I went to google and manually downloaded nunito mendium [ 2 variants] and installed by right click in windows - they then showed up in xara version 19, so I don't see a problem there [other than the xara internal google font install apparently not picking them up by default, but there were options]

    Click image for larger version. 

Name:	2022-06-15 08_18_12-Xara Designer Pro X - [Untitled1 _].png 
Views:	12 
Size:	101.4 KB 
ID:	132211

    did you install the fonts manually one by one, or batch; batch does not always work as it should

    can't help with the capitalisation as I don't do web servers, but hopefully acorn can; you never know it might just be a setting you need to change...

    an important point: there appear to be only the two varients for nunito medium: regular and italic, no bold variant - it seems that both xara ver 15.1 and 19 will allow you to enhance [format] the regular and italic variants to bold using the infobar, but whereas ver 15.1 will allow you to publish, ver 19 will not, I get this message:

    Click image for larger version. 

Name:	2022-06-15 08_34_59-Xara Designer Pro X - [Untitled1 _].png 
Views:	12 
Size:	7.5 KB 
ID:	132212

    which may be ver 19 saying in effect: ' there is no nunito medium bold variant installed that can be embeded' - not sure why ver 15.1 does not do this, but I know it's publishing routine is different; again maybe acorn or another member can shed some light...

    Hello, I had first downloaded the whole font family from the Google site as a ZIP file and installed it manually (via Font installer Total Commancer) it installed 16 fonts. As part of the problem search / solution, I have uninstalled them all again and installed new ones via the Xara program. Also there it was installed as font family (it was asked if family or single font). Only that "medium" was not included here.

    In v15 + before versions it was so if one equipped a font for example with the attribute "bold" which this did not have a message came that it would have no effect.

    The joke was also that NOT the font "Nunito medium" was criticized as not embeddable but only "Nunito" and "Nunito black" (the latter was not used anywhere on the whole page because it was too "bold" for me). Probably (since Xara did not "know" "medium") this message referred in reality to "medium" then.

    I have also written to Xara now because there the support is more experienced, faster and better than Magix Germany.

    Thanks, TomTom

  10. #10
    Join Date
    Feb 2007
    Location
    UK
    Posts
    20,028

    Default Re: Google font embedded without problems in XD 15+ makes problems in XD19+ ?

    you are welcome

    since you are using ver 19 and ver 15, which are both Magix' responsibility to support and not Xara's [Xara now only supports pro+/cloud], it will be interesting to see what response you do get
    -------------------------------
    is it true that we stand on the very edge of an abyss?
    no,of couse not - we used to, but since then we have taken a great step forward...
    Wyrd bi ful ard

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •