Welcome to TalkGraphics.com
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,221

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Chris, I appreciate that but until I can see for myself, it could be down to a configuration difference that you have not noticed or set a long time ago.

    I have no problem with snapping on a range of designs across v9 through to v18 & v21.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  2. #12

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Hi,

    I've attached a very simple example document, if you try to resize the the grouped object on the right using the bottom right handle does it snap for you? It does on my previous version, but not on the new.

    Cheers in advance,

    Chris

    Xara Designer Pro X 18.5.0.63630 DL x64 Jan 10 2022

    Snapping.xar

  3. #13
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,221

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Quote Originally Posted by Merlinski View Post
    Hi,
    I've attached a very simple example document, if you try to resize the the grouped object on the right using the bottom right handle does it snap for you? It does on my previous version, but not on the new.
    Cheers in advance, Chris
    Xara Designer Pro X 18.5.0.63630 DL x64 Jan 10 2022
    Snapping.xar
    Chris, thank you. You are 100% correct.
    I have trawled the Registry looking for an 'drag' differences and cannot find one.

    The use of the G key during a drag is a toggle so you don't need to hold it down.
    It is a drag to do this (pun totally intended).
    I think Xara has done this to have the effect off by default to make the G key action do something.
    I think it is a Xara developer error as it make no sense to have changed it.

    You can Select, Ungroup, Drag & ReGroup but that adds many more key actions.

    Do you want this Thread put into the dear xara Forum for Xara to rectify/ignore?

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  4. #14

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Yes please, I think I'll have to go back to 17 until it's fixed as this seemingly tiny and inconsequential behaviour formed an important way of working in my day to day.

  5. #15
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,221

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Dear Xara...

    ...
    As with every release we’ve also implemented a large number of minor enhancements including improvements and fixes to import and export formats like SVG, PDF, Word, PowerPoint and InDesign.
    The thrust of this Thread has been to identify an undocumented change that hinders Snapping that seems to have occurred at version 18.

    The are now so many ways that you have mangled the previously clean User Interface particularly affecting Snap to Objects that is different for basic shapes, Text Inside, SmartShapes and now Groups.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  6. #16
    Join Date
    May 2014
    Location
    Australia: GMT+10
    Posts
    237

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    I've found an easy way to snap the the middle of lines, rather than the inner or outer perimeter is to change the display to outlines rather than high quality because then they have zero width and if you zoom in a bit you can also see the little, tiny, eeny-weeny nodes

  7. #17
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,221

    Default Re: Snap to Object not Working Correctly - 18.5.0.63630

    Quote Originally Posted by jaydear View Post
    I've found an easy way to snap the the middle of lines, rather than the inner or outer perimeter is to change the display to outlines rather than high quality because then they have zero width and if you zoom in a bit you can also see the little, tiny, eeny-weeny nodes
    jaydear, yes it is useful but unless you have two views the switching back and forward is tedious.
    The other problem is you get confused when Scale line widths is On; the snapping is to the middle of the invisible line.

    In any case, Outline view does not sort the issue of scaling and snapping a Group.

    For the edge case of wanting a Group to be scaled to the exact size of another shape with the same ratio of H to V, then Copy & Paste > Size might be useful.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •