Welcome to TalkGraphics.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1

    Default Buttons: appear to be designed the same, but function differently

    I've been using Xara for 18 years, but this is my first time doing xara webdesign. (In the past I've used wordpress on a shared hosting site.) My last hosting provider went kaput, leaving me without a website (long story short), so I've decided to take this opportunity to try xara. I'm using Xara Designer Pro x/18, running as administrator, starting from the Auberge template.

    Naturally, I'm running into problems.

    Ignoring all the rest of the problems, the one I'm primarily working on right now is one with buttons. I have 2 sets of buttons on a page that, from my point of view, look exactly the same (even in the layer gallery) but aren't operating the same when previewed an a browser (Firefox 95.0.2). Troubleshooting isn't helping. Here's a screenshot:

    Click image for larger version. 

Name:	ButtonsScreenshot.png 
Views:	25 
Size:	435.5 KB 
ID:	131332

    I have 2 sets of pink buttons superimposed over 2 sets of images. The images are each embedded with corresponding text elements. Images are set to popup, so display a magnifying glass when the mouse hovers over them (this functionality does work on both sets of images).

    My hope is that when a mouse hovers over the buttons, which set atop the images, the magnifying glass will then change to the "pointing finger" and allow the button to be clicked, accessing the link.

    1. One set (above "shop all of argyleimp's fabric on spoonflower") functions as expected. When hovering over the images, the magnifying glass is shown, and the popup can be popped up. When hovering over a button, the mouse changes to the finger and the link can be accessed.
    2. The second set (below "shop all of argyleimp's fabric on spoonflower") does not function as expected. The mouse (almost) always stays as a magnifying glass. Oddly, sometimes if I rapidly or slowly or jerkily move the mouse in the general area of the edges of the buttons the finger might show up.
    a. In the cases where the magnifying glass only shows above the button, "inspect element" in the browser's tools reveals that there is no "onmouseover" code.
    b. In the rare odd cases where the magnifying glass DOES change to a finger, "inspect" reveals that mouseover code does indeed exist.
    c. When, in Xara, I pull the buttons away from the images and have them "sitting in the field" rather than on top of the images, then preview the webpage, the buttons work just fine. (So somehow the images and the buttons are playing havoc with each other?)

    I understand that Xara is generating html and code in the background, so that things that I'm doing in the GUI might be generating wonky coding if I don't have things ordered/layered/grouped together correctly, but no matter how I try, I just can't figure out how to do this.

    Rather than list the hours worth of fixes I've attempted, I was hoping someone might have an easy insight.

    I know this screenshot is most likely less than helpful. I would like to be able to share my webpage in a way that the community here can help. Is there a way to do that without attempting to upload an incomplete website to my hosting provider?

    Any input on this would be SO appreciated! I haven't been able to find anything in the forums.

  2. #2
    Join Date
    Apr 2018
    Location
    Barnes, London
    Posts
    806

    Default Re: Buttons: appear to be designed the same, but function differently

    I would like to be able to share my webpage in a way that the community here can help. Is there a way to do that without attempting to upload an incomplete website to my hosting provider?
    For your reply, scroll down and pick 'Go Advanced' - scroll down to Additional Options / Manage Attachments and add your test XAR document/design file to your reply.

    That way someone will be able to see what is happening.

    Gary

  3. #3

    Default Re: Buttons: appear to be designed the same, but function differently

    Is there a file size limit? I can't seem to get the 72mb file to upload. Could be a problem on my end. I have satellite internet. :I

  4. #4
    Join Date
    Aug 2000
    Location
    Placitas, New Mexico, USA
    Posts
    40,446

    Default Re: Buttons: appear to be designed the same, but function differently

    Way too big. I think the limit (and varies for file types) is more like 10MB max. Can you save and upload one page from your document? Or upload to a site such as Drop Box and provide a download link?
    Gary W. Priester
    Mr. Moderator Emeritus Dude
    , Sir

    gwpriester.com | eyetricks-3d-stereograms.com | eyeTricks on Facebook






  5. #5

    Default Re: Buttons: appear to be designed the same, but function differently

    Deleting all variants and leaving just one page gives me a 38mb file. When I get back from town I'll try and figure out how to use dropbox.

  6. #6
    Join Date
    Feb 2007
    Location
    UK
    Posts
    19,817

    Default Re: Buttons: appear to be designed the same, but function differently

    limit for a XAR is 10Mb according to the forum upload help, as gary said

    only other forum file upload option is to zip - but a 38Mb file unlikely to compress that much, so dropbox or similar it is
    -------------------------------
    is it true that we stand on the very edge of an abyss?
    no,of couse not - we used to, but since then we have taken a great step forward...
    Wyrd bi ful ard

  7. #7
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,068

    Info Re: Buttons: appear to be designed the same, but function differently

    WEL, if you have used Auberge, the Button there is Embedded with the Text Box as is the image.
    If you have then made the image into a pop-up, you will probably have issues over the stacking position of it and the Button.

    To remedy:

    • Unhide the MouseOver layer.
    • Drag the button over of the Text Box's grasp - you can tell when you select the Text Box, the selection does not include the Button.
    • Do the same with the image.
    • Select the Button and Bring to Front (Ctrl+F).
    • Hide the Mouse layer.
    • Rearrange and Soft-group the Text Box, image and Button.
    • Test it is now working.

    Acorn
    Last edited by gwpriester; 06 January 2022 at 08:02 PM.
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  8. #8

    Default Re: Buttons: appear to be designed the same, but function differently

    Quote Originally Posted by Acorn View Post
    [*]Drag the button over of the Text Box's grasp
    Acorn
    Acorn---
    I'm struggling to understand how the noun "button" interacts with the double prepositions "over of", or, perhaps I'm misreading and it is a nominal phrase "button over"? (In which case I'm still struggling to picture what I'm supposed to do with the "button over".

    Let's just call it uber confusion on my part.

    Can you clarify the phrase? Sorry!



    (Still trying to figure out dropbox; having trouble uploading. Probably the satellite upload connection...)
    Last edited by WideEyedLife; 06 January 2022 at 08:48 PM. Reason: Added update on dropbox.

  9. #9

    Default Re: Buttons: appear to be designed the same, but function differently

    Okay, if I've done this correctly, here is a link to the page I am working on, as a .xar file.

    https://www.dropbox.com/s/loqgxr98rm...ePage.xar?dl=0

    (If I understand dropbox correctly, this link should only access the file I've shared, not my whole account.)



    A note about this webpage: I basically just cut and pasted a bunch of buttons as I was working, playing around with my design. And, several times in the beginning stages of playing around, I dragged various images away from their text boxes, before realizing that I had somehow unembedded them. Then I tried to embed them again (but never adding buttons to the embedding). So I have no idea what state of buttons/text/images being embedded together actually exists anymore. I DO know that the images on the lower half of the page NEVER had buttons embedded with them, though.

    Sighs. Looking at the layer view on the right doesn't really help me much, either, because I'm such a novice at using the webdesigner side of xara. (I'm hecka good at graphic design, though; so maybe I'll be quick on the uptake?)

  10. #10
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    15,068

    Default Re: Buttons: appear to be designed the same, but function differently

    Quote Originally Posted by WideEyedLife View Post
    Acorn---
    I'm struggling to understand how the noun "button" interacts with the double prepositions "over of", or, perhaps I'm misreading and it is a nominal phrase "button over"? (In which case I'm still struggling to picture what I'm supposed to do with the "button over".
    Let's just call it uber confusion on my part.
    Can you clarify the phrase? Sorry!
    (Still trying to figure out dropbox; having trouble uploading. Probably the satellite upload connection...)
    'of' was to have been 'off'.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •