Welcome to TalkGraphics.com
Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2014
    Posts
    4

    Default Placeholder Code selection problem

    The following are the lines I've added to the 'Header' section. This gets added to the program after I publish.

    <link rel="stylesheet" href="index_htm_files/responsive-carousel.css" media="screen"/>

    <script src="index_htm_files/jquery.js"></script>
    <script src="index_htm_files/responsive-carousel.js"></script>
    <script src="index_htm_files/responsive-carousel.autoinit.js"></script>

    The following are the lines I've added to 'Code' section. THIS DOES NOT show up in the program after I publish.


    I have NO idea why this isn't working. Please HELP!!!
    IP

  2. #2
    Join Date
    Aug 2000
    Location
    Placitas, New Mexico, USA
    Posts
    39,856

    Default Re: Placeholder Code selection problem

    Richard - I am moving this thread to the Xara Web Design Chat forum. Not sure why this is happening unless there is something else on the page like a slide show or something that might be causing a conflict.
    Gary W. Priester
    Mr. Moderator Emeritus Dude
    , Sir

    gwpriester.com | Custom-Stereograms.com | eyeTricks on Facebook





    IP

  3. #3
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    14,156

    Info Re: Placeholder Code selection problem

    OK, I think you are mistaking a reference for a presence.

    I have added your lines to a blank page.
    In Preview, the source code shows up:
    Code:
    <head>
    ...
    
    <link rel="stylesheet" href="index_htm_files/responsive-carousel.css" media="screen">
    
    
    <script src="index_htm_files/jquery.js"></script>
    <script src="index_htm_files/responsive-carousel.js"></script>
    <script src="index_htm_files/responsive-carousel.autoinit.js"></script>
    </head>
    Al these say are go to the index_htm_files folder and run the named files.
    If the files are not there, nothing will happen, other than a pile of Error Messages: Failed to load resource: the server responded with a status of 404 (Not Found).


    To fix this, the resource files need to be added into the folder.

    For jQuery, Xara used a special Name, UsesJQuery , added to an object explicitly.
    If anything on your page has a Web Animation, jQuery is also loaded.

    For the other files, you could add them into the index_htm_files folder after Preview/Export/Publish.
    This is clearly madness as you would need to do this each and every time.

    Xara has a method of adding external resources that works but I would never recommend it.
    Select any object on the page and press Shift+Ctrl+Alt+A and pick one of your required files.
    Repeat for all the resources.

    You can associate as many files as you like to as many objects you want.

    You use Shift+Ctrl+Alt+D to remove the associations on that object.
    If you have added more than one resource to an object, all will be removed.


    This is a cleaner method. I have covered its use elsewhere: https://www.talkgraphics.com/showthr...age-File-Types & https://www.talkgraphics.com/showthr...Support-Folder.

    • Save your design, say you named it Emma.xar [Assertion: Emma.xar created]
    • Create a blob.
    • Web Properties > Link > Link to file: pick a small unimportant file (say, Peel.txt) [Prerequisite: Peel.txt must exist]
    • Save again [Assertion: Emma.xar updated; Emma_xar_file folder created; Peel.txt copied into Emma_xar_files folder] - the Save is strictly not necessary but explaining why is a tad more difficult.
    • Open Emma_xar_files folder and add in all required resources.
    • Save.
    • On Preview/Export/Publish Website, all files in Emma_xar_files are copied into index_htm_files folder.
    • Optionally, delete blob from the design and Emma.txt from the folder. I keep mine handy to record design decisions.



    Acorn
    Last edited by Acorn; 13 September 2021 at 12:07 PM. Reason: tidy up
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/
    IP

  4. #4
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    14,156

    Default Re: Placeholder Code selection problem

    Richard, I am closing this Thread as it was really just for your problem.
    I hope, as you have not come back in a month, that it is fixed.

    A small request for the future. TGers give their time to assist and do so willingly. Without feedback of any kind, that assistance is less likely to be there the next time. Support TG and it supports you.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/
    IP

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •