Welcome to TalkGraphics.com
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Join Date
    Feb 2007
    Location
    UK
    Posts
    18,211

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    ok no problem, thanks
    -------------------------------
    carpe diem
    carpo vitae

  2. #12
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    12,420

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Quote Originally Posted by Initiostar View Post
    The issue is you cannot easily override the browser's own controls when videos are deployed on popup layers. You could with a purpose-designed video player, but for a couple of videos that's a lot of hard work.
    Here's an idea (borrowed from an Acorn concept) of a page within a placeholder: https://initiostar.co.uk/demo/VideoPopup/
    A 'video popup' really - works OK with Chrome & Edge, but I've yet to loose the scroll bars on Firefox.
    It may be help? Gary
    Gary, I was reluctant to advise using the source target approach when the video itself is to be on a pop-up layer, simply because I have not tried it out fully.

    In principle, it should work.

    Thank you for sharing.
    I do like the mix of image and video; I know you realise that the contents can actually be anything: carousel, slideshow, clickable content, ...

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  3. #13
    Join Date
    Sep 2020
    Posts
    8

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Hi

    Thanks all for the replies

    I did look at the Demo of the other player - but it's not opening the video on another layer which is what I'm trying to achieve due to the layout of the web page. I may try putting both videos on one layer and see if that makes a difference.

    But I will certainly look at using a different player....it's just annoying that one video always play fine yet the other has the issue mentioned on the video popup demo namely
    "The Challenge - where you place multiple videos across multiple popups, closing the popup may not close the video. This only becomes apparent when a video has audio. Unless you have deployed your own video player, the video can only be controlled by the browsers video controls which are not easily over-ridden. A simple page-based Video Popup is one solution. "

    Thanks again for the replies

  4. #14
    Join Date
    Apr 2018
    Location
    London
    Posts
    414

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Quote Originally Posted by AFreeSpirit67 View Post
    Hi

    Thanks all for the replies

    I did look at the Demo of the other player - but it's not opening the video on another layer which is what I'm trying to achieve due to the layout of the web page. I may try putting both videos on one layer and see if that makes a difference.

    But I will certainly look at using a different player....it's just annoying that one video always play fine yet the other has the issue mentioned on the video popup demo namely
    "The Challenge - where you place multiple videos across multiple popups, closing the popup may not close the video. This only becomes apparent when a video has audio. Unless you have deployed your own video player, the video can only be controlled by the browsers video controls which are not easily over-ridden. A simple page-based Video Popup is one solution. "

    Thanks again for the replies
    Here's an idea that may meet the requirement - an embedded subsite much like a video library is placed on a popup: https://initiostar.co.uk/demo/VideoSubSite/

    You can have as many videos as you like. Each video has a unique page url and therefore should you wish popup links can be subject-specific to their links, or all links can open the video library (which has its own navigation).

    The key to making this work is the return button on the popup; this must do a full page refresh (which this closes the popup and stops the video). The return should go to an anchor which means that what a user was reading is still visible after the page refresh.

    I've not perfected the solution, but it looks to have some promise as a workaround for trying unsuccessfully to pause a video WITH AUDIO on a popup when you close that popup. Upside no tricky code involved here!

    For reference: the earlier version had a permanent video holder on the target page: https://initiostar.co.uk/demo/VideoPopup/
    Last edited by Initiostar; 20 November 2020 at 10:14 PM. Reason: easy without audio

  5. #15
    Join Date
    Sep 2020
    Posts
    8

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Thanks for the reply

    However I have to say I have no idea what you are telling me! The link is text only, half in latin, and the section I can read flies right over my head! I know there is a hyperlink to the video player in the latin section but it does seem strange to have it buried in latin! I had a look at https://initiostar.co.uk and it doesn't seem to offer anything specifically to do with HTML video players or seems to offer something that can be used to help me with the issue so again I'm confused. What you have shown on the site is what I would like to have on my site . . But I need to know how!
    I'm a beginner when it comes to all of this, so so far the only bit I've understood is Acorn's advise on editing the html I had used on my site. Thanks to some of the other replies, I also understand that this is a bit of a known issue although I'm still confused how it works fine for 1 video but not the 2nd one!
    I had a look at github for HTML video players and there are what appears to be some good 3rd party alternatives...but again, I can't find any clear instructions that tells me how to actually "install" them and use them on a website. Its like if you're not part of the gang, you're never going to be in the know!

    I will keep looking for a 3rd party video player that I can use and works - when I do I'll share it here

    Thanks again for the replies
    Last edited by AFreeSpirit67; 21 November 2020 at 09:13 AM.

  6. #16
    Join Date
    Apr 2018
    Location
    London
    Posts
    414

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    OK - let me try to explain: forget the 'latin' - this is just example text known as 'Lorum Ipsum'. You can have a text link, graphic link, photo link or combination thereof (e.g. button) that forms a link to the popup.

    In the example I provided, I used a text link; it could have been a graphic, photo or button. Think of a website within a website; there is a second website on the popup which holds the videos and when the link opens that popup, what you see is the second website.

    I have attached both website files. The Embedded Subsite is the main website, the second website has the videos, one per page.

    Hopefully you can see how these are constructed - if you want to try this approach, I can try to help you through the process.

    I do think integrating a third-party video player for two videos will likely be time consuming and involve coding.
    Attached Files Attached Files

  7. #17
    Join Date
    Sep 2020
    Posts
    8

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    That is a very simple yet effective solution! Thank you!

    The two sample files make it easy to follow the logic behind the workings and as you say is a lot easier than trying to implement a 3rd party player.

    I'm playing around with sub site part for now . . . Not really sure why but the videos are using are hell bent on playing larger than I've set them to play at but hopefully I can figure it out. The placement is set to the video size and the html place holder is set to 100% yet it plays almost full screen. I've resized the video itself to 360 X 720 (or whatever 6:19 comes out at!) But still plays larger.

    Hopefully when I get the host page to match it'll all pull together!

    Thank you again for your help with this

    Stay Safe

  8. #18
    Join Date
    Apr 2018
    Location
    London
    Posts
    414

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Good news then! Should you get stuck just post an update/question here.

    Meantime, I have added some instructions which should better help explain the process: https://initiostar.co.uk/demo/VideoSubSite/

    Personally, I would build version one of your website with both videos on the page, get comfortable with how Xara works and then advance - it has taken me 10 years of playing with Xara and lots of help from TGers to arrive at some of these ideas.
    Last edited by Initiostar; 22 November 2020 at 10:44 AM.

  9. #19
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    12,420

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    I have just tried with an embedded video in Before and a YouTube video in After.

    For the Before link, I used popup: close "After" open "Before"
    For the After link, I used popup: close "Before" open "After"
    I added a close icon/button/text of popup: close "Before" "After"

    Clicking and playing any combination stopped the sound of one to allow the other.

    I did nothing to the videos other than drop them into their layers.
    The approach will work with as many videos in layer and layers that you can be bothered typing in.
    Also tried with autoplay and that fitted in nicely too but I had to fiddle with code to get the YT one started.

    Acorn
    Acorn - installed and active Xara software: Cloud+/Pro+, XDPX, XWD Premium 15 & 12, XPGD10, X3D7, Xara Xtreme 5, back through time (to CC's Artworks).
    Raise software faults with MagiXara: http://support.magix.net/; if Cloud+/Pro+: https://xara.com/contact-us/

  10. #20
    Join Date
    Dec 2006
    Location
    Melfort, Saskatchewan Canada
    Posts
    360

    Default Re: Xara Designer Pro X 17.1.0.60486 - Issue with Video playback

    Quote Originally Posted by AFreeSpirit67 View Post
    Hi
    I'm hoping that somebody can help with an website issue I have with playing MP3 videos on a layer

    So I have a website, need to do a Before and After videos to show the improvement made to sound proofing a hall
    I have 2 layers, "Before" and "After". I import the videos so they are cached into index_html_files. Then draw a rectangle to the size of the video, and in HTML Placement section I enter

    <video class="xar_meplayer" src="index_htm_files

    I don't think I'm trying to do anything difficult but I'm obviously doing something wrong but surely it shouldn't be this difficult to play videos on pop out layers.

    Any assistance appreciated and Thanks for your time
    It might be very helpful if you could post your website URL to see how you’re progressing. Many Thanks
    -Bill
    Bill Wood
    Expresiv Designs.
    Charity Web Design
    XARA Pro+. WD17, Designer 17. Premium packages.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •