Welcome to TalkGraphics.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    138

    Unhappy "undefined" in top left hand corner of my homepage?

    Hi, I am using WD15P and have had our website running for a few years but this "bug" has only just happened and I cannot find the reason. The website is located at www.adelaidevncma.com (now mainly in Vietnamese language). What happens, since 2 days ago, is that by going to the website, it produces a blank homepage with just one word in the top left hand corner - "undefined". I have searched everywhere (except where the answer is of course) and can only find vague references to possible malware, script error, or redirected links, etc. My engineer at my web hosting service has tried hard to help and has spent a long time searching our website also but has all but given up. I have tried many things, including a complete deletion of all website content, and then re-uploading the entire website afresh. I have most recently removed half of the website (the English language pages), with no effect. I have tried several other forums but can't see anything to help me. The actual content in the home page (the index.html file) does in fact reappear if the page is refreshed, however our members don't really know or expect that. I cannot see where this error is coming from, unless perhaps it is buried in xara's coding? After many hours of head scratching and sleepless night, I am pleading for some help please!

  2. #2
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1,217

    Default Re: "undefined" in top left hand corner of my homepage?

    The site is working fine for me. All seven pages render correctly and in a timely manner in both Edge and Firefox.

  3. #3
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    138

    Default Re: "undefined" in top left hand corner of my homepage?

    Quote Originally Posted by Chris M View Post
    The site is working fine for me. All seven pages render correctly and in a timely manner in both Edge and Firefox.
    Hi Chris, thanks for the feedback. So I just attempted again to log in (using the link in my post) and after a second or two, the page went blank with that word "undefined" yet again? I am also using Edge and Firefox incidentally. As far as I know, my boss (the local pastor) and others have the same problem as me, and also, the engineer from flexi-hostings had the same issue at his end too. (otherwise I would have to suspect my computer, however I have the same issue on both my laptops. This is most odd?? Can I borrow your fingers? But seriously this seems almost inexplicable I must say, hmmm (I have also cleared my browser cache I neglected to mention before). Is it possibly because I have not chosen to update my WD15 is perhaps my last idea, and at $AU94 it's very hard for me to justify that amount of money just for maintaining a not-for-profit charitable website - my only one. I have also lost several of my extras that were removed by Xara which I think is very unfair, especially as I have supported Xara for many years with various software purchase and at the beginning I wasn't aware they were time limited anyway. Anyway, that's my only thought left if that is possibly the reason???. Cheers

  4. #4
    Join Date
    Jun 2012
    Location
    CZECH
    Posts
    86

    Default Re: "undefined" in top left hand corner of my homepage?

    The site is working fine for me. All seven pages render correctly and in a timely manner in both Edge, Chrome and Firefox.
    ____________________________
    __I am sorry for my bad English__

    P&G 10, 11, 15; XWD Premium 11,15; XDPX 15.1; XDPX 18.5;

  5. #5
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    138

    Default Re: "undefined" in top left hand corner of my homepage?

    Thank you also Spamiky. Must be a reason, but I just can't see it, yet!

  6. #6
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1,217

    Default Re: "undefined" in top left hand corner of my homepage?

    Quote Originally Posted by rikkoshea View Post
    Is it possibly because I have not chosen to update my WD15?. Cheers
    No, nothing to do with it at all. I've just checked again, and apart from an SSL warning everything is looking good.

    Click image for larger version. 

Name:	Site.jpg 
Views:	39 
Size:	75.6 KB 
ID:	126768

  7. #7
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1,217

    Default Re: "undefined" in top left hand corner of my homepage?

    You have a Stat Counter somewhere on the page. My script blocker did it's job and blocked it...maybe try removing the script?

  8. #8
    Join Date
    Jan 2001
    Location
    East Sussex, England
    Posts
    2,021

    Default Re: "undefined" in top left hand corner of my homepage?

    Undefined happens in IE.
    Christine

    Software: XDPX9, WD9,WD10,XDPX10,WD11,XDPX11,XDP365

  9. #9
    Join Date
    Apr 2018
    Location
    London
    Posts
    650

    Default Re: "undefined" in top left hand corner of my homepage?

    The error you reported replicated here; the site loaded very briefly before a redirect took it elsewhere. F5 refreshed content correctly. Loaded the site again (from browser history) and the same redirect occurred.

    Click image for larger version. 

Name:	undefined.jpg 
Views:	41 
Size:	31.0 KB 
ID:	126769

    I have seen a similar issue related to CND; the problem was resolved by clearing the CDN cache. If you use CDN worth try.

  10. #10
    Join Date
    Oct 2009
    Location
    Australia
    Posts
    138

    Default Re: "undefined" in top left hand corner of my homepage?

    Hi, I have to thank all of you, Christine and InitioStar for showing me that I wasn't going crazy and reproducing my same problem. And Chris, I think you solved the problem, sorry no monetary reward or chocolates, but because the Stat counter had been there and working for so long, I forgot about it. After removing it, problem solved! (permanently I hope!!),
    So thanks again and have a happy Easter Day tomorrow,
    Cheers,
    Roger

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •