Welcome to TalkGraphics.com
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: Nag Screens

  1. #21

    Default Re: Nag Screens

    Quote Originally Posted by Acorn View Post
    So Chris has confirmed it is Magix adding code we didn't ask for or know what it is doing but regardless it isn't doing it the way it was expected.

    I had hoped the other Magix interference around the delay with "Adding colours to document" for v16.3 might have packed its bags, but sadly no.
    While the renaming of the offensive folder or .exe works for the new MagixTricks notInstaller thingy, blocking the proper address in the firewall makes my XP&GD start up in 3 seconds. No Adding Colors wait.

    Mike

  2. #22
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    10,977

    Default Re: Nag Screens

    Quote Originally Posted by mwenz View Post
    While the renaming of the offensive folder or .exe works for the new MagixTricks notInstaller thingy, blocking the proper address in the firewall makes my XP&GD start up in 3 seconds. No Adding Colors wait.
    Mike
    Mike, thank you.

    Also renaming C:\Program Files\Xara\Xara Designer Pro X\16\Online\ to C:\Program Files\Xara\Xara Designer Pro X\16\OnlineXXX\ works for Chris M and me.
    Again, this is another addition from Magix, AFAICT. This too lets me work after 3 seconds.

    The other folders added in after a clean install, which I assume are benign, are Fonts\, Languages\ and PamoramStudio\.

    @Magix - get your act together; software integration and internationalisation is a skillset you need to work on.

    Acorn
    Acorn - My currently active Xara software: XDPX (current, v15, v12 & 11 (64-bit)), unserviced XWD Premium 15 & 12, XPGD10, X3D7; lots of licences back through time (to CC's Artworks). If your Post identifies a Xara software fault, please raise it directly with Magix --> support2.magix.com.

  3. #23
    Join Date
    Jul 2019
    Location
    Isle of Wight
    Posts
    2

    Default Re: Nag Screens

    I'm getting the same problem. Sent email to Xara support. They suggested uninstall the program, delete the Xara directory from C:\Program Data. Which I did. I also deleted all reverence to Xara and Magix from the registry. Re-booted the computer, re-installed Xara Web designer from the link that was sent to me in the email. I was then asked to open the program as administrator which I did. The program then did an update to the latest patch. I then re-started the program and low and behold I get a message asking me to renew my update service, so nothing has changed.
    Just a thought though I recently updated to the latest version of Windows 10 Pro 1909 build 18363.592. Could this have anything to do with this?

  4. #24
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    10,977

    Default Re: Nag Screens

    Quote Originally Posted by Tib.63 View Post
    Just a thought though I recently updated to the latest version of Windows 10 Pro 1909 build 18363.592. Could this have anything to do with this?
    No.

    Acorn
    Acorn - My currently active Xara software: XDPX (current, v15, v12 & 11 (64-bit)), unserviced XWD Premium 15 & 12, XPGD10, X3D7; lots of licences back through time (to CC's Artworks). If your Post identifies a Xara software fault, please raise it directly with Magix --> support2.magix.com.

  5. #25
    Join Date
    Apr 2018
    Location
    London
    Posts
    169

    Default Re: Nag Screens

    @ Acorn: Thank you! for your workaround:
    renaming C:\Program Files\Xara\Xara Designer Pro X\16\ Online\ to C:\Program Files\Xara\Xara Designer Pro X\16\ OnlineXXX
    This resolves (for me) the very irritating v16.3 Adding colours.... 20 second delay on startup immediately, for both my clean install and update. No more start up delays and no more nag pop-ups. The original fault in the startup script, introduced by Magic in v16.3, was acknowledged by Rob as a BUG some months ago; let's trust it really is on the bug list to be fixed.

  6. #26
    Join Date
    May 2010
    Location
    Lam, Bavaria-Germany
    Posts
    456

    Default Re: Nag Screens

    The same here, within 3 sec. is my installation ready to work. Thanks Mike & Acorn for fidding it out.

  7. #27
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    803

    Default Re: Nag Screens

    For clarification: the UPS folder isn't present on a fresh install. I presume it appears when an update is performed.

  8. #28
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    10,977

    Default Re: Nag Screens

    Magix has put a lot of nasty little hooks into the installation folders.

    For the brave these are nestled in the *.cfg files. I have redirected my v15 out of Update Service cover onto a nicer place similar to what I have had to do for the PDF Manual.
    Currently, I point them to the OCC so I at least have a working Search capability; something Xara ripped out in its quest for Cloud supremacy / degeneracy.

    Acorn
    Acorn - My currently active Xara software: XDPX (current, v15, v12 & 11 (64-bit)), unserviced XWD Premium 15 & 12, XPGD10, X3D7; lots of licences back through time (to CC's Artworks). If your Post identifies a Xara software fault, please raise it directly with Magix --> support2.magix.com.

  9. #29
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    803

    Default Re: Nag Screens

    Another point worth raising. Renaming the 'Online' folder stops Help > Check for Updates from working. Simply renaming back to default makes it work again.

  10. #30
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    10,977

    Default Re: Nag Screens

    Quote Originally Posted by Chris M View Post
    Another point worth raising. Renaming the 'Online' folder stops Help > Check for Updates from working. Simply renaming back to default makes it work again.
    Thank you for advising this.

    Not a big worry through. You could set your calendar reminder for the end of March to do this and you might be lucky.
    Six weeks clear of nagging to the chance of missing a possible update.

    I would recommend doing it a month before your Update Service expiry.
    I know of no simple check for the expiry date other than logging into https://www.magix.com/gb/support/my-service-center/.
    The actual page you are after is a link Show more details. This one is useful as it allow you to bypass the first page and possibly copy your Serial Number (e.g., https://ap.magix.com/servicecenter/i...evices&serial=P3-...).
    There is a further snippet; Last activated on lets you see when Magix last snooped on you.

    The main point is we are getting closer to a position where those who do not want to update can block the nags and work in peace.

    Acorn
    Last edited by Acorn; 09 February 2020 at 02:02 PM.
    Acorn - My currently active Xara software: XDPX (current, v15, v12 & 11 (64-bit)), unserviced XWD Premium 15 & 12, XPGD10, X3D7; lots of licences back through time (to CC's Artworks). If your Post identifies a Xara software fault, please raise it directly with Magix --> support2.magix.com.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •