Welcome to TalkGraphics.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Join Date
    Mar 2019
    Posts
    15

    Default HTML Placeholder after add Web Animation to any object

    Hi guys,

    sorry if this thread was created before, but i cant find it anywhere.
    I add to Xara Web Designer Premium HTML Placeholder (countdown timer)
    It works perfect. But when i add any web animation to any object, countdown timer start count not after each second, but after 2 seconds...
    Can someone help me, where could be the problem?

    Peter

  2. #2
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,490

    Default Re: HTML Placeholder after add Web Animation to any object

    Quote Originally Posted by Kraucik View Post
    Hi guys,
    sorry if this thread was created before, but i cant find it anywhere.
    I add to Xara Web Designer Premium HTML Placeholder (countdown timer)
    It works perfect. But when i add any web animation to any object, countdown timer start count not after each second, but after 2 seconds...
    Can someone help me, where could be the problem?
    Peter
    Peter, no we cannot help without seeing your design file.

    Acorn
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

  3. #3
    Join Date
    Mar 2019
    Posts
    15

    Default Re: HTML Placeholder after add Web Animation to any object

    Count.txt

    There is a count file. If i save it like count.html it works fine after open it.

  4. #4
    Join Date
    Mar 2019
    Posts
    15

    Default Re: HTML Placeholder after add Web Animation to any object

    There is a example project. When you open it, try open in website. Countdown count each 2 seconds.
    When you go on the purple picture, right click -> Web Animation and you delete animation (Parallax) , countdown start count every 1 second.. And thats it...
    I dont know, why..
    Attached Files Attached Files

  5. #5
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,490

    Info Re: HTML Placeholder after add Web Animation to any object

    Karucik, you are forcing two additional BODY tags into an HTML page that already has one.

    Because of that, you are calling function getSeconds() twice.

    The code you supplied also included a jQuery call to invoke function getSeconds().
    This is better replace with:
    Code:
    <script>window.onload = function () {
        getSeconds();
    }
    </script>
    I have parsed out your code away from the display HTML so you have a Placeholder with the JS/CSS in its Head and the web display in its Body.
    I removed the need for jQuery.

    JSCSS-Countdown Timer.xar

    Acorn

    P.S. You would be better adding extra variables for the HH:MM:SS part of this statement:
    var countertime = new Date(nowDate.getFullYear(),nowDate.getMonth(),nowD ate.getDate(),15,36,40);
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

  6. #6
    Join Date
    Mar 2019
    Posts
    15

    Default Re: HTML Placeholder after add Web Animation to any object

    Thanx a lot Acorn!! It solved my problem... When i had any problem, can i write a pm?

  7. #7
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,490

    Default Re: HTML Placeholder after add Web Animation to any object

    Quote Originally Posted by Kraucik View Post
    Thanx a lot Acorn!! It solved my problem... When i had any problem, can i write a pm?
    PM capability is permitted after around 10-20 Posts from you.

    In the meantime, raise a problem Thread. That way all TGers get to benefit and contribute.

    Acorn
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

  8. #8
    Join Date
    Mar 2019
    Posts
    15

    Default Re: HTML Placeholder after add Web Animation to any object

    OK Thank you again.

    Now i have some new problem. I just need create mouseover effect. When mouse over text i need move text to the right, and show arrow. Like this

    Contact

    (mouse over)

    >Contact

  9. #9
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,490

    Default Re: HTML Placeholder after add Web Animation to any object

    Quote Originally Posted by Kraucik View Post
    OK Thank you again.
    Now i have some new problem. I just need create mouseover effect. When mouse over text i need move text to the right, and show arrow. Like this
    Contact
    (mouse over)
    >Contact
    Kraucik, normally, I would suggest you create text over a white box and repeat the same on the MouseOver layer and just add the ">" Then you could soft-group both sets and add a hyperlink.
    My preference is to use CSS.

    I have four examples here: CSS - How to Contact.xar.

    The first is a FAIL as the MouseOff text is overlain and not hidden.
    Second & third use a White Text Background or, messily, White boxes.
    The fourth uses a pseudo-class - before - on a hover event. This last one does not require a hyperlink.

    Acorn

    P.S. New problem --> new Thread.
    Things get lost otherwise.
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

  10. #10
    Join Date
    Mar 2019
    Posts
    15

    Default Re: HTML Placeholder after add Web Animation to any object

    THank you. Yes, fourth uses is the best for me, but it doesnt have hyperlink :/

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •