Welcome to TalkGraphics.com
Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2018
    Posts
    2

    Default Trouble with Navbar Submenu

    Hi

    I've just purchased Xara Web Designer Premium. For a long time I've been looking for a similar program, and so far I like it.

    It seems that there is one thing I can't get as I want to have ir.

    I have a Navbar, to which I added submenus.

    I'm from Sweden and use the swedish language in the menu/submenus. Therefore I have in the text. In the top level it's ok, but in the submenus it's only a space where these letters ought to be ( gave the same result).

    I have the same font at all levels in the menu (Trebuchet).

    Maybe I've done something wrong?

    Thanks
    Stefan

  2. #2
    Join Date
    Aug 2000
    Location
    Placitas, New Mexico, USA
    Posts
    36,191

    Default Re: Trouble with Navbar Submenu

    Welcome to TalkGraphics

    The space indicates the character either does not exist in the font or that it is not mapping correctly (there are some areas for improvement in Xara's sub-menus).

    Try some of the other fonts and see if they support these characters. Or maybe use Character Map or a similar utility to find the appropriate character and copy and paste and see if this works.

    The other option is to create your own sub menus on separate layers that you can create in the page and layer gallery. Each new pop-up layer can contain buttons and a mouse over state and you should be able to use your characters correctly.
    Gary W. Priester
    Mr. Moderator Emeritus Dude
    , Sir

    gwpriester.com | Custom-Stereograms.com | eyeTricks on Facebook






  3. #3
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,095

    Info Re: Trouble with Navbar Submenu

    Stefan, welcome to TalkGraphics.

    I am sure you have done the right things; you must ensure you click OK for all changes when working on NavBars.

    Trebuchet MS is installed on my PC and the attached Trebuchet NavBar.xar renders in all major browsers including Safari.

    Things to do:
    1. Check you have Trebucket MS installed as a font
    2. Run the program once as Administrator
    3. Check you are saving each change correctly
    4. Check your keyboard region and language setting is Sweden
    5. In the Xara Spell-checker, ensure the document Language is Swedish
    6. Use a Unicode Character Mapping tool like Babelmap as a safety net

    Acorn
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

  4. #4
    Join Date
    Dec 2018
    Posts
    2

    Default Re: Trouble with Navbar Submenu

    After some testing:
    - Trebuchet is installed as a font (I use it often)
    - Tried to change font (Navigation Bar Properties -> Pop-up menu style... -> Font). Checked three different fonts, all of them OK.
    - Writing Swedish with Trebuchet on other places is OK. Even in the Navbars top level. It is only in the submenu the problem occur

    Something is wrong with the combination Trebuchet, ... & Navbar submenu.

    Maybe I can fix it in the html-code (will check that later).

    But for the moment I'll ignore it, I know it can be fixed by changing font (but I want to have Trebuchet).

    Thank you for quick response!!!

    Stefan J

  5. #5
    Join Date
    Apr 2012
    Location
    SW England
    Posts
    9,095

    Question Re: Trouble with Navbar Submenu

    Stefan, did you miss the example XAR file I created (https://www.talkgraphics.com/attachm...d=1546095254)?
    Does it display your acceneted characters in Trebuchet correctly?

    Acorn
    Acorn - My currently active Xara software: occasionally serviced XDPX, purposely unserviced XDPX12 & XDPX11 (32/64-bit), unserviced XWD Premium 15 & 12, XPGD10, X3D7 and lots of 'permanently-owned' licences back through time (to CC's Artworks)

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •