Welcome to TalkGraphics.com
Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22
  1. #21
    Join Date
    Aug 2000
    Location
    Placitas, New Mexico, USA
    Posts
    38,665

    Default Re: Changing a Xara website to secure SSL (https)

    Welcome to TalkGraphics blueknight

    This is a pretty old thread. I suggest you start a new thread with this question in the Xara Web Design Chat forum.
    Gary W. Priester
    Mr. Moderator Emeritus Dude
    , Sir

    gwpriester.com | Custom-Stereograms.com | eyeTricks on Facebook






  2. #22
    Join Date
    Nov 2020
    Posts
    2

    Default Re: Changing a Xara website to secure SSL (https)

    Quote Originally Posted by blueknight View Post
    This is invaluable, thank you.

    I followed all of your steps and it appears to work. However, I am now experiencing problems with the display of my website in http vs https. It is created in Xara DP (I have the latest version) and hosted by one.com. It has over 500 pages and a lot of content. In https, while the images are presented correctly, the fonts and font sizes are not and some text is invisible until highlighted. The same problem manifests in multiple browsers. The only way around it was to install a temporary .htaccess file that redirects everything back to http, which is far from ideal. All I can think is that something in the SSL is interfering with the linkages in the styles or fonts somehow. I am hoping that someone will be prepared to jump in with a suggestion for a fix. Thanks in advance.
    No need to reply, I found the fix. The problem was that I had constructed the website from two different Xara website documents with two sets of content folders. This created a referencing issue in https that was never a problem in http. I got around the problem by moving the limited contents of one of my Xara website documents across into the other (now working from a single document). I will retain this post here in case someone else is adventurous enough to be constructing a single website from multiple Xara documents and trying to navigate SSL/https.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •