Welcome to TalkGraphics.com
Results 1 to 7 of 7
  1. #1
    Join Date
    Sep 2005
    Location
    London, England
    Posts
    504

    Default Video in popup layer problem

    I have been trying to embed Youtube videos in popup layers on my events website. The idea being that they autoplay when somebody clicks the relevant link. The trouble is they all autoplay when the main page loads.

    Has anybody found a way? Also there a number of these so conceivably someone could close one popup and open another, so the previous video definitely needs to stop playing when the popup is closed.

  2. #2
    Join Date
    Aug 2000
    Location
    Harwich, Essex, England
    Posts
    18,406

    Default Re: Video in popup layer problem

    Here's an excellent video loader created by Siran.
    Attached Files Attached Files
    Egg

    Intel i7 - 4790K Quad Core + 16GB Ram + 232 GB SSD
    Xara Designer Pro X 16

  3. #3
    Join Date
    Sep 2005
    Location
    London, England
    Posts
    504

    Default Re: Video in popup layer problem

    Thanks Egg. Although correct me if I'm wrong, but this seems to play any video selected in a placeholder on the page. I'm trying to create popups with videos in them set to autoplay. The problem is that although the popups aren't visible when the main page loads they all start playing anyway.

    You can see the video links on the righthand side at www.smoothjazzevents.co.uk

    I currently have them opening the youtube page in another tab, but would have preferred the video to play in a popup.

  4. #4
    Join Date
    Aug 2007
    Location
    Maghull UK
    Posts
    6,202

    Default Re: Video in popup layer problem

    I remember [sort of!] this coming up yonks ago and the solution is to place the video on on it's own page and use the iframe tag (embed website widget) for the popup.
    JOHN -XaReg (FB) XaReg (DB - ignore prompt to register)
    Windows 10 [Anniversary] pro Intel Pentium CPU G630 @ 2.70Ghz RAM: 4 GB; 64-bit x64

  5. #5
    Join Date
    Sep 2005
    Location
    London, England
    Posts
    504

    Default Re: Video in popup layer problem

    Thanks John. I'll give that a try, although I already had the embedded video in an iframe, so I would have the thought that the autoplay thing would have worked the same way. Or does the embed website widget get around that?

  6. #6
    Join Date
    Aug 2007
    Location
    Maghull UK
    Posts
    6,202

    Default Re: Video in popup layer problem

    Quote Originally Posted by Jimi King View Post
    Thanks John. I'll give that a try, although I already had the embedded video in an iframe, so I would have the thought that the autoplay thing would have worked the same way. Or does the embed website widget get around that?
    It used to ... v15 seems to have changed a fair bit though
    JOHN -XaReg (FB) XaReg (DB - ignore prompt to register)
    Windows 10 [Anniversary] pro Intel Pentium CPU G630 @ 2.70Ghz RAM: 4 GB; 64-bit x64

  7. #7
    Join Date
    Aug 2000
    Location
    Harwich, Essex, England
    Posts
    18,406

    Default Re: Video in popup layer problem

    Although correct me if I'm wrong, but this seems to play any video selected in a placeholder on the page. I'm trying to create popups with videos in them set to autoplay.
    Which is exactly what Siran's file does. Did you preview it? If you just place a video in a pop-up layer & set it to autoplay all the videos in all the popup layers may load & start playing. Often closing the pop-up doesn't stop the audio.

    In preview it gives a scrolling thumbnail of available videos, click on one and it auto-loads and auto-plays. Click on another and it closes the previous video and auto-plays the new one.

    What's even better is that the videos aren't downloaded until the thumbnail is triggered.

    I tried making an example using your videos but unfortunately they're not set to enable in an iframe.
    Egg

    Intel i7 - 4790K Quad Core + 16GB Ram + 232 GB SSD
    Xara Designer Pro X 16

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •