Welcome to TalkGraphics.com
Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2000
    Location
    Skdstrup, Denmark
    Posts
    251

    Default XXP4: Bad utf-8 char handling in XPS import

    Hi,

    I am very pleased about the new XXP4! But never the less I wish to put some attention on the import of XPS documents (which will probertly be a big thing in future, as big as PDF).

    When importing a document containing som UTF-8 chars it does not work. I have enclosed a simple example to illustrate. It should render some danish special chars: , but does not.
    Attached Files Attached Files
    Cheers,

    Sten
    "Everything has two sides"

  2. #2
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,208

    Default Re: XXP4: Bad utf-8 char handling in XPS import

    Hi Sten,

    I can confirm that the characters shown in XXP4 are not those shown when the file is opened using the Microsoft XPS viewer.
    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

  3. #3
    Join Date
    Jul 2004
    Posts
    24

    Default Re: XXP4: Bad utf-8 char handling in XPS import

    I've just imported an XPS but Xara displays the text with no spaces between the words!

  4. #4
    Join Date
    Jun 2002
    Location
    Dunoon, Scotland
    Posts
    4,778

    Default Re: XXP4: Bad utf-8 char handling in XPS import

    See no problems with your file it displays text which is editable. Cam open it in Acro, Dreamweaver and XPro and options for a few other programmes but did not test. Also I think I am under powered memory wise at the moment even for Xara products.
    Design is thinking made visual.

  5. #5
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,208

    Default Re: XXP4: Bad utf-8 char handling in XPS import

    It has been a year since Sten posted his zip file. Extracting the file today and opening it in .xps viewer and Xtreme 4.0 I see the same text in both programs. The July 2008 patch corrected the problem I saw in April of 2008.

    Xarb are you running the latest version of Xtreme 4.0.1.5601 CD (Xara) Jul 4 2008?
    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

  6. #6
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,208

    Default Re: XXP4: Bad utf-8 char handling in XPS import

    I tested importing an xps file downloaded from the internet.

    It displays well in the MS .xps viewer plugin for IE. However there is some misplacement of text when imported into Xtreme 4.0.1.5601.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	xpsviewer-xps.gif 
Views:	113 
Size:	82.2 KB 
ID:	59803   Click image for larger version. 

Name:	xx4-xps-import.gif 
Views:	111 
Size:	69.6 KB 
ID:	59804  

    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •