Xara Designer Pro 6 & Photo & Graphic Designer 6 

This is a summary of new features in Xara Designer Pro and Photo & Graphic Designer v6 and includes some use instructions. All features are in both unless it is clearly indicated as Pro only.

This document is best viewed in 'fixed page width' mode in Google Docs. nb links may not work in IE 8 (if not, try right click on the link > Go To). We would recommend upgrading to any of the following browsers: 

 Firefox 

 Google Chrome 

 Apple Safari 

 Opera 

  

Other really useful information about V6: 

Gary Priester's preview of V6 on The Xara Xone 

A V6 intro movie by Xara Xhris on YouTube 
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Web Improvements 

Plus, all the new features and templates of Web Designer 6 are also included in Xara Designer Pro 6 (but not Photo & Graphic Designer). Details of these new web features are shown at the bottom of this document here.


Xara Xtreme / Xara Xtreme Pro 

The relationship between and name of both these products is changing. Xara Xtreme will not get most of the recent Web Designer enhancements listed at the end of this document. 

Xara Xtreme will now be called 'Xara Photo & Graphic Designer 6' (a longer, but deliberately more descriptive name). The new name should make it clearer that this is intended to be a general purpose graphic, drawing, photo, and document creation tool, but with basic website creation facilities only (it still remains an outstanding web graphics tool of course). 

Xara Designer Pro 6 is the flagship, top end, all-encompassing tool that includes all features of the latest Web Designer and Photo & Graphic Designer, along with a number of additional features that are more suited to a professional designer (more advanced drawing tools, CMYK support, higher performance, etc). 

New Features in V6 

Appearance and New UI Features 

· Totally re-designed application appearance (skin and icons) 
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· Fly-out tools and buttons present a simpler UI, but with direct one-click access to a wider range of common functions. 

· Many buttons now have a fly-out menu of related options. Such buttons are marked with a small white triangle in their corner. Hovering the mouse over such buttons will, after a very short delay, show the options. These buttons have been carefully designed so that you can still get to the main function with a single click of the button, but also very quickly access any of the additional options without any extra clicks. 

         [image: image2.jpg]


 

For example this is the 'Preview Website' icon with its fly-out showing the two options 'Preview current page' and 'Preview whole website'. (This is only available in Designer Pro 6 and Web Designer 6) clicking the main button (shown under the pointer above) will perform the 'Preview current page' function. To select the 'Preview website' option just move over the main icon, wait a fraction for the fly-out to appear and then select the second item. 

Some of the main tool icons have a similar fly-out, for example the Photo tool 
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providing quick, direct 'no extra click' access to related functions, and tools. 

· If you want any of the tools on the fly-out to appear as main tools, hold the Alt key and drag the tool from the fly-out to the main toolbar. 

  

Heirarchical Designs Gallery. A hierarchical arrangement of the Designs Gallery makes it far easier to find the template you're looking for at a glance. 
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Photo Features 

In keeping with the vector, object orientated nature of Xara Designer products, all the photo enhancement features remain vector based, fully editable and non-destructive - a world away from the destructive 'bitmap based' approach of the majority of mainstream photo editing tools.


Content Aware Scaling Tool 

This has been enhanced with some innovative new 'intelligent scaling' features. While this can operate on any resolution image, for performance reasons you are recommended to use reduced resolution photos (just say 'Import Reduced' when asked the question when importing photos). The Content Aware scaling is multi-processor aware and so the more processor cores you have the faster it is. 


Content-aware photo zoom. An alternative to content aware scaling (CAS) whereby the photo remains the same size and the content is intelligently zoomed inside it. There is now a new zoom slider on the Infobar to control this. Here's an example of the effect. 
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The picture remains the same size, but the program automatically detects and scales (zooms) the 'interesting' content. Note this is not just a crop of the girl, but that every element, cloud and grass, that appears in the original is still there in the zoomed version. The program automatically detects the girl is the 'region of interest' and so enlarges her only.

Another example: 
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The program has determined the flowers, not the background leaves, are the areas of interest and so scaled only those parts.  Using the Mask feature you can protect any part of the picture from distortion, although these two above examples use no mask.



Alternative 'Content Aware Scale'
When stretching photos there is now two alternative ways to scale the image.  The existing method of just dragging the size arrows works as before, but is not so good with some image types.
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For example converting the above portrait picture to landscape by using the existing content-aware stretch does not work well. The buildings look too distorted on the right stretched case.

However by holding the Alt key when dragging one of the side handles in the content-aware scale tool now performs a different intelligent scale using an alternative algorithm.
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The same image using the alternative content-aware scale produces perfect results in this case.  


Single prepare button for CAS and CAZ
We have improved the Prepare time and combined the two previous H and V buttons into one.


Clone Tool 
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This is an entirely new tool (on the Photo tool fly-out) to make it easier to 'erase' regions of photos by copying (cloning) parts of a photo from one place to another, even from one photo to another. 


In the Clone tool you can just draw a freehand line around the area you want to erase, it is shown as a 'marching ants' dotted outline. Now just drag anywhere on the photo outside the clone area to pick the new source for this area. 
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Here I am going to erase a flower from the center of this image.  So I select the Clone tool and draw around the center flower. 
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Here you can see the outline I have drawn around the center flower. It doesn't need to be accurate and should usually be slightly larger than the area you want to erase.


When you've drawn around the required area, it is shown with a dotted outline and with 8 re-size handles around the selected area. This is known as the 'clone shape'.
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I now click and drag anywhere on the photo outside the clone shape, and it will copy from that part of the photo into the clone shape area.  In this case I selected a point above the shape.  An arrow is shown indicating the source point of the clone fill.


The 8 re-size handles around the clone shape can be dragged to enlarge or reduce the size of the clone shape. 

There is a feather slider on the Clone tool Infobar which allows you to blend the edge of the clone. By default clone shapes have a slight 3 pixel feather. 
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The above example, at a glance, looks good, but the stalk of the missing flower is still visible. But this can be erased using the same technique to create a few more clone shapes. 

The result is a near perfect missing flower. 












Clone Tool Infobar [image: image14.png]2| Resize Smosthing 5%





In order the controls are:


Outlines on or off 

With outlines on all clone shapes on the selected photo are shown with a dotted outline. The current or selected clone shape is shown with an animated 'marching ants' outline, resize handles and an arrow pointing from the source point. 

Size slider 

This allows the clone shape to be enlarged or reduced. This is particularly useful if you use a larger feather value (which blends the edge of the clone shape inwards) in that you can compensate by enlarging the clone shape. 

Freehand Smoothing
After you've drawn your freehand clone shape, you can adjust the smoothness of the line. This is exactly equivalent to the Freehand tool smoothness control. This is only active immediately after you've drawn the clone shape. If you edit the clone outline using the other tools such as the Shape Editor, this control become disabled. 


Feather Control 

This pop-up slider adjusts the blending of the edges of the selected clone shape. It replicates the main Feather tool. 

Clone Tool Operation Summary 

To erase a part of a photo, select the Clone tool [image: image15.png]


 and draw around the area you want to erase. Then drag outside this area to set the source point for the copy. You can adjust the feather and size of the clone shape. 

· You can switch on or off visible outlines for the clone shapes with this icon [image: image16.png]


 on the Clone tool Infobar. 

· A click on a clone shape will select it. The selected clone shape is shown with an animated dotted outline (assuming outlines are on using the above control), 8 resize handles and an arrow indicating the source point of the clones area. 

· You can push the contents of the selected clone by dragging on the clone shape. This is an alternative method of adjusting the fill position or fill source point. 

· When setting the source point of a clone shape, if you drag over another photo you can copy regions of one photo onto another. 

· Dragging on the 8 resize handles around the shape will enlarge or reduce the clone shape size, or use the resize slider on the Infobar. 

· Dragging the feather slider control on the Infobar, or the main feather control on the top bar, will adjust the edge blend. 

· You can delete a clone shape by selecting it and pressing the Delete key. 

· The clone copy will always be of the original base photo, and will ignore any clone or enhance edits you may have performed on this photo. 

· Clicking on the background photo will de-select all clone shapes so allowing you to draw a new clone shape if required. 

· Clone shapes are normal vector editable shapes, and once selected you can switch into any of the normal line or shape editing tools to make further adjustments of the outline. 

· A photo with clone edits is stored as a new 'Photo Group' structure. This acts like a normal photo for many purposes (you can resize it, rotate it, enhance it etc, and it will act as a single photo object). But using 'select inside' (Ctrl+click) or using the Page & Layer Gallery to view the group structure, you can select and edit the individual clone objects within the Photo Group. 

Photo Enhance [image: image17.png]


 

Using the main Photo tool you can perform a wide range of classic photo enhancements on the whole photo using the Infobar controls (brightness, contrast, saturation, warm/cool color temperature, blur/sharpen, levels). 

You can perform selective enhancements using the Mask feature, to adjust any part or region of a photo. Such photo edits now create a new 'Photo Group' object (see below), which acts like a normal photo for most purposes, but is also a Group that contains all the individual edits as overlaid vector objects. 

For example, to adjust the brightness of a region of a photo, first select the photo, turn on the mask by clicking the [image: image18.png]


 icon (now below the main tools), and draw around the area of interest (The Freehand tool is selected when you enter the mask mode).  Now switch into the Photo tool and adjust any of the enhance sliders and adjust as required. This creates a shape with a new type of 'enhance' transparency that is now part of the Photo Group. 

You can adjust the blend (strength) of the effect by using the Transparency tool.  By creating a graduated transparency (drag across the new shape in the Transparency tool) you can create a faded enhance effect.  The Feather slider (right end of the top tool bar) can be used to create soft edges to your enhanced region. 

You can create any number of successive enhance areas, one on top of another, using the same technique.  This provides a very powerful method of adjusting the brightness, contrast, levels, color saturation and even selecting blur and sharpen, of areas of photos, but in a fully editable, non-destructive, reversible manner. 

Such edited photo are referred to on the Status Line as a Photo Group. 

Photo Groups 

When you use the Clone tool, Red-eye tool, or perform a photo enhance operation on a selected part of a photo using the Mask feature, this creates a special type of Group Object called a Photo Group.


You can disassemble a Photo Group into its constituent objects by using the normal Ungroup function (Ctrl+U). 

You can select the 'edit shapes' that are inside the group by using the normal Select Inside (Ctrl click) or using the Page & layer gallery to view and select the items within a Photo Group. 

You can 'flatten' a Photo Group to become a normal JPEG by selecting the Photo Group and the menu Utilities -> Optimize Photo... 

Sometimes a Photo Group will be called a Clipped Photo Group, in this case the Photo Group is contained inside a Clipview object. 
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In the Photo tool fly-out is an EXIF dialog which shows the embedded EXIF values of a JPEG photo. This dialog is mostly transparent (so it doesn't get in the way too much). By clicking the small down arrow on its title bar you can configure which actual EXIF values are shown and how transparent the dialog is.


EXIF data is now preserved on export of JPEG photos and across an Optimize Photo operation. 

Auto-downsizing of Imported Photos 

Most modern digital cameras produce very high resolution images, that are typically unnecessarily large.  These take a lot of memory and can produce very large files.  For example importing a typical 5 MByte digital camera image will add 5 MBytes to any saved .xar file. So importing 10 such images into a document could easily add 50 Mbytes to the file size. 

(Xara Designer embeds the original unmodified JPEG into any saved .xar or .web file. This saves considerable file space compared with storing the expanded uncompressed photo data as other programs do.) 


When you import a photo, using drag 'n' drop from your File Explorer, or using File->Import, the program offers you the option to reduce the resolution. 
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If you select to have images reduced they are created at 1920 pixels wide (same as TV HD resolution) which is typically good enough for any screen and most print work.  Selecting the 'Don't ask again' check-box will prevent this alert appearing again during the current session, and it will always do whichever option you choose from that point on. 

Importing reduced size images will reduce the memory consumption down to about 300Kbytes on average per picture. 

Tip: There's a new option in the Help menu to reset these Alert dialogs so they can be made to appear again. 

Photo Optimize Dialog Simplified 
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This is used to reduce the resolution of images, or to convert from a raw BMP or PNG format into a more compact JPEG format.


You can enter the required pixel size of the image, or resolution in pixel per inch (ppi). Note that this does not change the size of the image on the page, only the number of pixels and thus the resolution. 

Note: the default quality for JPEG is usually 75. There is little quality to be gained by going higher than around 85, and it only produces much larger files. 

Optimize All JPEGs 

A new menu option, Utilities -> Optimize all JPEGs is a quick way to reduce the file size of documents containing many JPEG photos, if they weren't optimised on import. 
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When you import a photo (either using File->Import or by drag n drop from File Explorer) Xara Designer Pro can embed the original, full resolution JPEG.  This still saves a huge amount of memory and file space compared to other graphics programs that typically convert the JPEG into a raw format.  But if you use a lot of photos, this can still add up to a considerable amount of file space. For example embedding 10 photos from a typical modern digital camera might easily take 50Mbytes (5Mbytes each). Almost always these images are far higher resolution than needed for print, screen or web work. 

The dialog very similar to the Optimize JPEG one, but applies the settings to all images in a document. 

Perspective Correction Tool [image: image23.png]


 

This is a new tool available on the Photo tool fly-out.  It's designed to be a simple one-click way to automatically correct common perspective effects. 
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The image on the left, taken inside a very large Basilica building in Rome, shows the common perspective effects of photos taken with a camera close to the ground.  To get a 'straight on' photo would require it to be taken from a height of probably 30 feet. The perspective correction tool can create a similar effect automatically (right example). 

Simply select the photo, and then the Perspective Correction tool.  The process can take some time, depending on the resolution of the image. 

Tip:  The resulting corrected photo is in a raw BMP format which can take a lot of memory and so you are recommended to optimize your photo to be a JPEG format to reduce the memory and file size. Select the menu Utilities -> Optimize Photo... 

Advanced users:  This utility provides no user interface or controls.  However there is a stand-alone program that does provide more control over the perspective correction parameters.  This program is available from inside the installed files folder of Designer. 

C:\Program Files\Xara\Xara Designer Pro 6\ShiftN 

Photo Editing Workflow 

When working with photos, Xara Designer Pro can work in a 'JPEG workflow' manner. That is you can open a JPEG photo, work on it using the various photo and vector tools, and save the resulting JPEG by just pressing the Save icon or selecting the Save menu. 

In this case the program also saves another file alongside the JPEG, in a folder called 'masters' which is the master .xar file containing all the edits and the original untouched JPEG image. 

When opening a JPEG photo, Xara Designer Pro checks to see if there is a corresponding master file and opens that instead of the JPEG. 

This provides a number of significant benefits: 

· Simplicity: You can just open a JPEG, edit it, and click Save to get an edited JPEG saved back in its place.   

· The original master 'negative' JPEG is retained and can be recovered or restored at any time. 

· Lossless editing cycle. You can open and save a JPEG any number of times, but instead of going through a lossy un-compress / re-compress cycle (which would badly distort the image after a few cycles), the program keeps working on the master file containing the untouched original JPEG image. 

· You can open an edited JPEG file, and remove or undo the edits you've performed on the image. This means you can do 'magic' like opening a cropped JPEG and undo the crop and recover the missing parts of the image.  Or undo or remove any edit, including any enhance operation, object erase using the clone tool etc. 

Resize Photo to be 1:1 (100%) 

Photos in Xara Designer can be placed on the page at any size.  Unlike destructive programs such as Photoshop where resizing an image permanently alters that image, doing this in Designer retains the original image and just changes the resolution to fit the required size on the page. 

So, for example, if you halve the size of a photo on the page, its resolution (pixels per inch) is doubled. This means all resize operations are lossless, non-destructive, and resizing an image back up will result in a sharp non-blurred image again. 

Sometimes it's useful however to have a 1:1 mapping between image pixels and screen pixels, so you know at 100% zoom that you are seeing the full resolution, non-scaled image. 


In the Photo tool on the Infobar there is a new icon [image: image25.png]


 which will resize the image back to be 1:1 at 100% zoom. In other words 96dpi - the same resolution as the screen. 
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Outline Trace Assist 

In the Freehand tool, there is a new option on the Infobar [image: image27.png]


 which can assist in drawing of vector lines around the outline of high-contrast shapes or objects in photos.  To use this when drawing lines over bitmaps, just select this option, and then draw around the edge (normally just inside the edge) of the shape, and the program will analyse the underlying image and draw the line along the edge. 

This only works with objects that have a high contrast between the foreground and background. It will usually be necessary to use the Shape Editor to adjust the line positions.  

You can turn tracing on and off while drawing, by pressing the T key. 
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Brightness Curves 
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In the Levels dialog you can create a manual brightness curve which provides very detailed control over brightness levels for any photos. 

To create a manual curve just click or drag on the histogram area, and you will see a control point added and a curve. 

Right click on a control point to delete it. 

The Curves control is used in combination with the other Levels controls, such as the central gamma control, and the black and white input and output levels. This means you can have both a manually entered curve, and still make general adjustments such as adjusting the gamma, or even the contrast on the main Photo tool Infobar. 


This example shows a manually entered curve with three control points. In this example the mid to dark shades have all been lifted (lightened), but the brighter shades of the photo (right side of the curve) have not been altered at all. 


The histogram graph shows both the original histogram (dark red) of the unmodified photo and the modified histogram (pale red overlaid) that is the result of the adjusted curve. 

Note: The two methods of altering the brightness levels (the new curves 'blue line' and the original brightness/contrast type controls) can be used together - the final histogram is the cumulative results of both methods.


Text Tool 

The Text tool is improved to include bullets, numbered lists and indents. Here's an example;


[image: image30.png]Bulleted and numbered lists, indents and outdents in Xara Designer

1. These operations work largely as you'd expect and very similar to most word
processors
2. But some less obvious features include:
i Clicking the indent button while in a bulleted or numbered lst will create
 sub-level numbered lists like this
i Ifyou right click on a list and select List Properties from the menu, you
can control the style of the numbers. Options include these styles
123 Numeric
A'B.C Uppercase alphabetic
abc  Lowercase aphabetic
L Upper case Roman
Lower case Roman
You can also control the start value of your list
3. Ifyou select one or more paragraphs of text (quad click short-cut), then press
the Tab key to indent the section. Pressing Shift-Tab will outdent it back one
level




 


These are controlled from the Text Tool Infobar [image: image31.png]


  and work like similar features in most word processors.


Find and Replace 

A Find & Replace function has been added to the Text tool. This performs live search so that as you type the search string the text is searched and highlighted in real-time.


To search for some text select the menu Edit -> Find/Replace or Ctrl+Alt+F and the following dialog is displayed. 
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Enter the search string and it's shown highlighted in the text. You can choose to search just the current text story, page or the whole document (all text flows on all pages).


The 'whole word' option will only search for whole words that match the search string. E.G. searching for 'met' will not find 'metro'.  The 'Case sensitive' option will match only the exact case. E.G. with this option on, searching for 'aBc' will not find 'abc'. 



Drawing Features 

Attribute Rules 

There is a major change in the way attributes (the object appearance or style) are applied to newly drawn objects.  We have changed the default behaviour to 'Give new objects most recent attributes' which was always an option in the Options dialog: 
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but we have also changed the way this works.


When you draw a new object it takes on the attributes (e.g. the color, line style, etc) of not just the last object drawn, but of the last object selected. 

Secondly there are now two sets of attributes remembered, one for closed shapes and one for lines. This means that when you draw a line and change its style, say to be a certain thickness, with a certain arrowhead style, the next line will take on the same appearance, but the next closed shape will not take on this line style. 

In other words any newly drawn shapes will take on the style (including line style) of the last drawn, or the last selected, shape.  Newly drawn lines take on the style of the last selected line. 

Although this is quite a substantial behaviour change for Xara, we believe this is more intuitive and more powerful. You can now, for example, copy the style of any object just by clicking it, and then drawing a new object. 

It means that if you draw a line and set its style, the next line will appear in the same style. But if you draw a closed shape instead, it will not take on the line style.  This is more useful because it's rare that you want a closed shape to have the same line style as an open line. 

It means, for example, that you can set the closed shape to have no outline at all (which is the most commonly required shape style), so that all newly drawn shapes have no outline, but that drawn lines can have an independent style. 

There is one minor oddity that results from this behaviour change, namely that as you draw a line, it's shown in the current line style, but if you close this line to form a closed shape, then it will immediately change appearance to that of the current closed shape style. 


Pressing Esc with no selected object will return to the default line and fill styles (black). 

Opacity Masks 

The Transparency tool allows you to apply either flat or graduated transparency to any object or group.  But sometimes you need more advanced control over the transparency (or opacity) of an object, and with the release of version 6 we've introduced a very powerful way to  control the transparency of objects. 

The Opacity Mask system takes any object, or group of objects, and uses the color (usually black to white shading) of these objects to define which parts of any other object are transparent or opaque. 

The process is quite simple. First draw the shapes you want to define the opacity. It can be anything from a simple shape, photo, or blend, to a complex grouped drawing. Any black color will become 100% transparent, while white will be 100% opaque and shades in-between will create varying degrees of transparency.  Select this object and copy it to the clipboard - this will become the opacity mask. 

Now select the object, photo, or group to which you want to apply this mask and select Edit -> Paste Opacity Mask.  There are two options, the first will position the opacity paste into the center of the selected object. The second option 'Paste opacity mask in place' will paste it into the selected object based on the original position of the opacity mask. 

This creates a new type of group called an 'Opacity mask group'. 

Use the Page & Layer Gallery to select the opacity mask.  Once the opacity mask is selected you can manipulate this object 'inside' the opacity group. You can also Ctrl+click on objects in the opacity mask, to select them inside the opacity mask group. 

Tip: You can use a little known trick to move the selected object without having to click and drag on it. Hold the Alt and Ctrl key down and now start dragging anywhere on the page - it will drag the selected object. Once you've started dragging you can let go of the keys and it will carry on dragging. 
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Say I want to produce a soft variable transparent mask around this girl.


First I draw a shape around the girl, blend it to larger one. 
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This is the final mask image. There is an inside white shape drawn with the Freehand tool, blended to a black version that is larger. The blend is set to have 50 steps to produce a smoother white to black blend. 

A black rectangle is then drawn behind this and then grouped.  This is copied to the clipboard.
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The photo is selected and the menu Edit -> Paste Opacity mask selected.


The result is the black regions are now completely transparent, the white areas opaque.








Opacity masks can be used on any shape, photo or drawing.  As with nearly everything in Xara Designer, this is resolution independent, vector based.  You can un-group the Opacity mask group, or use the Layer & Page Gallery to access the items in the Opacity Group.


Straight Line / Arrowhead Tool 

This tool provides two new functions: 

1. A really simple way to draw single-segment straight lines 

2. A new way to control the arrow head and tail (style and size) on any line 


This tool is on the the drawing fly-out toolbar. [image: image37.png]


  


To draw a simple straight line, just select this tool and click-drag across the page.  Each time you do this draws a new straight line.


You can adjust the line by dragging on either end of the line.  Clicking on any line or shape in this tool will select it. 

Note if you want to draw a multi-segment straight line, use the Shape Editor tool and select the straight line mode. 

Arrows 
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The Infobar of the Straight Line tool provides two drop-down controls to apply an arrow head or tail to the start and end of the line. Note this works with any selected line, not just straight lines.


The slider control provide an interactive way to adjust the size of the arrowhead. 100% size represents an arrowhead size of 6 times the width of the line. So as you adjust the line, the arrowhead adjusts in proportion. 

Tip: For narrower lines, say 1 pixel or under, it's usually better to have a size value greater than 100%, say 200% or so. For thicker lines, say 4 pixels or more, then an arrowhead size of 100% or less usually looks better.


Solid (live) Shape Drawing 

When creating new shapes such as Rectangles, Ellipses or Quickshapes, Xara Designer now creates a solid filled shape as you drag across the page (instead of an outline as it used to).  The benefit of this approach is that it's now a WYSIWYG operation - you see the correct fill and line color as you drag across the page. 

One potential downside of drawing solid filled shapes is that it covers the background as you draw, so making it difficult to draw a shape so it exactly covers objects below or reaches a specific point on the drawing. For this reason, as you draw, the new object is shown with some transparency, so you can see objects underneath it as you draw.  

As with other 'solid drag' operations, if you press the Tab key during the drag, you can switch to Outline mode.  Also this indicator on the lower status line (right side)  [image: image39.png]w3



 reflects whether solid or outline dragging is on. Double clicking it will switch between solid and outline drawing. 

Solid Real-time Blend update 

When you edit one end of a blend, (Ctrl+click to select the shape inside the blend) this is now also real-time solid update. There is perhaps no better demonstration of the rendering (and blending) speed of Xara Designer than to do this on a blend, and to see the perfectly smooth fluid movement on the page. 


Solid (live) Line Drawing 

Similarly drawing lines with the Freehand tool is now solid WYSIWYG live line drawing. This works even if you have a fat line, with a line profile, feathered, such as this example. 

[image: image40.jpg]


 

We have also altered the default line smoothing to more closely follow the drawn path, to 25% rather than the old 50% value.






Pressure Sensitive Line Drawing 

Support for pressure sensitive tables has been re-written so it's much more accurate and responsive. This also works as solid real-time variable-width rendering as you draw with a pressure pen on a tablet. To enable pressure sensitive drawing (you must of course have a pressure sensitive tablet and pen) select the [image: image41.png]


 icon on the Freehand tool Infobar. 

  

To summarize: 

  

* We now have a button in the Freehand tool Infobar to enable pressure sensitive drawing.
* There was no indication that a line carried pressure info in V5 except by looking at it. V6 shows pressure in the stroke type dropdown.
* Various improvements to make it more reliable and more efficient.
* Pressure stroked lines can now have arrowheads - size depends on average width of the stroke.
* Pressure is shown live during drawing.

Pressure stroked lines can be used in combination with sketch mode (auto-joining disabled) to make a very natural sketching environment for artists, particularly cartoonists. 

Balanced Bezier Editing 

In the Shape Editor Tool, when dragging the control handles on a bezier control point, if you hold Shift down, both ends of the bezier controls points will be equidistant from the center point. This enables more rounded or balanced bezier curves to be drawn going through a point. 
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Sketch Mode 

Background: 

In version 4 and earlier it was standard behaviour that you could draw a new line starting from either end of a previously selected line, and it would append the new to the old.  In version 5 we changed the behaviour so that this automatic joining only happened if you paused the mouse over the end of the line.  This was disliked by some users, and was not entirely intuitive (most customers didn't understand you had to pause).  So in version 6 we have restored the original 'fast join' behaviour. The downside being that you can accidentally join lines, especially with rapid repeated sketching type line drawing. 

The new Sketch Mode button [image: image43.png]


 on the Infobar of the Freehand tool removes the automatic joining feature, so that you can rapidly draw lines without worrying about them being attached. 

Paste Style 

There is a new copy / paste fly-out bar available from the clipboard icon on the top bar 
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which provides direct access to the common clipboard operations. 

These icons represent, in order: 

Cut, Copy, Paste, Paste in same position, Paste Attributes, Paste Opacity Mask 

The Paste Attributes is an easy way of copying the style or appearance from one object to another. First copy the source object, then select the destination, and select this option to copy the style from the first object to the selected object. 

Perimeter / Line Length / Area calculations 

The Infobar of the Selector tool has two new fields at the right hand end displaying the perimeter length of any selected closed shape, or line length of a line, and the area of any closed shape. 

[image: image45.png]


 

This is particularly useful for plans where you have set up accurate unit scaling, meaning that you could, for example, read the exact floor area in square feet or meters. 



Page & Layer Gallery 

(The new name for the Object Gallery) 

The Page & Layer Gallery improvements are a continued improvement to this important Gallery. They make it easier to navigate complex drawings, but also provide a better UI for management of layers (as used by Web Designer and all versions) and better page management. The Gallery in Pro, and now also in Photo & Graphic Designer, also allows drill-down to the object level so showing a representation of the whole 'object tree'. 

· New 'Layers mode'. Automatically adjust the Gallery to show just the layers for the current page 

· New 'Find mode'. Automatically adjust the Gallery to find and show the currently selected item in the tree structure, collapsing everything else. 

· New 'Solo mode'. Make all objects invisible except for the selected object, so it's easy to work on that object in isolation. 

· Dynamic soloing - drag over the solo icons and only the item under the mouse pointer is shown on canvas, allowing quick scans through the z-order to find an object. 

· You can move directly to any page in a long document by just clicking the page in the Page & Layer Gallery. 
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Enhance Transparency Type 

The new Photo Enhance feature is not limited to photos.  You can now enhance (that is adjust the brightness, contrast, brightness levels, color saturation, color temperature) of any part of your document - drawings, text and photos. 


This is enabled by a new type of transparency called 'Enhance' Transparency that can be applied to any vector object. It acts like other transparency types, by showing the objects underneath the shape, but the items under are 'enhanced' by any of the Photo tool controls such as brightness, contrast etc.


This means you can now have a floating 'enhance' shape that, for example, brightens anything it is over - photo, text or drawing.  There are two ways to create floating 'enhance' shapes. 

1. Go into Mask Mode by selecting the [image: image47.png]


 icon and now draw your required shape. Now go into the Photo tool [image: image48.png]


 and adjust one of the enhance slider such as the brightness value.

or


2. Draw any shape using any shape creation tools on top of your photo or drawing. In the Transparency tool [image: image49.png]


 select the new Enhance type of transparency. This will temporarily make the shape go invisible. Now in the Photo tool [image: image50.png]


 adjust any of the enhance values.


Now you can drag this shape over anything in your document and it will brighten anything it's over.

You can use the transparency tool to adjust the degree to which this blends with the background photo.


[image: image51.png]


 

Here is an example spectrum filled rectangle with  with a freehand shape drawn on top of it and given an Enhance Transparency type of 100% de-saturated. This has also been given a graduated transparency so the effect fades from one end to the other.

Objects with Enhance Transparency are just perfectly normal vector objects which can can be placed over any drawing, not just photos.  You can use the Transparency slider to adjust the overall transparency or 'blend' of the effect and even apply graduated transparency to create a gradual fade of the enhance effect, such as in the above example.


Note:  If you are applying Enhance Transparency to photos you can use the Blur / Sharpen control to blur or sharpen the shape or masked area of a photo. But if you're using a free-floating shape with Enhance Transparency it is not possible to apply Blur or Sharpen effects. 




Automatic Backup of all Open Documents. 

A new set of controls in the Options dialog provide an automatic backup facility where the program can regularly save copies of all open documents. You can set the folder where these backups are saved, and how often the backup occurs. The backup saves are designed to only happen when you're not using the program, so it shouldn't do a save operation while in the middle of editing.
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A new menu: File -> Open recent -> Backups display a File Open dialog on the backups folder.  
Automatic save and Restore of Open Documents on Application Closedown. 

You can just close Xara Designer (or shut down your computer) and it saves all open documents and restores them the next time you start the program. 

Auto photo-gallery filling 

If you drag and drop a selection of image files from your File Explorer onto a template that has many photos, such as a photo gallery design, it will replace the template photos with your photos. If you drop more photos than can be accommodated on the page, you will be offered the choice of having the current page duplicated as many times as necessary to accommodate all your photos.  

Screen Capture Improvements 

The Screen Capture tool (Utilities -> Screen capture..) now provides the option to capture after a set time-out period. This enables you to, for example, capture menus or other pop-up items that would otherwise disappear if you had a key-press capture trigger. 
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New Templates 

The Designs Gallery includes new templates, in particular a large number of interactive presentation templates and a new Web Graphics category. (Pro also includes new webpage and website templates, see below).


Free Web hosting with MAGIX 

See website for details. 


Other New Features: 

- Photo tool enhance attributes can now be blended using the Blend tool
- Panorama tool: General stitching and blending improvements 
- Pasting bitmaps from the system clipboard no longer offers the choice of DIB or Bitmap, it just pastes as Bitmap. Advanced users can restore the old behaviour with the registry option: Clipboard/AllowPasteAsDIB
- Ctrl-Click (select inside group) on a text line will now select the text object and not the individual character you click on
- Pixel units can be entered as px or pix
- Automatic crash reporting - dump a stack trace to disk and, with the user's permission, transmit to Xara
- PDF export: Reduced memory requirements when exporting 

- PDF import improvements
- Clipview behaviour changes. Keyhole controls have gone which reduces on-screen clutter, and now there is right click menu to select the clip shape or the contents of the clipview 

- When adding a new section of a line the smoothing control will now smooth the whole line rather than just the last section
- All sliders can now be adjusted using the mouse-wheel by just holding the pointer over the slider. No need to give the slider focus first. 

- Hierarchical Designs gallery. We now support folder within folder in the Designs Gallery. 

- New clipart 

- Paste into current layer. With release 5 we changed the copy / paste operations to retain the source layers. Before that a paste operation always collapsed the pasted result into the current layer.  Some users liked the ability to collapse all layers into one on a paste, so we've added a new operation (which means it has an icon you can drag to any bar, and a configurable key short-cut) so you can paste into the current layer. 

- A new option in the Help menu to reset the Alert dialogs so they can be made to appear again 

- Updated RAW camera definitions 

- Updated Xara Xone tutorials CD and quick reference card 





Web Improvements 


All the following, mostly web-based improvements are included in Xara Designer Pro 6 (but NOT Photo & Graphic Designer 6).

New features in Web Designer 6 / Designer Pro 6 

· Improved, more slick, photo thumbnail pop-ups 

The animated photo pop-up effects (where clicking on a photo thumbnail pops-up a larger version) have been improved to provide higher quality animation effects, an optional soft shadow, title and captions and page dimming (the page under the pop-up can be dimmed). This is controlled from the Image tab of the Web Properties dialog. 

· Ability to do a slideshow and Next / Previous on a gallery or any number of thumbnails 

If you have a number of thumbnail photos with the pop-up effect on the page, you can now show this as a slideshow, with Next / Previous / Play / Pause controls with an optional thumbnail strip shown at the bottom of the window. 

· New quick 'Preview current page' and 'Preview whole document' options 

The Preview icon on the top bar is a new style fly-out with 2 options; Preview current page, and preview whole website. Clicking the main icon (before the fly-out appears) does 'Preview current page'. 

· Incremental Publishing 

When you publish your website Designer now uploads only the files changed since the last publish operation. This provides a huge performance gain when editing large websites, particularly if you have large attachments such as video files. 

· FTP details can be stored with the document including password 

The Publish Properties dialog now offers the ability to save the FTP details with the document. This is great if you have multiple websites published to different server locations or under different domains. In addition you can choose to save the FTP password with the file. Although this is a potentially dangerous option (anyone who has access to the .web file can update your website) this is also a powerful tool for web designers with clients, because you can give the .web file to a client, tell them they can update the text as they wish and just click the Publish button to update their website. They need know nothing about the complexities of FTP settings. 

· Named FTP profiles, inc third party ones 

You can save the your FTP settings into a named profile. Again this is useful if you have to manage multiple websites under different domains. The Profile list can contain third party profiles, such as our MAGIX Online free web hosting offer. 

· Free web hosting offer 

Designer will come with free website hosting from MAGIX. This can publish your website as part of MAGIX Online World. 

· Auto-updating Designs Gallery 

The Designs Gallery includes new 'online' sections and content, that can be updated remotely by Xara. 

· Drag 'n' drop Widgets from the Designs Gallery, and new Widget library 

New sections in the Designs Gallery provide a wide range of 'widgets' which can be drag-dropped onto your website. The Widgets provide interactive website add-ons ranging from movie players, to e-commerce features (e.g. a 'Buy' button to sell goods or services from your website) forms, maps and a lot more. 

When you drag a Widget onto the page it opens a window onto a configuration website where you can customize the Widget. Clicking the 'Insert' option will then add this as a floating Widget with an automatically created 'place-holder' preview graphic. As with all page objects in Designer these can be placed anywhere on your page. 

· Improved HTML quality, better use of CSS, removed divs, options for 'pure HTML' paragraphs 

For advanced users who want 'pure HTML blocks' you can now override the individual line positioning and force each paragraph of text to be output as a single unbroken HTML <p> block of text.  To do this apply a name of 'HTMLBlockText' to the text block.  Note if you do this not only will the line breaks not necessarily be the same as in Designer (and might vary from browser to browser), but features such as repel text around graphics will not work. 

· Support for justified text 

We've added support for fully justified text, and this even works with text flow-around shapes features. 

· Easy MP4 video upload and built-in video player 

Drag 'n' drop an MP4 video file onto the page, and it embeds a Flash video player to play the file, and automatically uploads the video file to your web-server. 

· Better page color and background support i.e. you can color the pasteboard separately from the page. More WYSIWYG results 

By default the 'page color' in Web Designer maps to the website HTML background color. The default is white so your whole web page background will be white.  You can drag any color onto the page (the white area) to re-color this.  However if you drag a color onto the pasteboard area (outside the visible page area) this allows you to create separate backgrounds for both the page and page surround. Whereas with previous releases of Designer you had to draw rectangles to create a colored page on a different colored background. 

For both the page and pasteboard area if you hold Ctrl and drop a bitmap onto either page or pasteboard you can create a tiling bitmap background. 

· Ability to support rounded corner pages, with drop shadows 

If you enable page coloring this way (by dragging a color onto the pasteboard), then in the Page & Layer Gallery a new Page Background layer is enabled, locked by default. If you unlock this layer you can adjust the page rectangle's soft shadow using the Shadow tool, and also make it a rounded rectangle (using the Rectangle tool). This is how the Introduction document is done, and enables very easy rounded rectangle page backgrounds. Note you are very limited in what you can do on this layer, and really it should never contain any more than a single rectangle. You can still resize the page using the usual drag-the-page-edge. 

If you enable a page background this way you can adjust the vertical offset of the page relative to the top of the browser window by setting the ruler page origin. i.e. enable rulers (Ctrl+Shift+R), and then drag the 0,0 crosshair point from the top left corner of the ruler to the required position above the page. For example if you drag the 0,0 origin to be 1cm above the page, then the website page will start 1cm down from the top of the browser window. 

· Much improved NavBar handling (it pretty much replicates the functionality of Xara Menu Maker) 

· A new NavBar top level object which can be dragged around as a single object 

· Take any button design and quickly turn it into a horizontal or vertical NavBar 

· Intelligent automatic button stretching so as you edit the button text and the button width will adjust 

· Option to have all buttons the same width or each to be as wide as the text label 

· Ability to create an automatic NavBar with buttons linked to all pages of your website. The NavBar is updated as you add / remove pages 

· Auto-highlighting of the 'current page' NavBar buttons 

· DHTML sub-menus with various animation and transparency effects 

· Use notes. 

· Double click on a NavBar to open the NavBar dialog 

· You can edit button labels using the Text tool without opening the NavBar dialog (but not if the NavBar is an automatic 'site navigation bar'.) 

· Most NavBars (like buttons) will have a copy on the Mouseover layer (so they are interactive as you mouseover them), so when you select them in Designer the status line will report '2 Navigation Bars (Soft Group)'.  Because they are soft grouped this means they act as one object still, and you can resize and move it about the page as if its one item 

· To edit the graphic design of a NavBar it's necessary to 'dismantle' the bar by selecting the 'Ungroup to edit graphics' button in the NavBar dialog, or by simply un-grouping (Ctrl+U) on the page. You can now edit the graphic design of the button To re-make the NavBar select the buttons (they must be the right format - see the help about this) and select the menu Arrange -> Create Navigation Bar 

· Automatic Site navigation bars are also automatically updating in some respects. i.e. if you move them, then all copies on all pages will move. For other types of NavBars it is still necessary to select the menu 'Arrange -> Update repeating objects' to update the copies on all other pages 

· You can adjust the font and text size of the whole NavBar by selecting it and using the normal Text tool options. 

· Drag 'n' drop color schemes, and pre-built color schemes in the Designs Gallery for all themes 

Instead of editing each individual named Theme Color, you can now alter the whole color scheme of your website in one go. You can test this using the provided Beta theme in the Designs Gallery. Open any page from the theme, or the 'website' design which is a complete 8-page linked up website. At the end of the Theme designs there are a selection of color schemes called 'Color Scheme 1' etc. Just drag and drop these onto your website to change all the theme colors in one go. 

You can make your own color schemes for any theme (say you want to distribute your color schemes on TalkGraphics) by customizing the named colors as you want, then saving the document with a name that contains the string 'ThemeColorScheme' in it.  When any file containing this string is dropped on an open Designer document, instead of opening the document, it just imports the color definitions. 

· Paste HTML snippets in directly with automatic preview/placeholder created 

Many website add-ons and widgets provide a snippet of HTML to embed into your page. Web Designer can now accept just pasting this snippet, and it detects this is an HTML snippet and automatically creates a placeholder on the page, with a static preview of the snippet.   Try this; go to maps.google.com and zoom into an area of interest. Click the 'link' in the top right corner and copy the second line of HTML to the clipboard (or click the customize option to make other adjustments). In Designer simply paste (Ctrl+V). After a few seconds a placeholder object appears with a preview image. How easy was that? You can position this anywhere on your web page. 

Most snippets do not allow resizing, so altering the placeholder size will not produce useful results. Some, usually simple Flash ones, do allow resizing.  Also note that this feature uses the built-in Internet Explorer control of Windows, and so if you have an older version, such as IE6, this doesn't function as well or as reliably as more recent versions. We recommend updating I.E., even if you use another browser as your main browser. 

· Easy way to add links to (and upload) external files such as PDF and Word files etc. 

You can link to external files using a new option in the Link dialog. Selecting a file such as a Word document will attach the file and upload it to your website. Clicking the link on the website will let your visitor download (or open) the file.  You can also drag and drop .PDF and .SWF (flash) files onto the page which will also attach the file to the website for upload next time you Publish. 

In the case of Flash (.swf) files these are embedded into the page and a static preview is automatically created. This can be resized on the page. 

In the case of PDF files a PDF icon is added to the page, and the PDF file uploaded to your website which if clicked will open the PDF file in the web browser. 

· Improved 'Page & Layer' Gallery providing a quick way to view and re-arrange pages and layers on each page.  e.g. drag and drop re-ordering of pages. Solo mode allows a layer to be isolated 

Use notes: Click the Pages button to view only pages, or the Layers button to view only layers. Depending on whether you're in Layers or Pages mode the New button will create a new layer or a new page. Click the S icon on a layer to go into Solo mode for that layer. This hides all other layers and lets you work on the layer in isolation. Clicking the S again will restore the previous state. A nice feature is that you can drag down the S column to quickly show each layer in turn. Layers and pages can be dragged in the Gallery to re-order. 

· Templates Gallery expanded with new designs 

Existing designs updated. A new 'complete website' design is provided for each template set, which is a ready-made, fully linked up 8-page website. Each theme set also includes a variety of alternate color schemes that can be dropped onto any of the templates (or whole website) to change the whole color scheme. 

· Anchored graphics. So photos and graphics can flow with the text 

In the Text tool if you have the caret in the text and select the Paste option (or Ctrl+V) if a graphic object was on the clipboard, you get the option to embed this graphic into the flowing text story as an anchored object. Once done you can drag the graphic wherever you like, for example to be outside one of the margins, but it will remain tied to the anchor point. So as the anchor point moves up and down as you edit text above, so the graphic will move as well. 

· New automatic photo optimize features. 

When you import a photo e.g. drag and drop a large .jpg file from your digital camera, Designer offers to reduce the resolution for you.  This can save a lot of memory and disc space. (Most digital camera files are far, far higher resolution that you'd ever want to use on a web page). This can reduce the Web Designer memory and file size from a typical 4Mbytes or more per picture to perhaps 400Kbytes.  If you select the 'import reduced' option, then the image is resized to be 1920 pixels across - the same pixel size as a Full HD picture or largest typical size of a 24" computer monitor. 

This is in addition to the automatic reduction that takes place when you publish a website, where Designer automatically reduces the resolution of all images to be no more than the size they appear on your website. 

Additionally there's a new menu option 'Optimize all JPEGs' which will go through your document and reduce the size of all photo files to be no more than the size on the page. It is recommended that you only use this option once you've finished composing your pages and are sure your photos are the intended size, and you want to reduce the size of the Designer .web file. 

