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Scroll through this document to see a description of all the great new features released in the latest version of 

Xara Designer Pro+ (available standalone or included in Xara Cloud Pro+, our great value bundle of Xara Cloud 

and Designer Pro+).

If you have an active subscription to Xara Designer Pro+ or Xara Cloud+ then these updates are free and they 

will be downloaded automatically.  And if you are an owner of an older version purchased from Magix, then 

check out our current offers on upgrades. To upgrade you will need to install the new Designer Pro+, you can 

download the the free trial here.

Other Useful Pages

Our Designer Pro+ User Guide and Knowledgebase 

You can find Release Notes for the earlier v19 here.
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Version 20.0 (04-Jun 2020)

Improved Export of Web Documents

Web documents published in Designer Pro+ (such as presentations or SuperSites) now have the same 

flexible User Interface as Xara Cloud ‘Share To Web’ documents.

There are some new easy to use page and zoom controls at the bottom of the page, and the option for 

viewers to download the document as a PDF or set it to full screen view at the top.

New options for presentations and SuperSites

In Designer Pro+ you can decide whether or not to include the downloadable PDF of your document - see 

the new Include a PDF download option in the Utilities > Web Properties > Export dialog. When 

included the PDF is generated with default High Quality settings.

The new user interface appears for all types of documents from presentations to print (SuperSites), but 

websites continue to export as before. When the PDF option is on, the UI includes a large top bar that has

download as PDF

set to full screen (Esc to revert)

select a page by clicking 

thumbnail

alter the zoom

step thru the pages
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a Powered by Xara logo in the top left corner. If you wish to disable this logo or the PDF download 

options, you can do so by unchecking the options in the Export dialog.

Tool Switch on SmartShape insertion

In previous versions we select the QuickShape tool whenever a SmartShape is inserted into a document, 

so that the object’s smart handles are visible. However since we now have the option to show smart 

handles in the Selector Tool we now select this tool instead when smart handles are on (as they are by 

default).

Don’t resize SVGs on import

Imported SVG graphics are no longer scaled, they are imported at the size defined by the SVG, with the 

exception of images from Pixabay (because their sizes are wide ranging and unpredictable).

Other Fixes & Minor Improvements

• Fixed an issue which caused the color editor dialog to lose dropdown menu after changing height

• Fixed an issue which caused the Get Color from Photo tool to be disabled whilst photo is selected

• Fixed invalid embedded repelling objects when importing Word documents

• Fixed an issue which caused certain .docx files to crash Designer Pro+

• Fixed an issue where 1bpp images were being corrupted on export to PDF

• Fixed an issue which caused text formatting to enter an infinite loop

• Fixed an error which caused Designer Pro+ to not shut down cleanly

• Fixed an error when pasting the contents of another file with a locked MouseOff layer

Version 20.1 (25-Jun 2020)

High DPI Display Support

• Designer Pro+ now makes best use of the screen resolution whatever the Windows scale factor is 

set to.

• On high-resolution screens, like 4K Monitors and devices like Surface Pro tablets, document display 

is sharper.

• Even on lower resolution screens, you can now use the Windows display settings to make the 

controls bigger, while the document display still uses the screen’s full resolution.

Export Options for SuperSites

The Page Thumbnails & PDF Download checkbox on the Utilities > Web Export Options dialog now 

optionally turns on & off the new navigation options introduced for web documents such as presentations 

and Supersites in v20.0 (see the 20.0 section for full details). These include:

• Full screen button

• A downloadable PDF of the whole document/site

• A pop-up page thumbnail bar
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• Additional navigation buttons

If the option is off, sites and documents export to the web in the same way as earlier versions of Designer. 

In all cases websites set to export as Conventional Website in the Utilities > Web Export Options dialog 

will work as before with no additional navigation UI added.

Settings

Users are no longer prompted about settings when starting an updated version of Designer. Designer will 

use the user’s current settings. In case users do need to reset all settings back to their default values, a 

new Default Settings option has been added to Utilities > Options > Tune-ups.

Other Fixes & Minor Improvements

• Fixed an issue which prevented a correct export of alt rainbow fills to web

• Fixed an issue which caused selecting text on new web UI moved to previous page

• Fixed an issue which prevented RAW file import

• Fixed an issue which caused errors when updating Table Of Contents

• Fixed an issue which caused links not working in web export with some Panel components

Version 20.2 (04-Aug 2020)

Tables - tab key support

You can now press the tab key to move from one table cell to the next, or Shift+Tab to move backwards. If 

you press tab with the text caret in the last cell of the table, a new row is added.

Tab setting controls for Table Of Contents

When a Table Of Contents (TOC) includes page numbers, you can now control how the tab space between 

the heading and the page number is displayed. You can choose what character should be used to fill the 

space (most commonly a “.” character, which is the default setting) and also the spacing of those 

characters in the tab space.

Simple TOC with levels 2 & 3 tab spaces filled with “.”
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To insert a new TOC, place the text caret and choose Insert > Table Of Contents. Or to update an existing 

TOC, right-click in it and choose Table Of Contents > Properties, from the context menu. The Table Of 

Contents dialog appears.

Table Of Contents Dialog

The Include page numbers option has been moved into a new Page Numbers section of the dialog. With 

this option on, the other controls in that section become enabled, allowing you to choose the character 

that should be used to fill the tab space before the page number, and the spacing of those characters. A 

spacing value between 0 and 10 is normally suitable, but you can set higher values if you want much 

larger spacing. You can set different character and spacing values for each of the first 3 levels (Heading 1 

to Heading 3). Levels 4 and above, if included in the TOC, will use the same settings as those set for Level 

3.

If you don’t want any character to fill the tab space, simply clear the tab character field.

Custom Spacing - Advanced

Spacing works by adjusting the tracking setting on the tab characters within the TOC. The dialog above 

allows you to set any value in em/10 units. If you need finer control over the spacing, you can use the 

Tracking control on the Text Tool InfoBar to set any tracking value you like directly on the TOC, instead of 

using the dialog. Select the first tab character on the first line of the TOC to set the spacing for the first 

level in your table. Set the tracking value you want on the tab, then right-click Table Of Contents > 

Update. All first level lines of the TOC are updated to use the spacing/tracking that you set on the first line. 

Similarly you can set the spacing for levels 2 and above by selecting the tab in the first line of each level 

that appears in the table and adjusting the tracking, then doing an Update.

The dialog only allows you to set the tab space character for the first 3 levels. But you can use the same 

approach described above to overcome this, if you have a TOC with 4 or more levels. Select the tab of the
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first Level 4 line, right-click, Tab stop properties…. Choose the character you want to use. Then update 

the TOC as described above to update all Level 4 lines in the table.

Minor Improvements

Paste format/attributes operation no longer pastes links.

Bug-fixes

• Upgrade button resolution fixed.

• Table row/column selection fixed.

• Bitmap tracer truncated text fixed.

• PDF import very slow due to text used as clipping path. Fixed.

• Dialog layout improvements for HiDPI.

• Bitmap tracer dialog cropped label. Fixed.

• Rotate/scale inside handle missing on upright photos. Fixed.

• Popup photo doesn’t work due to Quickshape with bitmap fill. Fixed.

• CMYK color editor fields could be mis-aligned. Fixed.

• Text Style change on pie chart not handled correctly. Fixed.

• Pro+ window does not restore maximized on 4k screen. Fixed.

Version 20.3 (07 Sep 2020)

Selection UI

New SmartShape Handles

The handles on SmartShapes (tables, charts, shapes, text panels, etc.) have been improved, made more 

consistent and now match the handles used in Xara Cloud. Note functionality hasn’t changed.

Example SmartShapes with new handles
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New Selector Tool Handles

The selection handles shown when in the Selector Tool have also been updated. These are shown on all 

types of object that don’t have their own smart handles, and on all multi-selections as in the example 

below.

Multi-selection with new Selector Tool handles

Footer Designs

These are new components that automatically size and position themselves at the bottom of the page on 

insertion. They are also made repeating on insertion, so that they appear on every page of your design.

Example Footer design 

Each footer typically has a logo, page number and a line of text.

To insert a footer use Insert > Footer …, which opens the Content Catalog onto the selection of footer 

components.

If you insert a new footer when there is already a footer in the design, the new footer replaces the old one 

and where possible the content of the old footer is maintained in the new footer.
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Other Improvements

Image Import Resolution

In earlier versions of Designer large images imported into web documents were always automatically 

reduced in size to Full HD resolution. Designer now prompts about this so the user can choose to import 

either the original image or a reduced image, as when importing into print documents.

Google Fonts Update

40 new fonts added:

Alata, Alatsi, Baskervville, Bebas Neue, Bellota, Bellota Text, Caladea, Calistoga, Comic Neue, Courier Prime, 

DM Mono, Epilogue, Gelasio, Girassol, Gotu, Grenze Gotisch, Gupter, Ibarra Real Nova, Inria Sans, Inria 

Serif, Inter, Jomolhari, Jost, Kulim Park, Manrope, MuseoModerno, Odibee Sans, Oxanium, Public Sans, 

Recursive, Red Rose, Rowdies, Sen, Solway, Sora, Spartan, Sulphur Point, Tomorrow, Varta, Viaoda Libre

Bug-fixes

• SVG import: Remove empty groups.

• Name Gallery HiDPI fix

• Bleed margin fix for print pages when exporting to PDF

Version 20.4 (07 Oct 2020)

Selection UI

Improved Rotation Center Handling

By default when you rotate an object, the origin of the rotation is the object’s center point. But you can 

move this origin to rotate any objects around a common origin point. First turn on visibility of the rotate

center by pressing the toggle button  on the Selector Tool InfoBar.

Rectangle selection with rotation center visible

Now you can drag on the center point handle to move it anywhere on the page. For example if you move it
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to the center of the page, then when you rotate the rectangle or any other objects, they will all rotate 

around the center of the page. Unlike in earlier versions of Designer, the visibility and position of the 

center handle is now maintained until you press the button again to turn visibility off. You can change 

selection, switch to and from other tools and even switch to different pages and the rotation handle keeps 

its position. To revert to normal, where objects rotate around their own centers, just turn visibility off 

again.

Selection box offsets on small objects

When you are zoomed out in Selector Tool, or have very small objects in your design, the selected object 

may be very small on screen so there is very little space for Designer to show the selection box with its 

handles. So now in such cases you will notice that Designer shows a larger selection box around the 

object, so it’s easier to work on it without having to zoom in.

Large object on screen - selection box is 

tight to the object

Small object on screen - selection box is 

bigger than the object
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New QuickShape handles

QuickShape Tool selection handles have been updated to match the new Selector Tool handle style.

QuickShape editing handles

PDF Import Improvements

Many fixes and improvements to import of PDF documents, including:

• Wrong fill colors on some shapes. Fixed.

• CMYK image imported inverted. Fixed.

• Links to next/previous page not imported. Fixed.

Also some improvements to the export of imported PDF documents to web:

• Wrong font weights on some text in web export. Fixed.

• Narrow lines invisible in web export. Fixed.

• Dropped capitals wrong positioned. Fixed.

• Some embedded fonts failed to be exported to web. Fixed.

• Text with outlines now export to web correctly.

• Image resolution now better in web export.

Other Fixes/Improvements

• Spurious internal error when inserting footer components

• Selection indicator blobs lost. Fixed.

• Serious error exporting document to PSD. Fixed.

• Small Caps corruption during edit inside. Fixed.

• Pasteboard range limit removed so objects dropped a long way from the page don’t jump from the 

drop position.

• Chevron SmartShapes now support click on + handle to add, as well as drag.
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Version 20.5 (11 Nov 2020)

Selection UI

The Shape Tool  now has improved selection handles, similar to those recently added to the Selector 

and QuickShape Tools.

New Shape Tool handles

Also the QuickShape Tool now shows a reduced number of handles, but retains all the same capabilities. 

Previously some handles were duplicated around each vertex of a shape, each performing the same 

function.

Web Export Settings

The old Web Export Options dialog has now been replaced by a new Export tab in the Utilities > Web 

Properties dialog. This brings these options, which control how your document or website appears when 

published to the web, together with other web settings, all in the same dialog.
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New Export tab of Web Properties

The Transition Effect and Direction have been separated into two controls, instead of a single combined 

control.

Also you now have more control over what features are enabled in your web document or website, in the 

Viewer Options section at the bottom of the dialog, as follows:

Page previews

This option allows you choose whether or not you want the page navigation panel along the bottom of the 

browser window, that allows a viewer to navigate directly to any page by clicking on a page preview.

PDF download

If this option is checked, a Download button is added to the top right of the browser window, that allows 

the viewer to download your document as a PDF file, for printing or offline viewing. When this option is 

on, the PDF file is generated and published for you automatically along with the web view.

Xara logo

This option determines whether or not the Xara logo is shown in the top left corner of the browser 

window.



Page 16 of 95

Note that whenever the PDF download option or the Xara logo option are on, a bar is added across the 

top of the browser window that also includes a Full Screen button. But if neither of these options are on, 

the bar is not present and so neither is the Full Screen button.

Presentation document with all 3 options enabled

Headers

Footers were introduced in Designer Pro+ 20.3. Headers work in exactly the same way, except they 

position themselves at the top of the page instead of the bottom. To view and use the available designs 

use Insert > Header ….

Example Header design

Other Improvements & Fixes

• The Web Preview operations  now open your document/website directly in your default web 

browser, instead of in an internal preview window.

• PDF Import: Improved handling of alpha-channel images.

• PDF Import: Reduce/combine subset fonts where possible.

• PDF Import: Character appears as a hyphen. Fixed.

• Word Export: Borders missing from table exported to Word. Fixed.

• Corner-styled rectangle shape doesn’t report correct line width setting. Fixed.
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Version 20.6 (02 Dec 2020)

PDF Editing

This update includes multiple PDF import fixes and accuracy improvements, plus the following changes to 

font handling when editing imported PDFs:

PDF Fonts

Most PDF files include a definition of all the fonts that are used by the text in the PDF, so they can be 

displayed accurately by any PDF Viewer. So when opening a PDF, Designer Pro+ is able to import these 

fonts too. However in previous versions these fonts would not always be used - Designer Pro+ would often 

use a similarly named locally installed font instead. This meant that the appearance of text could vary, 

depending on what locally installed fonts were available on the device. This resulted in an inconsistent PDF 

editing experience.

Now Designer Pro+ will always use the fonts from the PDF (if they are included), so all text should always 

appear exactly as the document author intended, on any device. They all have a PDF- prefix on their 

names, so you can easily distinguish them from your locally installed fonts.

Font Replacement

One problem with the PDF fonts is that they usually only include characters that are used in the text of the 

PDF. That helps keep PDF file sizes small. So if you type a character that was not in the original document, 

it can’t be displayed correctly.

In earlier versions, Designer Pro+ would use a different font for such missing characters, so they would 

usually not match the rest of the text. And this could easily go unnoticed initially. So now Designer Pro+ 

will prompt you if you ever enter a character that is not available in the PDF font that is being used. It 

offers you the chance to replace the font with a local installed font, throughout the entire document. 

Alternatively you can choose to ignore the problem and continue using the PDF font. Then you will not be 

warned again about missing characters for that particular font, in the current editing session.

This improvement means you can confidently edit text using the original font, without having to visually 

check the text for consistency. If ever you type a missing character, you’ll be alerted and you can then 

decide either to switch to a different font, or avoid using the missing character(s).

Minor Improvements

• Published documents and websites that are set to use page transitions (Utilities > Web Properties 

> Export) no longer show the keyboard shortcut pop-up.

• Opening files with drag and drop didn’t work in some circumstances. Now fixed.

• Insert > Table now opens the correct folder again in the Content Catalog.
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Version 20.7 (16 Dec 2020)

CMYK Color Profile

In this release we’ve improved the display of CMYK colors on screen, and also in all export formats that 

require conversion of CMYK colors to RGB. These color conversions now use a standard Color Profile. As 

yet there are no user controls for changing the Color Profile used, or for using a custom profile, but these 

further improvements will be coming in another update soon!

Other Fixes & Improvements

• More kerning improvements for PDF import.

• ‘Scale to fit’ Web Properties > Export settings would revert. Fixed.

• ‘Scale to fit width’ Web Properties > Export setting now works also when Viewer options are on.

• Word import text positioning problem fixed.

• Help updates.

Version 20.8 (1 Feb 2021)

CMYK Color Profile Control

The Color Profile used to display CMYK colors on screen and on export can now be controlled for each 

document, via the View tab of the Options dialog.



Page 19 of 95

In the Color section of the dialog you can select from the set of standard profiles included with Designer 

Pro+, or you can use the Browse… button to select a custom profile. Custom profiles are saved with the 

document automatically.

The set of Color Profiles included in Designer Pro+ has also been updated.

The selected profile is used in exported PDF/X files by default, or you can change this in the PDF Export 

dialog, as before, if you wish to use a different profile.

PDF Filename in Web exports

The PDF file that can optionally be included when a document is exported to web, is now named according 

to the filename of the current document. So for example if the current document is ReleaseNotes.xar, the 

PDF file will be ReleaseNotes.pdf.
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Selector Tool Handle Visibility

Selector Tool handles remain visible even on small objects on screen. Previously some handles were not 

shown at small on-screen sizes.

PDF Import Improvements & Fixes

• Serious errors importing some PDF files. Fixed.

• Occasional text lines wrapping too early. Fixed.

• Very slow PDF opening due to excessive rectangle conversions. Fixed.

Other Improvements & Fixes

• Some problems with text links in some Text Panel components. Fixed.

• Rectangles set to export to HTML full width with tiling, were not exporting correctly. Fixed.

• Occasional problems after copy/paste of repeating and non-repeating objects together. Fixed.

• Document failed to open due to SmartShape. Fixed.

• Word (docx) export. Table did not export correctly. Fixed.

• Word (docx) import: Tab positions imported incorrectly. Fixed.

• Line Gallery controls disabled until folder is selected. Fixed.

• PDF Export: Serious error exporting with embedded CMYK profile. Fixed.

Version 21.0 (10 Mar 2021)

Smart Duplication

Smart Duplication allows you to quickly duplicate an object multiple times horizontally or vertically, with 

the copies equally spaced. With all the objects selected you can then also adjust that spacing.

Turn on Smart Duplication mode by pressing the new button  on the Selector Tool InfoBar. With this 

option on, you’ll see that most objects have handles around them.

Selected object with Smart Duplicate handles on
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Drag the right handle rightwards to duplicate objects to the right, drag the lower handle down to duplicate 

downwards, etc.

Object duplicated 3 times, equally spaced

You can then adjust the spacing by dragging the spacing handle  shown near the top right corner of the 

selection. If you want to keep the selected objects centered, Hold the Shift key down while dragging. You 

can also use this feature to quickly adjust the spacing of any set of selected objects, horizontally or 

vertically. Just select them all and drag on the spacing handle, to equally space the objects.

Selection Improvements

• The Selector Tool InfoBar used to have a button for toggling between SmartShape and transform 

modes, which only really affected SmartShapes. Now these two modes have been combined, so the 

toggle button has been removed.

• Clearing the selection now once again turns off rotate handle mode, if it is on. This is in response to 

user feedback on Designer Pro+ 20.8, where rotate mode would stay on until explicitly turned off.

• Non-working handles displayed on objects selected inside a SmartShape. Fixed.

• Serious error pressing rotate mode button with no documents open. Fixed.

PDF Editing Improvements

• Further improvements to text import accuracy, and a reduced number of kern characters in the text, 

which improves text editability.

• Tracking reconstruction.

• Improved handling of fonts with symbols in their names.

• Performance improvements, so some large PDFs will open more quickly.

Other Improvements & Fixes

• Google Fonts update: 44 new fonts added.

List of fonts: Akaya Kanadaka, Akaya Telivigala, Andik, New Basic, Ballet Benne, Big Shoulders Inline

Display, Big Shoulders Inline Text, Big Shoulders Stencil Display, Big Shoulders Stencil Text, Bodoni 

Moda, Brygada 1918, Castoro, Commissioner, DotGothic16, Fraunces, Goldman, Grandstander,
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Hachi Maru Pop, Imbue, JetBrains Mono, Kufam, Kumbh Sans, Langar, Libre Barcode EAN13 Text, 

Nerko One, Newsreader, Oi, Piazzolla, Potta One, Reggae One, RocknRoll One, Sansita Swashed, 

Shippori Mincho, Shippori Mincho B1, Space Grotesk, Stick, Syne, Syne Mono, Syne Tactile, Texturina,

Trispace, Truculenta, Xanh Mono, Yusei Magic

• File > Save Template … no longer saves files to the installation folder, which was problematic on 

some systems.

• Widget problem caused document to fail to export to web. Fixed.

• PowerPoint import fixes.

• Help link added to help users who have problems unlocking their Designer Pro+ after installation.

• User’s repeatedly asked to connect to Xara Cloud on startup, following an abnormal closure of the 

application. Fixed.

Version 21.1 (22 Apr 2021)

WebP Image Export

WebP is a new image format that is an alternative to the well established JPEG and PNG. It uses new 

compression technology that allows image files to be smaller than JPEG or PNG image files of similar 

quality. Therefore it’s particularly suitable for use with images in websites and web documents, which will 

open faster if viewed in a web browser that supports WebP images, which most modern browsers now do.

Exporting Individual Images

WebP has been added to the extensive list of file formats that Designer Pro+ can export. Select the object 

or image that you want to export and choose File > Export WebP … . This option is also available on the 

right-click context menu. Choose a filename and folder location and click the Export button to export with 

default/previous settings, or click the Settings button to open the settings dialog.
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WebP Export Settings

Here you can choose whether to export the current selected object(s), the current page contents, or the 

whole of the current page including the page background. You can also choose the size of the image you 

want to export, by entering the required dimensions in pixels, or choosing the resolution required (DPI 

field).

Transparent background

If you select the Transparent option the image will be exported with a transparent background, so that it 

can be placed on any background. With this option off, whatever background you see behind the selected 

object(s) will be included in the exported image. Normally if you are exporting individual objects it’s best to 

select the transparent option, but if you want an image of a whole page including the page background, 

turn transparency off.

Encoding

WebP files can be either lossy or lossless. With a lossy file, some image detail is lost in order to achieve a 

smaller WebP file size. With a lossless export, full image detail is retained. So for the same image, a 

lossless WebP file will typically be larger than the equivalent lossy file.
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For the best balance of file size versus image quality, it’s generally best to export photos as lossy and 

graphics as lossless.

Quality

With the lossy (best for photos) option selected, the quality controls are enabled so that you can control 

the balance between image quality and file size. The file size that will result from the current selected 

settings is displayed at the bottom of the dialog.

WebP Images in Websites

You can choose to have all the images in your website or document automatically exported as WebP, so 

that images will appear faster when your website/document is viewed in a browser that supports WebP. 

Simply turn on the new Include WebP images option, which is at the bottom of the Website tab of the 

Utilities > Web Properties dialog.

Browser Compatibility

While most modern web browsers now support WebP files, some still do not, so it’s not yet advisable to 

provide images only in WebP form. So with the WebP option on, Designer Pro+ will automatically encode 

all your images in WebP AND also in either JPEG or PNG form, to maximize browser and device 

compatibility. And it will make sure browsers that do support WebP will only download and display the 

WebP files, realizing the benefits of a faster web browsing experience with WebP. While older browsers 

and others that don’t support WebP will download only the JPEG or PNG files instead.

This does mean that previewing and publishing your website/document will take a little longer with the 

WebP option enabled, because of the additional image encoding that has to occur. If this delay is 

significant for your document, it’s best to turn off the WebP option while you work on your design, so that 

preview is faster, and then turn it on again just before publishing.

PDF Import

• Further general text positioning accuracy improvements.

• Ligature auto-kerning fix.

• Slow import of PDFs with very large numbers of colors. Fixed.

Word Import

• Improvements relating to export of imported PDF documents to Word (for PDF to Word conversion).

• Auto-kerning now applied to exported text, for improved position accuracy.

• Other text positioning accuracy improvements.

• Bold set incorrectly on text using embedded font. Fixed.

• Shape on top of text prevents text selection in Word. Fixed.
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Other fixes & improvements

• Some stock image searches returned fewer results than expected. Fixed.

• Detaching inverted Opacity Mask did not redraw correctly. Fixed.

• Serious error on import of Word doc. Fixed.

Version 21.1.1 (29 Apr 2021)

Bug Fixes and Improvements

• Fixed an error when saving a template

• Fixed an image quality issue when exporting to WebP at 100% quality

• Fixed an issue that caused background images to not display properly in IE

• Fixed an issue that caused error 84.k.cx.mp when exporting or previewing

• PDF import improvements

• Fixed an issue that caused PNG transparency to not be maintained when opening directly and 

saving

• Improved PDF to Word export

Version 21.2 (18 May 2021)

WebP Image Import

Designer Pro+ can now import WebP images as well as export them. As with other image file types, you 

can simply drag and drop a WebP image file onto your document from Explorer, or use File > Import to 

browse for your WebP file.

New Timelines & Smart Diagrams

These are in the following folders of the Online Content Catalog:

Components > Print & Web Components > Timelines

Components > Print & Web Components > Diagrams

These components have internal elements that can be easily re-arranged, duplicated or deleted, without 

spoiling the designs. For example in this Pillar Diagram below, you can easily choose how many pillars 

you want.

https://xara-ltd.atlassian.net/browse/P9052-16795
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3 Pillar Diagram …

… 4th Pillar added
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Each pillar has a set of 3 handles on it:

• Click the  handle to delete a pillar

• Click the  handle to add/duplicate a pillar

• Drag on the  handle to change the order of the pillars.

There is also a single spacing handle  that you can drag to adjust the spacing between the pillars. 

As you change the number of pillars, Designer Pro+ tries to maintain the current width of the component 

as much as it can. But if you add more than can be fitted in the current width, the component will get 

wider. And, as with all components, you can drag the width and height handles on the outside of the 

component to adjust the size. Or use a corner resize handle to scale the whole component up or down, 

but note that this will change the text sizes too.

The same principle applies to the other Timeline and Diagram designs in the Content Catalog. They 

each have similar elements inside them, as indicated by the same set of 3 handles. So for example the 

Timeline shown below lets you choose how many labeled circles you would like along the arrow.

Timeline with 4 bullet points

Some of the components have parts stacked vertically instead of horizontally, but the same principle 

applies in the vertical direction.

Word Import/Export Improvements

• Improved handling of Word’s ‘At least’ line spacing option on import.

• Locked background shape movable in Word after export. Fixed.

• Other Word export fixes.

Other Bug Fixes and Improvements

• PDF file fails to open. Fixed.

• Rounding handle on Oval shape gives error. Fixed.

• Problems with Repeating objects using text inside shapes. Fixed.
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• Error on web export due to large WebP file. Fixed.

• WebP export affected by JPEG export retina setting. Fixed.

• Shadows exported to SVG correctly.

• Serious error on zoom due to brush strokes. Fixed.

• Editing of photo with transparency lost the transparency. Fixed.

Version 21.3 (28 May 2021)

Template Locking for Xara Cloud

Designer Pro+ already had support for completely locking an object, so that clicking or dragging on the 

object will do nothing. This is very useful in Designer Pro+ and in Xara Cloud, for objects in the 

background, behind text for example. It prevents users accidentally moving or selecting the object, when 

they intended to work on objects on top. It can also be used by template designers to discourage users of 

a template from making unnecessary design changes - for example locking a company logo in place, so 

users can’t move or change it. However template designers need more flexibility, so they can lock different 

aspects of an object in their design, while still allowing some customization of that object by users of the 

template.

New Lock types to restrict Xara Cloud editing

To achieve this flexibility we have introduced 2 new types of locking to Designer Pro+ and Xara Cloud. 

Designer Pro+ is often used for creating and editing templates that are deployed with Xara Cloud, so these 

two new types of lock can be applied using Designer Pro+, but the locking is only enforced in Xara Cloud. 

In Designer Pro+ the objects can still be edited without restriction.

Lock Size & Position

This lock prevents an object from being moved or resized in Xara Cloud. So when such an object is 

selected, the user won’t see any handles for changing the object size. But users can still edit the content of 

the object. For example if a photo is locked in this way, a user can still change the photo image, using 

Replace Photo, as normal. But they can’t move the photo, resize it, or change its shape. The same 

principle applies to other types of object with this lock - that is, they allow content editing, while 

maintaining the object’s size and position in the document.
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Photo selected with Lock Size & Position

Lock Aspect Ratio

This lock prevents users from changing the aspect ratio of an object in Xara Cloud, for example by 

stretching it wider or taller. Such objects can still be moved and also resized by dragging a corner resize 

handle, but no handles are shown for changing the width or height of the object. Content can still be 

edited, as with the Size & Position lock.

Photo selected with Lock Aspect Ratio

Locking Dialog

The new Locking dialog is opened with Utilities > Locking …
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Locking

The Lock All option is the original Designer Pro+ locking whereby the locked object can’t even be selected. 

With this lock the object can only be unlocked using the Page & Layer gallery, as in previous versions of 

Designer Pro.

The Only Admins can unlock in Xara Cloud option prevents ordinary Xara Cloud users from overriding a 

lock on an object. So this option allows template designers to determine whether a lock is just advisory 

(users of the template can choose to turn it off), or compulsory. However this restriction does not apply to 

Administrators of the Team in Xara Cloud.

Object Right-click Menu

You can also view and change lock settings using the right-click context menu on any object. There is a 

Lock sub-menu, that gives quick access to all the same settings available in the Locking dialog described 

above. There’s also an option to open the Locking dialog itself from this menu.

Fixes

• Word  Export: Some CMYK bitmaps appear as empty rectangles. Fixed.

• Word Export: Some images appearing inverted. Fixed.

• Blank line added unnecessarily when pasting objects embedded into empty text area. Fixed.
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Version 21.4 (24 Jun 2021)

Open Graph

Open Graph gives you control over how your website is presented when you post a link to it on social 

media. You can set image, title and description, which stops the social media site making a best guess on 

your behalf. For example if you paste www.xara.com into a Social Media app, the app will show the 

graphic below, which is published as part of the Xara website.

Now you can easily create and include a similar graphic with your website and web documents. 

Setting the title and description gives you the opportunity to improve your page rank by including your top 

keywords.

Open Graph Dialog

The Utilities > Web Properties dialog has a new Open Graph tab.

http://www.xara.com/
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Open Graph Dialog

Enable Open Graph for your website or document by selecting the Enable checkbox at the top. Then you 

can enter the Title and Description you’d like to appear as part of your site’s preview. If you already added 

Title and Description in the Website tab of this dialog, the same text will appear here by default, but you
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can change it if you like.

Below the Title and Description you can see the current Open Graph image that is set for the current 

document. By default you will see a relatively simple graphic with a logo in the center. There are a 

selection of other Open Graph image designs to choose from in the Content Catalog - just click the 

Catalog… button below the preview image to browse and select one.  Or, if you already have a suitable 

image you’d like to use instead, just click the Import… button to import it.

Where a design includes a logo, if the document you are editing already includes a suitable logo, it should 

be used in the preview image by default. If not, or you want to change the logo, you need to edit the image 

design.

Editing the Open Graph preview image

Click the Edit… button and a new document tab will open containing just the Open Graph preview image 

design for the current document. Here you can edit the graphic just as you would edit any other content 

within Designer Pro+

• Select the Text Tool to edit the text

• Right-click on a logo and choose Replace… to replace a logo

• Right-click on an image or photo and choose Replace photo… to replace

You can change the dimensions of the design if you want, but the default size is recommended for best 

results on most Social Media platforms.

When you’ve finished editing, you can Ctrl+S to Save and return to your main document, or click the Save 

button in the Open Graph dialog, or just close the tab.

Finishing & Publishing

Press OK or Apply in the Open Graph dialog when you have finished setting it up. Now just publish your 

website or document as normal and then try pasting a link to it into a Social Media platform to see your 

preview appear.

Shape Editing Improvements

When the end point of an open bezier curve is selected in the Shape Tool the InfoBar now shows the angle 

of the tangent and allows the user to edit it numerically. This helps when aligning the curve with other 

rotated objects in a drawing.

The open end points of bezier curves now project tangential angled constraints for the Smart Snapping 

system to use. When dragging other objects in the Selector tool, press “A” to turn on Angle snapping, and 

when any snap point gets close to the tangent the point will be snapped to the tangent with indication. 

This helps when aligning objects to the angle from the end of the curve.
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Numerical control of the angle of the tangent and improved snapping

Other Fixes & Improvements

• Advanced locking fixes.

• PDF Import: Single page PDFs imported into an existing document now correctly import as a new 

page.

• Word Export: Some images appeared inverted. Fixed.

• Web Export: JQuery update to latest version.

• PowerPoint Import: PP file caused serious error in Pro+. Fixed.

• PowerPoint Import: Table positioned wrongly. Fixed.

• Selector Tool: Selection handles sometimes not cleared completely on selection change. Fixed.

• Selector Tool: Improved performance selecting very large groups.

• Text: Inserting rule-off in a list now ends the list.

20°

New Smart Snapping constraint 

when you press A while dragging 

in the Selector tool

Angle of bezier curve at the end point 

reported in Shape Editor tool infobar
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Version 21.5 (3 Aug 2021)

Web Improvements

Use Photo Filename

Many customers have asked why the photos in their published website don’t use the original filenames of 

the photos that they imported, so that Search Engines can find and index those names. That’s because it’s 

not always helpful to expose those names in your public website - some filenames may be inappropriate 

and others may having nothing at all to do with subject of the site and so could be worse for SEO rather 

than better. Also of course most photos from digital cameras have meaningless names anyway.

Therefore users can control what names are used for image files in the published website or web 

document. The Utilities > Web Properties > Image tab lets you set any name for the selected photo and 

that name will then be used for the photo’s filename. And since sometimes the photo’s original filename is 

useful there is now an additional Use photo filename button that will instantly fill that name field for you 

with the selected photo’s original filename (if it has one). Only use this if the photo filename is meaningful 

and relevant to the content of your site.

Canonical Links

A canonical tag is a way of telling search engines which specific URL to treat as the master copy of a page, 

thereby preventing SEO problems caused by identical or "duplicate" content appearing on multiple URLs.

Publishing a web page to your domain might mean the same page is served when visiting the web page 

address with or without the www prefix and on both HTTP and HTTPS protocols.  This can appear as 

duplicate content to search engines.  Applying a canonical link will suggest which URL to show in search 

results and allow search engines to count links pointing at different versions as links to the canonical 

version.

A <link rel=canonical> is now automatically applied to the <head> of your web page when you publish to 

Xara Hosting  / MAGIX Online World. If you are publishing to Other Web Host, enter the URL you want set 

as canonical in the Website URL field.

links with target="_blank"

A link that is set to open in a New window or tab (_blank) will now automatically have the ‘noopener’ and 

‘noreferrer’ attributes applied. This is a security improvement to prevent the targeted page from gaining 

access to the referring page.

Web fixes

• Alt text added to web document viewer buttons

• Videos mis-positioned on popup layer. Fixed.
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Show Printer Colors

The Show Printer Colors option in Window > Show Printer Colors has been replaced with Show 

Profiled Colors. As the name suggests, in this mode all HSV and RGB colors in your document are 

processed using the current document’s selected color profile, in the same way as when your document is 

exported to PDF/X for printing purposes using the same profile. So in this mode the on-screen 

appearance of these colors should now more closely match how the colors will appear in the PDF. And the 

colors seen on screen will vary, depending on the color profile used (as set in Utilities > Options > View).

Note that this mode does not change the on-screen appearance of any CMYK colors in your document, as 

these are always displayed by applying the same document color profile.

Text Improvements

• Google fonts update: Another 21 new fonts added.

• When pages in a flowing document are re-ordered, page breaks are now added to prevent text 

moving between pages, which can be confusing.

• Spell checker: Each SmartField is now treated as a separate word.

• An unexpected font size change after outdenting of a sub-list has been fixed.

Import/Export

• PowerPoint import: Some sub-headings appear too bold. Fixed.

• PDF to Word: Misplaced text. Fixed.

• AI file from stock illustrations in Content Catalog failed to import. Fixed.

• Word import fixes.

• PDF import fixes.

Other Fixes/Improvements

• Dialog width/height text pixelated while editing Open Graph graphic. Fixed.

• Button palette not displayed correctly on some screens. Fixed.

• Trapezoid shape issue. Fixed.

Version 21.6 (6 Dec 2021)

Web Export Improvements

Shapes as SVG (Scalable Vector Graphics)

Modern web browsers have great SVG support, which means we can now export many more types of 

graphical object to web using SVG, instead of having to make separate bitmap image files for each one. As 

a result your website and web documents load faster - with all the usability and SEO benefits that brings -

because there are fewer bitmap images to download. What’s more, your content also looks sharper as 

SVG.
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All you need to do is turn on the new Shapes as SVG option at the bottom of the Utilities > Web 

Properties > Website tab. Then Xara will automatically use SVG for as many objects as it can when 

exporting your document for the web. Flat fills, linear graduated fills and circular graduated fills, all now 

export as SVG. Which means it’s now possible to build graphically rich web documents and websites that 

have no images to download at all!

Online Help

Designer Pro+ help is now online. The various Help buttons throughout the application now open your 

default web browser onto the online help system, where you can browse and search the help, just as you 

could with the locally installed help in earlier versions.

Having the help online allows Xara to update it more frequently without having to release application 

updates, and to integrate it with the online knowledgebase articles.

Live Copy Improvements

Live Copies allow you to create multiple copies of any image that can be updated simultaneously with a 

single edit (similar to Repeating Objects, but more flexible since you can have multiple Live Copies on a 

single page and they don’t have to be in the same position). It’s a valuable time-saving feature for 

illustration and document creation.

We’ve made various improvements, which will make working with Live Copies easier and more flexible:

• Deleting/cutting a Live Copy no longer prompts you to confirm that all instances of the Live Copy 

should be deleted, as this is rarely needed.

• Double-clicking on a Live Copy will now always initiate an ‘edit inside’ on the Live Copy. Previously 

this worked for multi-object Live Copies, but not for single object Live Copies.

• Now when you edit a Live Copy the ‘edit inside’ view shows the design with its original size and 

orientation, even if the Live Copy has been rotated/scaled. This generally makes editing easier.

• You can now easily partition a set of Live Copies into two separate sets. In the following example 

there are 6 instances of the same Live Copy design. Editing any one of them will also change all the 

others, because they are all part of the same Live Copy set.

1 Live Copy Set 

But what if you want to make the last 3 look different to the first 3?

Now you can simply select the last 3 objects and choose the Live Copy > Make Unique Live Copies
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option on the right-click context menu. Now you have 2 separate sets of Live Copies, so you can edit one 

of the last 3 objects to make them different.

2 Live Copy Sets

Multi-line SmartField Values

SmartFields are another great time-saving feature of Xara Designer Pro+, offering an efficient way to deal 

with commonly used text phrases that you want to insert in multiple places in text.

In this update we’ve added the ability to have multi-line SmartFields. Open the SmartFields dialog 

(Utilities > SmartFields…), select a SmartField in the list and press the new Edit button, to bring up the 

multi-line text editor.

SmartFields can now be multi-line- postal address is a typical example
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Where a value has more than one line, only the first line is displayed in the dialog and a … symbol in the 

right column indicates that the SmartField has more than one line. You can also click in the right side 

column to bring up the multi-line editor and see the full multi-line text. Note you can still edit single line 

values directly in the dialog.

Other Improvements & Fixes

• Improved AI import, including support for more recent AI versions.

• Wrong font sometimes applied to text in PDF export. Fixed.

• PDF form field import/export fixes.

• Spelling dictionaries updated.

• Web publishing (sFTP). Compatibility problems with some external hosting services solved.

• SVG file with linear gradient failed to import. Fixed.

• Overlapping text in exported SVG. Fixed.

• Error sometimes shown moving mouse pointer over text inside shape. Fixed.

• Clipped Opacity Mask Group incorrectly rendered after move. Fixed.

• Dead accent key handling fixed, when working on text inside smart components.

• Canonical links in conventional websites now reference the correct page filename.

• rel=”noopener” can now be stripped from a web link with a blank target by applying the name 

“opener”.

• WebP web export option could sometimes be auto enabled when saving a template after applying a 

page background. Fixed.

Version 21.7 (17 Feb 2022)

Web Export Improvements

More use of SVG (Scalable Vector Graphics) for Faster Sites

Following on from the previous 21.6 release, this update brings even more use of SVG into Xara web 

exports, further improving the speed with which your websites and web documents load - with all the SEO 

benefits that brings - as well as the sharpness of your content.

Given the importance of page loading time to page rank, this is a valuable improvement for your SEO 

efforts. Just make sure you have the Shapes as SVG option turned on at the bottom of the Utilities > Web 

Properties > Website tab. Then Xara will use SVG for as many objects as it can, when exporting your 

document for the web. New documents you create will now have this option on by default.

Wall Shadows as SVG

Wall Shadows created with the Shadow Tool will now export as SVG instead of as images. Wall shadow is 

by far the most commonly used type of shadow. Floor shadows and Glow shadows will continue to 

export as images, due to a lack of direct support for these shadow types in SVG.
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Elliptical Fills as SVG

Elliptical fills are now also exported as SVG, in addition to Flat, Linear and Circular fills which were already 

supported.

Mix & Multiply Transparency as SVG

Objects with Mix or Multiply transparency are now also exported as SVG. 

Export group as single image

Sometimes you may want to force a group of objects to export as a single image, even when you have the 

Shapes as SVG option on. There has always been an option for this, but the UI for this is now clearer and 

simpler, at the bottom of the Utilities > Web Properties > Image tab.

New groups export as SVG

With this update, new groups you create (Arrange > Group) when Shapes as SVG is on, will export as SVG 

unless you deliberately turn on the above Export group as single image option for the group.

And the same applies to groups created by importing graphics from SVG or PDF files - these groups will 

also now export as SVG by default. This means most of the Illustrations in the Content Catalog (Insert > 

From Content Catalog, Stock Illustrations), will also export to web as SVG, with all the benefits that 

brings.

Improved performance of websites across mobile and desktop devices

In addition to the SVG changes, we’ve made other refinements that will help improve page load speeds for 

the benefit of your SEO:

• Several JS files are no longer exported when not required.

• Optimized CSS by removing deprecated fall-backs.

• Reduced render blocking scripts.

• Up to 15% improvement in performance for mobile devices in our own tests.

Shape Tool

A nice improvement for vector illustration has been made to the Shape Tool, with the introduction of an 

easy way to maintain the angle of the bezier curve when you drag its handles to change its length.

Now when dragging a point or curve handle you can hold down Alt to constrain the movement of the 

handle relative to its original angle with nearby points.
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It works for both curve handles:

(the Shift key can also be used to balance the control handles around the selected smooth point) 

and point handles in shapes with straight lines:

(In this case the Shift key chooses which of the two possible angles connected to the selected point should 

be used to constrain the angle of the dragged handle. See the Online Help for more details.)

Other Improvements & Fixes

• TIFF import: Support for zip compression added

• Serious error importing an AI file with missing data. Fixed.

• Opacity mask group on Live Copy rendered wrongly after Live Copy edit. Fixed.

• Resize of photo filled shape changed shape to rectangle. Fixed.

• Serious error on starting text edit due to mis-handled font. Fixed.

• Serious error with repeating objects on guides layer. Fixed.

• PDF Import: Reconstruction of shape outline and shape fill into single shape.

• Default photo optimization resolution increased to 300dpi for print documents.

Alt constrain angles 
Alt+Shift constrain angles

Alt constrain angles

https://helpandsupport.xara.com/xara_desktop/product_support/drawing_lines_and_shapes/constraining_lines.html
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Version 21.8 (9 March 2022)

Automatic self-hosting of Google Fonts

Google Fonts are immensely popular with web designers, providing a huge library of quality fonts with 

good cross browser support, which is why we provide seamless support in Xara Designer Pro.

However a recent court decision in Germany has cast doubt on whether calling fonts from Google is 

compatible with GDPR (because it passes the IP address to Google). Xara has reacted quickly with this new 

release of Designer Pro+, which offers instant compliance by automatically publishing any Google Fonts to 

your web space, and no longer referencing Google. All you need to do is republish your website.

Xara’s automatic self-hosting makes an otherwise complex workflow simple, but there could be 

performance and SEO benefits too. In the past, it was considered better to link to Google Fonts and not 

self-host fonts because of browser limitations. But with modern browsers, that is changing. Now self-

hosting fonts can improve page speed and Web Vitals score, with all the SEO and page rank benefits that 

implies.

Font Menu Improvements

• The font menu used to automatically scroll to the current font when opened. This meant that the 

most useful part of the font menu, the top section that shows the fonts used in the current 

document, was often out of view. So now the menu always opens with the top of the font menu 

visible.

• Some font type icons missing in the menu, on HiDPI displays. Fixed.

Version 21.9 (April 2022)

Web Windows to Edge

There are several functions in Designer Pro+ that bring up a web browser window inside the application, 

to display content, including:

The Widget editor

Used when inserting/editing most of the widgets available in the Online Content Catalog.

Google Font Finder

Launched when you click Add in the Google Fonts section of Fonts menu.

Symbol picker

Launched when you click Insert > Symbol
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Erase Tool Guide window

Until now these have relied on using a variant of Internet Explorer. But since Internet Explorer is coming 

to the end of its life and support for it on the web is declining, it’s time to upgrade these windows. The 

Widget Editor in particular was becoming a problem, as external widget provider websites have been 

dropping support for Internet Explorer.

So with this update, all the above web windows are now using the latest Microsoft Edge technology 

instead.

Text Improvements

Numbered Lists - show all level numbers

Normally when using Numbered Lists, only one number is shown at the start of each list point, as in the 

left example below. But now there is also the option to show parent numbers too, as shown in the 

example on the right:

This new option is available in the List Properties dialog. To show the dialog, place the text caret in a list, 

right-click and choose List properties … in the context menu.

1. Level 1 point 1

1. Level 2 point 1

2. Level 2 point 2

i. Level 3 point 1

2. Level 1 point 2

1. Level 2 point 1

3. Level 1 point 3

1. Level 1 point 1

1.1. Level 2 point 1

1.2. Level 2 point 2 

1.2.i. Level 3 point 1

2. Level 1 point 2

2.1. Level 2 point 1

3. Level 1 point 3 

Previous level numbers OFF Previous level numbers ON
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Insert Page Count

It’s long been possible to show a page number on every page (use Insert > Page number and Arrange > 

Repeat on all pages). Now you can also show the total page count with the page number (for example on 

this page, Page 43 of 71), using Insert > Page count.

Note that this option only works for inserting at the text caret, so go into the Text Tool and place the text 

caret in text before inserting.

Change font size and Auto-fit

Auto-fit is a feature on a text area, whereby the font size of the text is set automatically by Designer Pro+, 

so that the text fills the text area container exactly. See the vertical text alignment option on the Text Tool

InfoBar .

This works even when you have a mix of different text sizes - the relative size differences are maintained. 

However if all the text is the same size, and you don’t realize that auto-fit option is on, it can be confusing. 

Attempting to change the font size manually will do nothing, because the font size is set automatically. It’s 

an easy mistake to make if you’re editing a template and don’t realize that auto-fit is on.

So now if you attempt to change the font size on all the text in a text box with auto-fit on, auto-fit is turned 

off automatically, so that the text size change will just work. The same happens with the related Shrink 

text on overflow option.

Other text handling fixes

• Serious error merging in List Styles on paste/import. Fixed.

• CID font Noto Sans causes serious error. Fixed.

Web export improvements for mobile

We’ve made some changes to the way exported documents/websites work on mobile and touch devices, 

to improve the user experience:

• A swipe will no longer change page if there is an active text selection (if the user is trying to select 

text on a touch device, by dragging on the selection markers on the text, it shouldn’t navigate to the 

next/previous page if the user misses the selection markers with their drag).

• A vertical swipe will no longer change pages on pages with vertical scrolling (on long pages that 

won’t all fit on the screen, the user needs to scroll by swiping up/down. Therefore this shouldn’t 

navigate to the previous/next page, only horizontal swipes should).

• Improved page animations on pages with vertical scrolling. 

Other web export fixes:

• Some characters missing from web export due to self-hosting of Google Fonts. Fixed.

• Can’t interact with a form that has reveal animation applied. Fixed.
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Other Import/Export Improvements

• Wrong miter on imported SVG. Fixed.

• WebP export fails after exporting a low bpp PNG. Fixed.

Version 22.0 (July 2022)

A New Subscription Option From Xara

We’re happy to introduce a brand new stand-alone option for Xara Designer Pro+. Our Cloud Pro+ bundle 

with Xara Cloud is still available if you want to use these 2 great products together (for example if you are 

collaborating with a team on your documents, or need to access your documents remotely) but now you 

also have the option of subscribing to Designer Pro+ alone.

Tip: Both these options offer all the advantages of a subscription model, namely frequent delivery of new 

features and content, as they are developed by Xara, and the fastest possible response to new 

compatibility issues and bug reports. You can always be sure you’ll have the latest version. What’s more 

the + options come with direct support from Xara, via chat.

New Look User Interface

Xara Designer Pro+ has a new, clean, modern appearance. 

Key highlights:

• The new darker background puts more focus on your design, with less user interface distractions

• There are new, clearer icon designs throughout.

• All icons and mouse pointers are now High DPI, so they look sharp and clear on high resolution 

displays

• And other minor tweaks and improvements - for example in the Page & Layer Gallery, the Page 

names are now separated from the page thumbnails, so both are clearly visible.
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Other Improvements & Fixes

Text

• External text pasted into list not added as list items. Fixed.

• Serious error in flowing document as anchored object flows up.

Web Export - Buttons

All buttons under Components > Buttons in the Online Content Catalog have been updated.  These are 

now SmartShape buttons. The entire button, including mouse-over state, reside on a single layer instead 

of parts of the button being on the MouseOver layer as with previous buttons. This makes it easier to use 

buttons in multi-layer designs. It’s also easier to change their widths and to resize them.
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Other Web Export

• Repeating photo failed to ‘stick at top’. Fixed.

• Some non-JPEG images get exported as JPEG in web export. Fixed.

• Web export hung exporting specific document with repeating group. Fixed.

• Links applied to list paragraphs should not include the list bullet/number.

• Error using popup photo feature with photo gallery widgets.

• Image Alt-text missing in web export of document.

Other Import/Export

• Word document caused serious error on import. Fixed.

• EPS import fix.

Other

• Templates updated with latest widgets.

• Company and licensee information now shown correctly in Help > About.

• Opening color editor onto page color initially shows ‘no color’. Fixed.

• Applying color to a page no longer turns on page shadow automatically. Page shadow can still be 

turned on/off in File > Page Options … .

• FX Painter Tool profile adjustment not working. Fixed.

Version 22.1 (5 Sept 2022)

Table Tool

Tables are often a key part of any business document, which is why we’ve been working on a new, very 

flexible and powerful Table Tool, to replace the old Smart Table SmartShapes. You will find the new tool at

the bottom of the main Toolbar on the left .

The Table Tool InfoBar is where you can change the settings for a selected table or selected cells in a table.

Create table

Cell spacing

Table background color

Insert rows

Row height

Delete rows

Insert Columns Column width

Delete column

Cell padding

Cell horizontal justification

Cell vertical justification

Cell background color

Merge and split cells

Cell borders
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Creating Tables

In the Table Tool, click the first button on the InfoBar to quickly create a new table . Or you can click-

drag on the page, to drag out a new table with the number of rows and columns you want.

There’s also a great range of professionally designed tables in the Online Content Catalog (Insert > Table 

> Tables …), all the existing table designs have been updated and we’ve added 20 completely new designs.

Some of the table designs in the Online Content Catalog

Table Size

In the Selector Tool, single-click to select the table, then simply drag the table width/height handles to 

change the width/height of the whole table. Or you can set the width and height in the InfoBar, as you 

would with any other object.

Changing Rows & Columns

When you have a table selected in the Table Tool, move the mouse pointer over the hotspots as shown 

below.
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Using these controls you can quickly add rows and columns, change row and column sizes, select and 

delete rows and columns, all directly on the table without using the InfoBar. Use Ctrl+click or Shift+click on 

the row and column headers to select multiple rows/columns. Backspace will also delete a selected row or 

column (whereas Delete will delete the contents).

You can set the selected row heights and column widths on the InfoBar numerically, which makes it easy 

to give multiple rows or columns the exact same sizes.

Selecting Cells

Selecting cells you want to change is easy. First click to select the whole table, then in the Table Tool you 

can click on individual cells to select them. Or click-drag to select a rectangular range of cells. You can also 

Ctrl+click on a cell to add it to the current selection, or Shift+click to extend the current cell selection range.

You can also select multiple cells while in the Text Tool, by simply click-dragging.

Cell Contents

Once you have selected the cell(s) a simple Delete will delete the contents. The usual copy and paste 

commands will work, Ctrl C and Ctrl V. Font, font size and color can be changed like regular text.

Click on the dots to add rows/columns Click-drag on borders to change row/col sizes

Click here to select rows/columns Row selected - click to delete row
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Cell Background Color

By default cell background color is white. To change this, select the cell or cells you want to change, and 

click the new color you want in the Cell color background dropdown on the right side of the InfoBar, 

which includes all the theme colors in the current document. If you select the Edit option in that 

dropdown, you can open the color editor to create a custom color. Alternatively you can right click any 

color on the color line and select Set Table Cell Background.

Note there is also a table background color behind the cells, which you will see if you open up spacing 

between the cells; see Table Spacing below.

Cell Justifications

You can choose between left, right and center justified text using the buttons on the InfoBar.

Use the vertical alignment dropdown to choose between top, center or bottom aligned text in the cell.

Cell Borders

Click the Borders button  on the right end of the InfoBar to open the Borders dialog.

Borders Dialog

First select the cell(s) you want to change as this dialog always works on the selected cells only. In the top 

Border Filter section of the dialog you first choose which borders you want to change. For example if you

want to change only the right side of the whole cell selection, select the  filter. Then as you change the 

border style, width and color in the lower half of the dialog, only that right side border will change. If you

want to change all borders of every individual cell in the selection, choose the  filter, then again choose



Page 51 of 95

the border settings you want.

If you have a lot of different border colors, styles and widths in your table, you may have to perform 

several border changing operations on different cell selections with different Border Filters, but every 

possible combination of borders on a table is possible!

Cell Padding

Cell padding is the space you see between the text in a cell and the borders of that cell. In most cases it’s 

desirable to have some non-zero padding applied, so text doesn’t appear too close to the cell borders.

Table Spacing

The table spacing setting lets you add space between all the cells of the table. Most tables tend to have 

zero spacing, meaning that cell borders overlap with no space between one cell and the next.

The color you see in the spaces between cells, blue in the example above, is the Table Background Color, 

which you can also set using the Table Background Color dropdown towards the left of the InfoBar, or 

with a right click on a color in the color line > Set Table Background.

Merging & Splitting Cells

Select multiple cells and click the Merge button on the InfoBar, to merge them into a single cell. 

For example you can easily add a header row to a table by selecting all the cells in the first row and 

merging them into a single cell.

To unmerge/split cells again, select them and click the Split button.

Useful Table Shortcuts

• Double click on a cell in the Table Tool, to jump to the Text Tool and start adding/editing text in the 

cell.

• When you’ve finished typing in one cell, press Tab to jump to the next cell, or Shift+Tab to move to

0pt spacing 4pt spacing

Table Spacing

Table text with 

no padding

Table text with 

4pt padding

Cell Padding
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the previous cell. When you are in the last cell of a table, pressing Tab again will automatically add a

new row so you can keep extending the table.

• Clear the contents of all selected cells by hitting the Delete key. Delete will also clear the contents of 

a selected row(s)/column(s), whereas Backspace will delete the row(s)/ column(s).

• If you are in the Table Tool with a cell selected and you press the Return key, Xara will switch to the 

Text Tool and place the caret at the end of the text.

• You can set cell background colors and table background colors using the color line, as well as on 

the InfoBar. Select the cells, right-click on the color line and choose from the menu.

• You can drag and drop embedded objects between cells.

Other Fixes & Improvements

• Pasting list items from external source into list, did not add list items. Fixed.

• Docx file caused serious error opening in Designer Pro+. Fixed.

• Inserting components via the Insert menu will always brand the components with the current 

document styles and colors, without asking the user as previously.

• Missing handles in Mold Tool. Fixed.

• Scrollbar thumbs now more visible against scrollbar backgrounds.

• Installation problems for some users caused by missing MS VCRUNTIME DLL. Fixed.

• Can’t scroll to all pages in Page & Layer Gallery due to new page name position. Fixed.

New Web Themes (22 Sept 2022)
We’ve added a set of 20 new website templates to the collection - from cars and spas to food blogs and 

weddings. You can find them in the Online Content Catalog in a new Websites > Creative Websites 

folder. All include mobile variants.
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Version 22.1.1 (27 Sept 2022)

New Table Tool Fixes & Improvements

• Cell selection behavior with merged cells improved.

• Undo fails after resizing table column while a cell is selected. Fixed.

• Error when pasting a larger table into a smaller table. Fixed.

• Error after closing document with table cell selected. Fixed.

• Difficult to change cell background color.  Fixed.

• Status line text misleading for column grid position drags. Fixed.

• Applying borders to merged cells doesn’t work as expected. Fixed.

• Unselected table backgrounds still appearing when in Solo mode (Page & Layer Gallery). Fixed.

• Serious error resizing column with merged cells. Fixed.

Photo Color Selection Tool Fix

• Photo color selection tool not working as expected. Fixed.

Version 22.2 (05 Oct 2022)

Table Improvements

Re-order rows & columns

You can now re-order rows and columns using drag and drop. To move a single row, simply click+drag on 

the row header. As you drag up/down, a thick blue line shows you where the row will be moved to. To 

move multiple rows at once, first select the rows (use Ctrl+click and Shift+click to add rows to the 

selection) then drag on one of the row headers.

Similarly you can move columns left/right using the column headers.

Convert old tables to new

The old Smart tables will continue working as before, but will not be improved in future. But now with 

one click you can convert these to new tables, so that you can edit them with the new Table Tool.

The mouse pointer is over a row header - click+drag to move the row up/down
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Whenever you click on an old table, you’ll be asked if you would like it to be converted. You should see 

that the converted table look almost exactly the same as the old table, although you may see some small 

differences. The prompt will allow you to refuse the conversion and to turn off future prompts, but we 

strongly recommend you convert all old tables to new tables when you next need to edit them. Old tables 

will continue to work for now but may not be supported in future.

Other table improvements/fixes

• Some table context menu entries are inappropriate when merged cells are selected. Fixed.

• Minimum cell size reduced to 1mm.

• Problem copying and pasting cells containing embedded objects. Fixed

• Changing page height interactively is slow/difficult in documents with tables. Fixed.

Selection improvements

The following changes have been made to selection handling in response to user feedback and to make 

selection more consistent across different object types.

Offset handles

Selector Tool transform handles are now offset by a small distance so that they don’t obscure any part of 

the selected object, or get in the way of any other handles on the object. The offset remains constant for 

all zoom levels and does not affect object snapping.

In addition to the lollipop rotation handle, there are hidden rotate ‘hotspots’ just inside the 4 corner 

resizing handles (in the offset gap).

Selector Tool handles offset
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Rotate and Skew mode

If you click a second time on an object that is already selected, the selection handles change to show 

rotation and skew handles. Each time you click, the handles toggle between the two modes. You can also

change this mode using the  handle on the Selector Tool InfoBar.

The skew operation used to rely entirely on dragging hidden handles near the stretch handles or on the 

InfoBar field, which only skews in one axis. It was too easy to drag the hidden skew handles by accident

without realizing it, resulting in unwanted skew effects in a document. So the hidden skew handles have

been removed completely and skewing by dragging is now only available in Rotate & Skew mode, using

the new visible handles.

SmartShapes & Photos

The Selector Tool only shows SmartShape handles that don’t interfere with the (now offset) 

transformation handles. This means that the Selector Tool handles now always work consistently, 

whatever is selected.

Rotate & skew handles

Inside rotation hotspot (shown top right)
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The most significant result of this change is that photos can now be scaled and stretched by any of the 

selection handles. Switch to the Quickshape Tool tool to see all the handles of a SmartShape and to the 

Photo Tool to see all photo related handles.

Double-clicking on a SmartShape now switches to the Quickshape Tool where all its handles are always 

available, just as double-clicking a photo switches to the Photo Tool.

Note the two different effects of dragging photo stretch handles:

• In the Selector Tool stretching keeps the center of a photo in the center of the object and only 

scales the photo if it needs to make it fit the new shape. This is the least intrusive way to stretch a 

photo without distorting it and is appropriate when the photo is being stretched along with other 

objects.

• In the Photo Tool stretching the photo shape keeps the photo position fixed and only moves it, or 

starts to scale it, if required to fill the shape. This is most appropriate when editing a photo on its 

own.

Stretching & Squashing

Wherever possible, stretching objects will stretch their outer shape and automatically reformat the 

contents to fit in the stretched shape, without distorting. For example when stretching a rectangular 

object that has rounded corners, the corners won’t distort, they’ll remain circular. This is called Smart 

Transformation and it prevents the introduction of unwanted or accidental distortion into documents.

However, sometimes you may want to deliberately stretch both an object and its contents (e.g. to 

stretch/distort a photo or some text).

It is now possible to stretch any object, including Text and Photos, by holding down the Alt key to disable

Selector Tool handles Photo Tool handles
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Smart Transformation when dragging the Selector Tool’s stretch handles.

Other Selector Tool fixes/improvements

• The Selector Tool now shows the full width of a text column, instead of just the width of text in the 

column. This makes text columns consistent with text areas/boxes.

• Serious error dragging Smart Duplicate handle on objects with Push applied. Fixed.

Make Repeating

Repeating Objects are used where you want the same object to appear on multiple pages of a 

document, in the same position on each page. They are most commonly used for page headers and page 

footers. Until now the only way to make an object repeating was to use the Arrange > Repeat on all 

pages operation. This makes a copy of the object on every single page of the document. This is great if 

you want the object on every page, but sometimes documents have more than one different page design

Stretched with Alt key (photo IS distorted)

Stretched without Alt key (photo IS NOT distorted)
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and you may want one Repeating Object only on some of the pages and perhaps a different Repeating 

Object on other pages.

Now there is a new operation Arrange > Make repeating, which simply makes the current selected object 

into a Repeating Object, without making any additional copies of it on other pages. Once you’ve done 

this, you can then copy and paste the Repeating Object to whichever pages it’s needed on. Note that you 

can achieve this very quickly by first selecting the target pages in the Page & Layer Gallery (use Ctrl+click 

and Shift+click to select multiple pages in the gallery), then paste, and the object will be pasted onto all 

the pages you selected.

Align Toolbar

The distribute options on the Align Toolbar (Window > Bars > Align) have been changed from Distribute 

centers, to Distribute equally spaced, which is more commonly used because it works well with objects 

of different sizes. The Arrange > Alignment dialog still includes the center distribution options.

Other fixes & improvements

• Inconsistent font sizes when pasting same sized text into ‘Shrink on overflow’ text boxes. Fixed.

• Icon line widths wrong when replaced with SVG. Fixed.

• Serious error opening Document info with specific document. Fixed.

• Help users recover from unusual installation, update and activation errors.

• Check and (when necessary) fix the Windows Explorer ‘thumbnail view’, automatically during 

program startup.

• When replacing a color in an object, Xara will no longer preserve shading if there is only one shade 

of the color used. The user’s chosen color is applied directly instead.

New Templates (12 Oct 2022)
A bonanza of 200+ new web & print templates in the Online Content Catalog of Xara Designer Pro+:

• 2 website themes, in addition to the 20 added last month (in Websites > Creative Websites)

• 57 extra tables, so you can make the most of our brand new table tool (in Components > Print & 

Web Components > Tables)

• 42 social media buttons, to help you maximize the potential of social media (in Components > 

Print & Web Components > Buttons > Social Media)

• 125 'fancy' buttons with creative outlines (in Components > Print & Web Components > Buttons >

Distribute 

horizontally

Distribute 

vertically
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Fancy)

• 3 restaurant menus templates (in Print > Menus)

• 1 invoice template (in Print > Invoices)

You can find them now in the folders indicated above or in the WHAT'S NEW folder in the Online Content 

Catalog.

New Photo Overlays (19 Oct 2022)
Almost 1300 extra Overlay Photo Filters in the Online Content Catalog of Xara Designer Pro+. Overlays can 

be added to your photo, even on top of other photo filters, to provide a massive array of different creative 

effects.

You can find them in Components > Image resources > Photo Filter Presets > Overlays, in 4 new 

categories (Bokeh, Color Gradient, Light Leak and Snow). Simply select your photo, then select the overlay 

and click Import.

1285 new photo overlays in the Online Content Catalog

Version 22.3 (24 Oct 2022)

Table Improvements

Copy/paste external data into Tables

An important step forward for our new Table Tool. You can now copy and paste text and numbers from 

your spreadsheets and other sources into Xara tables. Simply copy the cells you want to copy in your 

spreadsheet, then in the Table Tool select a table cell and paste (Ctrl+V).

Snow

Light Leak / White

Before After

Before After

Color Gradient

Light Leak / Blue

Before After

Before After
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Technical notes: This should work with data from any application that is able to place TSV (Tab Separated 

Values) as unformatted text onto the clipboard, when you copy it. If you find it doesn’t work with an 

application you use, please let us know. Support will be added for pasting data from HTML format in a 

future release.

Other Table fixes & improvements

• Table reformatting fixes.

• Pasting an image into a selected cell in the Table Tool now works as expected.

• Pasting an image into a cell no longer increases the row height excessively.

• Error deleting rows that are part of a merged row. Fixed.

• Error pasting RTF tables. Fixed.

Other fixes & improvements

• We’ve added an option to apply page settings changes to all pages. See the Page Size tab of the 

Utilities > Options  dialog.  So, for example, this allows you to change the bleed margin settings 

across all pages of a document, even when the All pages the same option (in the same tab) is off.

• Error when pasting list items into an existing list. Fixed.

Version 22.4 (08 Nov 2022)

Table Improvements

Paste of multi-line text

We have improved handling of multi-line text when copy and pasting data from external applications such 

as spreadsheets into your Xara tables, see 22.3 above.

Paste unformatted

Sometimes when working with tables you’ll want to copy the contents of one table to another table. If you 

simply copy the cells of one table, and paste them onto another, this will also paste the style of the source 

table cells, as well as the content.

Now there is a new Paste unformatted option, in the right-click context menu. So to paste just the cell 

contents, copy (Ctrl+C) the source cells in the first table, select the target cells in the second table, then 

right-click and choose Paste > Paste unformatted from the context menu.
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Other table fixes & improvements

• Other clipboard handling improvements.

• Tables don’t always redraw correctly after width/height changes. Fixed.

• Error when importing a particular table with color matching. Fixed.

• Extending row selections using the Shift key is now more reliable.

• Error when exporting a PDF while table cells are selected. Fixed.

• Can’t click/drag on a table’s background to select/move the table. Fixed.

Other Improvements

• Print options: The options in the print dialog have been renamed to make it clearer at a glance what 

they do: Automatic is now more helpfully described as Actual size and Fit as Best Fit. Tip: if you 

select Best Fit your design is moved to the center of the page and expanded or shrunk to suit the 

paper size, the print dialog will show the degree of scaling.

• Second and subsequent pastes of the same clipboard contents now work the same way as the 

initial paste (a list of formats to choose from is shown, if there is a choice). This means if you don’t 

like the results of the first format you choose, you can simply paste again and choose a different 

format, without having to re-copy from the source application.

• Lock icons are now shown in an “unlocked” or “locked” state.

New Web Themes (10 Nov 2022)
The template bonanza of 2022 continues with another 12 new website templates, all with the latest

Copy (Ctrl+C) Target selection

The result with Paste (Ctrl+V) The result with Paste unformatted
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animation effects and SEO optimizations - and totally customizable to fit your business or personal 

website requirement!

You can find them now in the Online Content Catalog in the new Websites > Creative Websites folder.

• All include mobile variants

• Now with a 1280 pix wide main variant for the best possible results on your 4K monitors (but of 

course they auto scale to lower resolution on other devices)

• Default image export is now WebP for faster loading, giving a better experience for your visitors, 

and better SEO results too.

12 modern new website themes added to the Online Content Catalog

Version 22.5 (07 Dec 2022)

Table Improvements

Export of tables to Word & PowerPoint

Xara tables now appear as editable tables in MS Word, when documents are exported to Word (.docx) 

format. Xara tables should now also look visually correct in exported MS PowerPoint (.pptx) presentations, 

but the tables are not currently editable in PowerPoint (text can be edited but the table won’t update).

Table Fixes

• Making a copy of a table by dragging on it with right mouse button down gives an error. Fixed.
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Font handling for missing characters

Automatic font selection

Xara Designer Pro+ now helps you to find and apply fonts that support characters that are not supported 

by the majority of Google fonts. For example if you enter or paste a Chinese character such as  into text 

that is using a typical Google Font such as Open Sans, the character won’t appear correctly because Open 

Sans does not support Chinese characters. Instead you will see  or similar in the text. Now when you 

enter such a character, Xara will check your device for fonts that do support the character. If it finds one, 

the font will be changed so you should see the character appear correctly.

When changing the font automatically in this way, Xara will choose a font that is already being used in the 

current document where possible, to avoid introducing lots of different fonts.

NOTE: Currently this automatic font selection only happens when pasting in unformatted text at the text 

caret, not when pasting from other formats such as HTML. Go into the Text Tool, place the text caret, 

select Paste and choose Unformatted text. This will be improved to include all types of paste in a future 

update.

Alternative Font Suggestions

If you don’t like the automatically chosen font, select the character(s) in the Text Tool, right-click and you 

should see a Font Suggestions entry at the top of the context menu. This shows you all the fonts installed 

on your device that support the first character in your text selection.

Font suggestions for selected Chinese character
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You’ll see the selection update to preview the font that is under your mouse pointer, so you can quickly 

choose which font works best.

Google Fonts

For Chinese, Japanese and Korean characters, Xara will first look for the most popular Google fonts that 

support the character set, if any are installed on your device. You can find the names of such fonts by 

searching for them on Google Fonts, using the Language filter, then download and install them onto your 

device using the Add option in the Google Fonts section of the Fonts menu in the Text Tool of Xara 

Designer Pro+. Once installed, you should see them in the main Fonts menu and in the Font Suggestions 

menu described above.

Line Gallery

In previous versions of Designer Pro, when interacting with the Line Gallery for the first time in every 

session, there was a delay of a few seconds while Xara downloaded all the different brush definitions that 

are available in the gallery. In some cases this also caused the current selection to be lost. This has now 

been improved so that each separate brush definitions folder is loaded only if/when needed, so there is 

no initial delay when using the gallery and the selection is always maintained.

Account menu

Designer Pro+ now has a new Account menu on the main menu bar. This currently contains options for 

managing your Xara subscription (upgrade your subscription, or update your billing address or credit 

card, download invoice) and for managing members of your team, if you are using Designer Pro+ as part 

of a team. Both options open in your default web browser. In future this menu will include other options 

for managing your account and device registrations.

Other improvements

• Scrolling and text editing performance improvements (noticeable with larger documents with many 

pages).

• Image export setting sometimes changed unexpectedly when page clipping option changed. Fixed.

New Photo Overlays (13 Dec 2022)
We’ve added another 1200 Photo Filter Overlays to the Online Content Catalog of Xara Designer Pro+. 

Overlays can be added to your photo, even on top of other photo filters, to provide a huge choice of 

creative possibilities.

You can find them in Components > Image resources > Photo Filter Presets > Overlays, in 4 new 

categories (Light Rays, Night Sky, Rose Petal and additions to Light Leak). To apply the overlay simply 

select your photo, then select the overlay and click Import.

https://fonts.google.com/
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Mix and match the filters and overlays for an almost infinite choice of photo effects

Calendar Templates (20 Dec 2022)
We’ve just added a new category of templates to the Online Content Catalog. You’ll find 12 new calendar 

designs in Print > Calendars, fully customizable to your brand - just in time to get 2023 off to a great visual 

start.

One of the new calendar templates in the Online Content Catalog
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Version 23.0 (13 March 2023)

Designs Gallery - Now Online

The Designs Gallery now automatically connects and updates online, so it has the same content as the 

Content Catalog, except for the stock photo & illustration and symbol libraries. So you can access the 

same content whichever way you prefer.

Generally the Designs Gallery is more convenient when importing components and other content into the 

current document, because you can use drag and drop from the gallery onto your document, instead of 

opening the Content Catalog on top of it. So for the maximum productivity, all the Insert menu options 

that insert objects from the catalog now open the Designs Gallery instead of the Content Catalog. The File 

> New from Content Catalog option works as before, because the larger window of the Content Catalog 

is usually best for browsing document templates.

New Widgets

Widgets are a powerful way to enhance the functionality of your website, which is why we've added a big 

selection of new widgets, both to existing categories such as e-commerce and forms, and in completely 

new categories such as chat and appointment managers. You can find them in the Online Content 

Catalog/Designs Gallery. What’s more we’ve improved the editing experience, see the section below on 

Widget Editing for more information.

Modular Websites

Check out our YouTube channel on Modular Websites and Web Blocks.

Welcome our new way of creating websites Modular Websites. Whether you need a simple landing page 

or a full featured e-commerce website, we guarantee that you won’t find a quicker and easier way to 

create that showstopper website that you’ve always imagined.

A Modular Website page is very simple; it’s just a vertical stack of ready-designed Web Blocks, one above 

another, with navigation controls at the top. Websites can be built very rapidly by just adding as many 

different Web Blocks as required to build up a web page. Add your content and you’re done. What’s more 

a mobile-friendly variant of the website is created automatically.

To get started with your Modular Website, you can choose one of the pre-built website templates from the 

Content Catalog and add/remove Web Blocks to customize it. Or you can begin with a Start Page which 

has just the navigation, and then drag and drop Web Blocks from the Designs Gallery one by one to build 

up your website.

All the capabilities for building websites without Web Blocks (now called ‘Freeform Websites’) are still 

available for more advanced users, but you will find that using Web Blocks is the simplest, quickest way to
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https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf
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build your new dream site.

A modular website with a Web Block selected

Getting Started: Choose a Template Website or Start Page

Ready-made website templates can be found in the Content Catalog or Designs Gallery, under Modular 

Websites > Website templates. Or if you want to start with just the navigation and build up your website 

yourself, choose Blank (website) from Modular Websites > Website Templates. There is also a blank 

Modular Website template, with just navigation, under File > New.

Adding Web Blocks

You’ll find a wide selection of different Web Block designs in the Designs Gallery under Modular 

Websites > Web Blocks. Double-click on an item in the gallery to add it to your website document. Each 

new block is added to the bottom, below all your existing Web Blocks. Or use drag & drop to insert at any 

position. You can then add your own content by editing text using the Text Tool, replacing images, etc.

Working with Web Blocks

Whenever you click on an object that is part of a Web Block, you’ll see a green Web Block bar appear to 

the left of the page, as shown below:
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Photo selected inside Web Block

Objects can be selected inside the Web Block with one click, then you can edit objects using the usual 

tools on the main Toolbar on the left; Text Tool for text, Photo Tool for photos, etc.

To select the Web Block itself, click on the Web Block bar. A green outline around the whole Block shows 

that it is selected, and the Web Block bar is brighter.

Web Block selected 

Deleting a Web Block

To delete an entire Web Block that you don’t want, simply select it by clicking the green bar and Delete. 

When a Web Block is deleted, any Blocks below it are automatically moved up to close the gap.

Changing the order of Web Blocks
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Web Block bar

Use the arrow buttons on the Web Block bar to move Web Blocks up or down. Or you can click-drag on 

the center of the bar and drag the block up or down. As you drag, a horizontal line appears between Web 

Blocks, to indicate the drop position.

Adjusting the height of a Web Block

Many of the Web Blocks can have their height adjusted by click-dragging on the bottom edge of the Block, 

as shown below:

Adjust Web Block height

Note the Web Block needs to be selected first (click on the green bar). Then move the mouse pointer over 

the bottom edge and you should see the mouse pointer change as shown above.

Copying Web Blocks

To copy a Web Block, select it by clicking on its Web Block bar and then use Copy (Ctrl+C) as you would for 

any other object. When pasting, the Web Block will appear immediately below the selected Block, or at the 

bottom of the website if there is no selection. You can copy and paste Blocks from one Modular Website 

document to another.

Widget Blocks

Some Web Blocks include dynamic content (widgets) that can considerably enhance the value of your 

website, such as video players, maps and forms. After you’ve inserted one of these Web Blocks, click on 

the widget inside it and you’ll see an Edit option appear on a context menu. Click Edit and a window 

appears allowing you to setup your widget. See the section below on Widget Editing for more information.

Move Block up 

Move Block down 

Drag to move Block up/down 

Click to select Block 
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Widget Editing

Now when you insert or edit a Widget you’ll see this new Widget window appear.

Widget Editor

For widgets that are provided by an external service, such as a Google Map, configuration of the widget in 

the external service is now done using your regular browser, instead of inside a web window inside 

Designer+. This means that signing into the external service will generally be easier, because your browser 

probably has features helping you sign-in, such as saved passwords or a password manager. Also you can 

work in a full size browser window, rather than in a smaller web window inside the application.

Press the Edit in browser button to open the external service in your default browser. Once you’ve setup 

your widget, copy the widget code from the external service and then come back to Designer+ to paste 

that code into the widget window.

Most widgets have an online help page available, which will advise you on how best to use the external 

service with Designer+, how to find the code in that service and other helpful tips. Press the How to get 

HTML code link to open this help.

There are some lesser used widget options in the Utilities > Web Properties dialog that are not available 

in this new window. Press the Advanced button to jump directly to this dialog, if you need to use these 

options.

Launch external 
service in browser 

Paste code from 
external service here 

Open online 
help page

Open Web
Properties 

dialog
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Table Improvements

The Table Tool InfoBar has been improved, with the Table background color and Spacing between cells 

options moved into a new Table Properties dialog.

Table Properties

Bring up the dialog by clicking the  button on the Table Tool InfoBar.

Header & Footer Rows

In the dialog there are new options for setting the number of header and footer rows on your table. This 

information is used when copying and pasting the style of a table from one table to another. To do this 

select a table and press copy (Ctrl+C). Then select a different table and do Edit > Paste > Paste 

format/attributes (Ctrl+Shift+A).

Header and footer rows will become much more important once tables can be split across pages and text 

columns, which is coming soon to the Table Tool!

Other Table Improvements

• Improved support for dotted/dashed table borders.

• Serious error right-click dragging a table from one page to another. Fixed.

• Table border widths wrong at some zooms in Chrome and Edge. Fixed.

• Text links not underlined inside tables. Fixed.

• Drag-selecting table cells could cause serious error. Fixed.

Web Fixes & Improvements

• New documents/websites will export to .html files instead of .htm. An option to change this for 

existing documents/websites is coming soon.

• NavBar sub-menu displayed without its background. Fixed.

• Alt text for background images.
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Other Fixes & Improvements

• Auto-bleed objects now created at full print resolution.

• Accounts menu now has options to jump to Team Profile and Downloads page

• Bring to front / Put to back / Move forwards / Move backwards operations now work on objects 

inside groups. Objects are moved relative to other objects in the same group.

• Text copied and pasted from PDF reader has incorrect case. Fixed.

• Can’t move text caret between consecutive embedded objects with arrow keys. Fixed.

New Modular Website & Web Block templates (29 

April 2023)
In a further boost to our new Web Blocks feature, we’ve added 12 new modular website templates, 92 

new web blocks and almost 300 new page background styles. You can find them in the Designs Gallery > 

Modular Websites and Web Blocks.

Web Blocks offer the quickest and easiest way to create a professional, mobile-ready website, and with all 

the new templates you can be sure that we have the layouts you need.

Just some of the 29 ready-made modular website templates, 328 web block designs and 500+ backgrounds

Version 23.1 (24 May 2023)

German Support

Designer Pro+ now supports both English and German languages. When starting the application for the 

first time on a device, it will use the current language as defined in Windows. Thereafter you can change 

the language at any time using Help > Language (requires an application restart).
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Accounts Menu

The Accounts menu now has some additional options to help you manage your Designer Pro+. 

Account details

This option shows you which account email and Team you used to activate Designer Pro+. 

Sign-out

Use this if you need to re-activate Designer Pro+ using a different account email or Team. This is 

important if you purchased Designer Pro+ using a different email address to the one you used to activate 

it.

Change sign-in details

This option opens your web browser to let you change the name or email address in your Xara account.

Other Fixes & Improvements

• Deleting all Web Block contents now deletes the whole Block.

• Link dialog: Link to page and Link to heading menus are now wider to show longer headings and 

page names.

• Spelling dictionaries have been added for Ukrainian and Amharic.

• Rendering artifacts sometimes visible in auto-bleed bitmaps. Fixed.

• Adding link to PDF doesn’t work if website is set to export to .html. Fixed.

Version 23.2 (5 July 2023)

Working with Responsive Websites

Using Web Blocks in Existing Websites

Our new Web Blocks offer an extremely easy way of to build a new Modular Website (see Modular 

Websites above). But now you can also use the wide range of Web Block designs in your existing (non-

modular) websites. You’ll find the Web Blocks in the Designs Gallery and Online Content Catalog, under 

Modular Websites > Web Blocks. Add a Web Block by double-clicking on it in the Designs Gallery, or 

simply drag & drop it onto your page. If you drop the Web Block onto an existing page it will be added to 

the bottom of the page, just above any footer, and it will automatically adjust to fit the width of your page. 

But you can now also create completely new pages in your existing sites, built from our large and 

constantly expanding library of Web Blocks.

Improved Positioning of New Live Shares

Now when you Live Share an object with other variants, it is positioned more usefully in those other
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variants, relative to neighboring objects. Where you need a different layout in the other variant(s), you will 

still need to manually re-position the shared object, but in most cases this will be a time-saver.

Other Web Improvements

• When you delete an object that is shared with other variants, a prompt offers to delete from all 

variants.

• Dragging live shared embedded objects between text areas doesn’t work across variants. Fixed.

• Widget/placeholder HTML Head code is now shared across variants, as body code is.

• Google Analytics code is now inserted immediately after <head> element, the current 

recommendation from Google.

• NavBar menus with links to headings not updated correctly. Fixed.

• Issue with cut & paste of Web Block. Fixed.

• Links to SmartFields would only open in current tab. Fixed.

• Undo of Web Block height change doesn’t work if smart transform is disabled. Fixed.

Personal SmartFields

The set of Personal SmartFields in Designer Pro+ (Utilities > SmartFields …) has been extended to match 

the fields in your Xara Cloud profile, so that templates and documents using these fields will work the 

same way in both Designer Pro+ and Xara Cloud. The new fields in Designer Pro+ are full address, website 

text, facebook text, instagram text, linkedin text, twitter text, tiktok text and link, adding to the great time-

saving potential of SmartFields.

Name Gallery Font Selection

The Name Gallery is a useful but sometimes overlooked Gallery that allows you to see which fonts are 

used on the current page, and select text that uses each font, a quick and easy way to identify which text 

on a page uses a particular font or font variant. A change in this release will ensure it now works reliably 

for all multi-weight and multi-family fonts.

Other Fixes & Improvements

• + handle disappeared on some SmartShape components. Fixed.

• Serious error importing SVG file that has embedded WOFF2 fonts. Fixed.

• The number of decimal places shown in the UI is no longer linked to Windows settings, which 

caused some user confusion. It now defaults to 2 decimal places and can be changed in the registry 

if required.

• The Designer+ automatic updater now closes the program automatically to allow update installation 

to proceed.

Content Update (5 July 2023)
This release also includes a very significant update to the template library in the Online Content Catalog 

and Designs Gallery, adding many of the Xara Cloud designs. You’ll find over 700 new creative choices in 

the templates / new categories as follows:
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Just a handful of the 50 new Facebook templates

Social media

YouTube (16)

Carousel Posts (18) - New Category

Instagram (66)

Instagram stories (20) - New Category

Facebook (50) 

Twitter (52) 

LinkedIn  (54)

Web

Skype backgrounds (8) - New Category 

Email Header banners (20) - New Category 

Email Signature banners (26) - New Category 

Web banners (80) - New Category 

Zoom background (26) - New Category

Print

Booklets (8) - New Category 

Business cards (46) - New Category 

Catalogs (11) - New Category
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Flyers (108 templates in 27 new themes) - New Category 

Letterheads (4) - New Category

Newsletters (4) - New Category 

Product sheets (51) - New Category 

Proposals (8) - New Category 

Resumes (8)

Invoices (7)

E-books

E-books (17)

Presentations

Presentations (37)

Version 23.3 (17 Aug 2023)

Navigation Bar Improvements

Change NavBar Style

Previously you could already change the style of your NavBar by 

dragging and dropping a new NavBar from the Designs Gallery onto your 

existing NavBar. This feature has been made more discoverable with the 

addition of a Change style button to the NavBar dialog, which opens the 

Designs Gallery onto the NavBars folder. Also you can now simply select 

your existing NavBar and doubleclick a NavBar in the Designs Gallery to 

change style.

New NavBar templates

We’ve added 101 all-new NavBar template designs to the Online Content 

Catalog/ Designs Gallery (have you seen the movie?).  You’ll find them in 

Print & Web Components > Navigation Bars in the new folders 

Standard, Glow, Bevel, Bitmap, Cartoon and Mobile (hamburger style).

Use any font in menus

You can now use any font you like in the menus on a navigation bar (NavBar), you are no longer limited to 

the restricted set of web-safe fonts. That means you can now use the same fonts you use on other text in 

your website, including the huge range of Google fonts.

https://www.youtube.com/watch?v=XBf487cy2m4
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NavBar Pop-up menu style - full font list

To change the menu font, double-click on your NavBar and use the Pop-up menu style … button to open 

the menu settings dialog.

Web Export Fixes & Improvements

• Link dialog can delay selection changes in documents with many links. Fixed.

• Web export problems when exporting with All layers/objects visible. Fixed.

• Spurious internal error on second attempt to publish. Fixed.

• Screen redraw problem after inserting Web Block from Designs Gallery. Fixed.

• Smart duplicate of live shared text column doesn’t work correctly. Fixed.

• Umlaut characters not appearing correctly in German popup photo tooltip text. Fixed.

• Links to pages wrong after insertion of Web Blocks with links. Fixed.

• German characters appearing incorrectly in popup message shown when previewing a single page 

of a presentation. Fixed.

• Menu now closes on touch devices after selecting a menu item.
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• Document causes export to web to hang during export. Fixed.

• Image Alt text is now shared across web variants.

• Web export of Open Sans Light font wrong when Bold applied. Fixed.

Other Fixes & Improvements

• Improved reporting of program activation problems.

• Holding down Alt while resizing image width/height now distorts the image, as intended.

• Very small objects could cause PDF export to error. Fixed.

• Serious error when applying elliptical transparency to a group. Fixed

Version 23.4 (31 Aug 2023)

Support for Dutch, Spanish & French

Designer+ now supports Dutch, Spanish and French, in addition to the English and German languages 

already available. When starting the application for the first time on a device, it will use the current 

language as defined in Windows. Thereafter you can change the language at any time using Help > 

Language (requires an application restart).

Other Fixes & Improvements

• Online help articles improved to help with publishing/FTP problems.

• Web export: Button clickable prior to being visible

• Various other small fixes & improvements.

Version 23.5 (14 Nov 2023)

Elements

Elements is the new name for what was previously known as the Online Content Catalog. As before, all the 

same content is available through Elements and in the Designs Gallery.

Improved Web Blocks

Web Blocks were introduced in v23.0 as an all-new way to create modern websites, more quickly and 

easily than ever before. In this release Web Blocks have been improved to make them considerably more 

flexible, while maintaining the ease of use.

You can now resize objects directly inside a Block, drag objects in and out of Blocks, or from one Block to
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another, and easily duplicate and delete objects inside Blocks. There is also now a new Flexible Web 

Block type, which automatically arrange the objects inside them. Most of the Web Blocks in the Designs 

Gallery are now Flexible, making them much easier to use and more powerful.

As with earlier versions of Designer Pro+, you can start building a website using Web Blocks by either 

opening a new blank Modular Website (File > New > Modular Website), or by opening one of the 

professionally designed Modular Websites in Elements (formerly Online Content Catalog) or in the 

Designs Gallery. Then you can add new Blocks to your site by dragging them in from the Web Blocks 

folder in the Designs Gallery.

Note you can’t directly create your own Web Blocks in Modular Website documents (the option for 

creating them is disabled in the Arrange Menu). But you can start with any Web Block from the Designs 

Gallery and simply add and remove objects (as described below) to change it into a completely new Block.

TIP: There is a new Introduction to Blocks 2 document in the Designs Gallery First Look > Introduction.

Web Blocks 2

A Quick Introduction to Using Web Blocks 2

Demo: 25 minutes to create a website from scratch using Web Blocks

Flexible Web Blocks

Flexible Web Blocks are Web Blocks that arrange objects inside themselves automatically, according to 

some simple layout rules that can be set on each variant of a Web Block. As more objects are added to a 

Flexible Web Block, or objects are made wider, they flow onto new rows automatically, to stay within the 

width of the page. For example if you start with the following 3 photo Block:

and you add 2 more photos, the layout is automatically adjusted to 2 rows of photos, because there is not 

enough space in a single row for all 5 photos:

3 photo Flexible Web Block

https://youtu.be/bkCYJhjg14g?feature=shared
https://youtu.be/IVzIiKBLAHg?feature=shared
https://www.youtube.com/watch?v=z97QkW81psM
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A Flexible Web Block won’t change the width of any of its objects automatically, it will just add as many 

rows as required to fit in all the objects, according to the layout rules set on it. With the above example, 

you could simply reduce the width of all the photos so they would all fit in one row. Or you might decide 

to make the last 2 photos wider, to better fill the second row.

Note the purple outline in the examples above. This outline is visible whenever the Block, or an object 

inside it, is selected and it indicates that this is a Flexible Web Block. If you don’t see the purple outline, 

that indicates the Web Block’s objects are positioned manually inside the Block.

In a Flexible Web Block each variant (Main and Mobile) can have its own separate layout settings, so the 

same objects can be arranged differently in each variant. With the 5 photo example above the photos 

would typically be arranged in a single column in the narrow Mobile variant. Each time you add another 

object, it is shared with the other variant and positioned according to the layout rules set in each variant.

All the Flexible Web Blocks in the Designs Gallery have been created by a professional designer and so 

already have appropriate layout settings in both Main and Mobile variants, so most users should never 

need to change those settings. But if you do need to change them, this is done using the Flex Layout 

toolbar described below.

Re-ordering objects

Click-dragging on an object that is inside a Flexible Web Block allows you to change the order of the 

objects in the Block. As you drag, a vertical purple line appears to indicate at which position the dragged 

object will be placed. In the example below, the red photo is being dragged from position 5 to position 2, 

so you see the purple line between the first and second photos as you drag:

2 photos added
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So the end result on drop will be:

Moving objects in and out of Web Blocks

With all Web Blocks in the Designs Gallery you can now easily add new objects to them by simply dragging 

the object over the Block using the Selector Tool. As do this, you will see the green Block bar, to the left of 

the page, light up, so you know which Block you are targeting. If it’s a Flexible Web Block you’ll also see an 

insertion point indication, as shown above in the Re-ordering example. On drop, the object is moved into 

the Block. If it’s a Flexible Web Block, it will be positioned according to the Flex rules in each variant.

Re-ordered

Re-ordering
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Otherwise the object will be left where you dropped it.

Whenever you add an object to a Web Block, it gets shared automatically with the other variant, so it will 

appear on both Main and Mobile variants. If the Web Block is not a Flexible Web Block, you will need to 

manually position the object appropriately in each variant.

Similarly you can also drag an object out of a Web Block, to remove it from a Block. Simply click-drag on it 

and move it to another Block, or drop it to the side of the page to remove it from the Block. Alternatively 

selecting an object and pressing the Delete key will delete the object.

When you initially draw, paste or import a new object into a Modular Website, it will not automatically be 

added to a Block. To add it to a Block, simply drag it over a Block, as described above.

If you want to have an object floating above or below a Web Block, rather than being part of the Block, this 

can be done by holding down the Shift key while dragging the object over a Block. This prevents the 

object being added into the Block. Similarly if you move a floating object you need to hold down Shift to 

prevent the object being moved into a Block on drop.

Advanced tip: If you hold down Alt while dragging and dropping an object onto a Flexible Web Block, the 

object is added into the Block, but it will be outside of the FlexGroup that is inside the Block.

Changing the height of a Block

Select a Block by first clicking on any object inside it, then clicking on the green Block bar to the left of the 

page (the green bar goes slightly darker and the status line says 1 Web Block …”. Then you can move the 

mouse pointer over the bottom edge of the Block and click-drag to change its height.

Normally you don’t need to adjust the width of a Block as they are the same width as the page. But 

sometimes, if you’ve added a very large object to a Mobile variant for example, the Block may exceed the 

page width. In these cases you’ll need to reduce the size of the object(s) to fit the page width, then reduce 

the width of the Block itself. Do this by dragging on the right or left edges, with the Block selected.
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FlexGroups

A FlexGroup is a new type of group that has the potential to save you a huge amount of time and effort! 

The objects within a FlexGroup are automatically arranged according to a set of layout settings, which 

control how objects are spaced in a row, horizontal and vertical alignment, etc. In Modular Websites a 

FlexGroup is used inside a Web Block, to make the Flexible Web Blocks described above. You can’t create 

your own Flexible Web Blocks or FlexGroups for Modular Websites (though you can of course edit the 

ones in the Designs Gallery), but you can create new FlexGroups for any other type of document, such as 

a presentation, classic website or print document. They are useful whenever you want to organize a 

variable number of objects on the doc, without having to manually space and align each one.

To create a new FlexGroup, select the objects you want to put in it and do Arrange > Create FlexGroup. 

To ungroup a FlexGroup, select it and use Arrange > Ungroup, or Ctrl+U, the same as for an ordinary 

group.

The layout settings are controlled the same way for a FlexGroup and for a Flexible Web Block, using the 

Flex Layout toolbar, described below.

The width of a FlexGroup is set manually by you and will never change automatically. But the height of the 

FlexGroup will vary according to how many rows are needed to fit in all the member objects.

Flex Layout Toolbar

This bar should appear automatically at the top of the Designer+ window whenever a Modular Website 

document is current. You can also turn this bar on/off in any type of document, using Window > Bars.

This bar shows the current layout settings for the selected Flexible Web Block or FlexGroup. Each of the 

available settings are described below.

Horizontal alignment

This setting affects how objects are positioned in a row if there is some spare horizontal space. With the 5 

photo example above, this will affect how the second row of 2 photos appears. There are 6 options for 

this setting:

Justify left

All spare space is on the right.

Horizontal alignment Vertical alignment Row alignment

Flex Layout Toolbar
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Note that the small spaces visible between the photos with the first 3 ‘justify’ settings is because each 

photo has its own object margin (see below).

Vertical alignment

This setting works the same way as Horizontal alignment described above, but in the vertical direction. 

Once again the setting only has an effect if there is some spare space vertically, that needs to be 

distributed.

Row alignment

This setting determines how objects in a row are positioned, if they don’t all have the same height. The

Space evenly

Equal spaces between each 

object and to the left and 

right.

Space around

Equal spaces between each 

object, half spaces left and 

right.

Space between

Equal spaces between each 

object, no space left and right.

Justify right

All spare space is on the left.

Justify center

Equal space to the left and 

right
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options are simply Top, Bottom or Center alignment.

Object Margin

This option allows you to set a margin around an object. For example in the 3 photos Web Block above, 

every photo has been given a 10px margin horizontally and vertically, so there will always be at least 20px 

between the photos. If you wanted the photos to touch each other with no space between them, you 

would set the margin to 0px on each of them.

You can give all objects the same margins, or set a different margin for each object. To set the margin on 

multiple objects together, select one object by clicking on it, then add more objects to the selection by 

holding down Shift and clicking on each in turn. Then you can change the margin values on the FlexGroup 

bar to set them all to the same value.

When an object is selected inside a Flexible Web Block, you can see some pale blue shading around the 

object that shows you the extent of its margins. In the example shown below, we’ve selected the last 2 

photos and increased their margins to 100px, to force much more space around them, as shown by the 

pale blue shading:

Top aligned Center aligned Bottom aligned
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Padding

This option allows you to add space around the whole Block/FlexGroup. When it is selected, the padding 

extent is shown in pale purple, around the contents of the Block. In the example below we’ve set 50px of 

padding horizontally and vertically:

Margins increased on the lower 2 photos
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Other Web Improvements

• Save publish settings in document option was being turned off if there are no publish settings. 

Fixed.

• Serious error adding text inside to object in Web Block. Fixed.

• Web export: Export of empty href without a nofollow. Fixed.

• Web font problems could be triggered by very long analytics code. Fixed.

• WebP export library updated, with latest security fixes.

PDF Export

Text using some fonts can look wrong at some zoom factors in Adobe Reader. This only happens with a

Padding increased
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very few fonts, but there is now a workaround for this in Designer+ 23.5 for the few occasions when this 

problem appears. A new option in the PDF Export Advanced Options dialog (General tab, Embedded 

fonts format) can be set to TrueType instead of the default setting of OpenType.

Other Fixes & Improvements

• On newly created documents, the document language is now set according to the current device 

language.

• Serious error optimizing a specific PNG file. Fixed.

• Tolerance and Fade controls not visible on Photo Tool InfoBar with some languages. Fixed.

• Serious error possible if font warnings are shown during program startup. Fixed.

• Serious error possible selecting inside photos with effects. Fixed.

New Web Content (14 Nov 2023)

What’s New 14th November

There’s also a significant boost to our content library to coincide with 23.5. You can find all this great new 

content in Xara Elements (formerly Online Content Catalog) and the Designs Gallery under Modular 

Websites:

• 5 new Website Templates created with the new Flexible Web Blocks

• A new block category Web Blocks > Section Headings with 19 new blocks

• A new block category Web Blocks > Sliders with 2 blocks (more coming soon)

• 20 new Web Blocks > Hero blocks

in addition the existing blocks have been updated to take advantage of the new Flexible Web Block 

functionality:

• 306 blocks have been updated to Flexible Blocks

• 29 Website Templates have been updated to Flexible Blocks

Last but definitely not least there is a new Introduction to Blocks 2 document in First Look > 

Introduction.

https://youtu.be/H4mDGal1HmQ?feature=shared
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New content includes 5 all-new websites created with the new Flexible Web Blocks

Calendar Templates (6 Dec 2023)
We’ve added 18 new calendar templates for 2024 (and updated the existing ones), you’ll find them now in 

Xara Elements (formerly Online Content Catalog) under Print > Calendars.

Introducing the New 2024 Calendars 

See how a calendar is actually created

Just some of the new calendar designs for 2024 in Xara Elements

https://youtu.be/J3kBS1OxMBU?feature=shared
https://youtu.be/poM1e-GTxzQ?feature=shared
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Version 23.5.1 (21 Nov 2023)

Web fixes

• Web export failed due to very long image filenames. Fixed.

• Anchor links sometimes scroll to incorrect position. Fixed.

• Ordering changes made to a Flexible Web Block are not reflected in the other variant if there are 

embedded objects included. Fixed.

• Copy/paste of a Web Block can corrupt links to pages. Fixed.

• Some Web Blocks in the Designs Gallery have text as images in web export. Fixed in live Designs 

Gallery.

• Links to popup layers not working. Fixed.

Version 23.6 (18 Jan 2024)

Web Blocks

Resize on live-share

When new objects are live shared across all variants of a Responsive Website, each copy created now gets 

reduced in width so that it will be no wider than the page in each variant. So for example objects created 

and shared in the Main variant will be reduced in width in the Mobile variant, if they would otherwise be 

wider than the Mobile page.

When this is done, photos are reduced in size without cropping them, so the image looks the same in all 

variants. But text columns, text panels, etc. are reduced in width only, so the text font size will not be 

reduced.

In the example below the green photo, which is the full width of the Main variant page, was added to a 

Web Block in the Main variant. In the Mobile variant, the photo is automatically resized so it’s no wider 

than the Mobile page width.
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Other Web Block Improvements & Fixes

• Info popup sometimes appearing incorrectly when adding new objects. Fixed.

• Objects on top of Web Blocks are too easily added to the Block accidentally. Fixed.

• Can’t select placeholder object if it’s the only object in a Web Block. Fixed.

• Margin settings could be lost from Web Blocks. Fixed.

• Problem with shadow added to object in flexible Web Block. Fixed.

• Objects could change dimensions when moved between Web Blocks. Fixed.

• Flex Layout toolbar appears when switching to any website document. Fixed - it now appears only 

when switching to a Modular website.

Publishing of stylistic changes to websites

Many users reported that when they change some stylistic aspects of their website and re-publish, not all 

visitors to the updated site see the changes immediately without having to press Refresh in their 

browsers. This is now fixed so that all visitors to the updated site will always see the updated version 

immediately.

Web Publishing Improvements

• Problem publishing filename with space in the name. Fixed.

• Problem updating website with Designer Pro+, if it was published with an older Magix version. 

Fixed.

• Support for Internet Explorer discontinued. This means websites no longer need to include 

additional legacy files that were required only for this old, unsupported browser.

Green photo resized to fit in Mobile Variant
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• Now easier to enable FTP logging/tracing to help solve FTP publishing problems. Press 

Ctrl+Alt+Shift+3 to toggle on and off.

Italian Support

Designer Pro+ now supports Italian, in addition to the German, Dutch, Spanish and French languages 

already supported. When starting the application for the first time on a device, it will use the current 

language as defined in Windows. Thereafter you can change the language at any time using Help > 

Language (requires an application restart).

Text Improvements

Google Fonts Update

The set of Google fonts has been updated, adding around 350 new fonts, as listed below.

A
ADLaM Display,AR One Sans,Aboreto,Abyssinica SIL,Afacad,Agbalumo,Agdasima,Akatab,Akshar,Albert 

Sans,Alexandria,Alkalami,Alkatra,Allison,Alumni Sans,Alumni Sans Collegiate One,Alumni Sans Inline One,Alumni Sans 

Pinstripe,Andada Pro,Anek Latin,Angkor,Anuphan,Anybody,Aoboshi One,Are You Serious,Aref Ruqaa Ink,Arima,Atkinson 

Hyperlegible,Azeret Mono

B
BIZ UDGothic,BIZ UDMincho,BIZ UDPGothic,BIZ UDPMincho,Babylonica,Bacasime Antique,Bagel Fat One,Bakbak 

One,Battambang,Bayon,Beau Rivage,Belanosima,Besley,BhuTuka Expanded One,Birthstone,Birthstone Bounce,Blaka,Blaka 

Hollow,Blaka Ink,Bokor,Bonheur Royale,Borel,Braah One,Bricolage Grotesque,Bruno Ace,Bruno Ace SC,Bungee Spice

C
Cairo Play,Caprasimo,Caramel,Carattere,Carlito,Castoro Titling,Charis SIL,Cherish,Cherry Bomb One,Chivo Mono,Chokokutai,Climate 

Crisis,Comforter,Comforter Brush,Comme,Corinthia

D
Dai Banna SIL,Dangrek,Darumadrop One,Delicious Handrawn,Diphylleia,Dongle,DynaPuff

E
Edu NSW ACT Foundation,Edu QLD Beginner,Edu SA Beginner,Edu TAS Beginner,Edu VIC WA NT Beginner,Ephesis,Estonia,Explora

F
Familjen Grotesk,Fasthand,Figtree,Finlandica,Fleur De Leah,Flow Block,Flow Circular,Flow Rounded,Foldit,Fragment 

Mono,Fredoka,Freehand,Fuzzy Bubbles

G
Gabarito,Gajraj One,Gantari,Gasoek One,Gemunu Libre,Genos,Gentium Book Plus,Gentium Plus,Geologica,Georama,Gideon 

Roman,Gloock,Glory,Gluten,Golos Text,Gowun Batang,Gowun Dodum,Grandiflora One,Grape Nuts,Grechen Fuemen,Grey 

Qo,Gulzar,Gwendolyn
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H
Hahmlet,Handjet,Hanken Grotesk,Hanuman,Hedvig Letters Sans,Hedvig Letters Serif,Hina Mincho,Hubballi,Hurricane

I
IBM Plex Sans Arabic,IBM Plex Sans Devanagari,IBM Plex Sans Hebrew,IBM Plex Sans JP,IBM Plex Sans KR,IBM Plex Sans Thai,IBM Plex 

Sans Thai Looped,Imperial Script,Inclusive Sans,Ingrid Darling,Inspiration,Instrument Sans,Instrument Serif,Inter Tight,Island 

Moments

J
Joan,Kablammo

K
Kaisei Decol,Kaisei HarunoUmi,Kaisei Opti,Kaisei Tokumin,Kalnia,Kantumruy Pro,Kay Pho Du,Kdam Thmor Pro,Kings,Klee One,Koh 

Santepheap,Kolker Brush,Konkhmer Sleokchher,Koulen

L
Labrada,Lavishly Yours,League Gothic,League Spartan,Libre Bodoni,Licorice,Linefont,Lisu Bosa,Love 

Light,Lugrasimo,Lumanosimo,Lunasima,Luxurious Roman,Luxurious Script

M
M PLUS 1,M PLUS 1 Code,M PLUS 2,M PLUS Code Latin,Marhey,Martian Mono,Material Icons,Material Icons Outlined,Material Icons 

Round,Material Icons Sharp,Material Icons Two Tone,Material Symbols Outlined,Material Symbols Rounded,Material Symbols 

Sharp,Mea Culpa,Meow Script,Metal,Mingzat,Mochiy Pop One,Mochiy Pop P One,Mohave,Moirai One,Monomaniac One,Montagu 

Slab,MonteCarlo,Moo Lah Lah,Mooli,Moon Dance,Moul,Moulpali,Ms Madi,Murecho,My Soul,Mynerve

N
Nabla,Narnoor,Neonderthaw,Nokora,Noto Music,Noto Sans Display,Noto Sans Gothic,Noto Sans Mono,Noto Sans SignWriting,Noto 

Sans Symbols,Noto Sans Symbols 2,Noto Serif Display,Nuosu SIL

O
Odor Mean Chey,Ole,Onest,Oooh Baby,Orbit,Outfit

P
Padyakke Expanded One,Palette Mosaic,Passions Conflict,Pathway Extreme,Petemoss,Phudu,Pixelify Sans,Playfair,Playpen Sans,Plus 

Jakarta Sans,Poltawski Nowy,Praise,Preahvihear,Puppies Play

Q
Qwitcher Grypen

R
REM,Radio Canada,Rampart One,Readex Pro, Red Hat Mono,Redacted,Redacted Script,Rethink Sans,Road Rage,Roboto Flex,Roboto 

Serif,Rock 3D,Rubik 80s Fade,Rubik Beastly,Rubik Broken Fax,Rubik Bubbles,Rubik Burned,Rubik Dirt,Rubik Distressed,Rubik Doodle 

Shadow,Rubik Doodle Triangles,Rubik Gemstones,Rubik Glitch,Rubik Iso,Rubik Lines,Rubik Maps,Rubik Marker Hatch,Rubik 

Maze,Rubik Microbe,Rubik Moonrocks,Rubik Pixels,Rubik Puddles,Rubik Scribble,Rubik Spray Paint,Rubik Storm,Rubik Vinyl,Rubik 

Wet Paint,Ruwudu
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S
STIX Two Text,Sassy Frass,Scheherazade New,Schibsted Grotesk,Send Flowers,Shalimar,Shantell Sans,Shippori Antique,Shippori 

Antique B1,Shizuru,Sigmar,Silkscreen,Slackside One,Smooch,Smooch Sans,Sofia Sans,Sofia Sans Condensed,Sofia Sans Extra 

Condensed,Sofia Sans Semi Condensed,Solitreo,Sometype Mono,Sono,Source Sans 3,Source Serif 4,Splash,Spline Sans,Spline Sans 

Mono,Square Peg,Stick No Bills,Style Script,Suwannaphum

T
Tai Heritage Pro,Tapestry,Taprom,Tektur,The Nautigal,Tilt Neon,Tilt Prism,Tilt Warp,Tsukimi Rounded,Twinkle Star

U
Unbounded,Updock,Urbanist

V
Vazirmatn,Victor Mono,Vina Sans,Vujahday Script

W
Water Brush,Waterfall,Wavefont,Whisper,WindSong,Wix Madefor Display,Wix Madefor Text

Y
Yaldevi,Young Serif,Ysabeau,Ysabeau Infant,Ysabeau Office,Ysabeau SC

Z
Zen Antique,Zen Antique Soft,Zen Kaku Gothic Antique,Zen Kaku Gothic New,Zen Kurenaido,Zen Maru Gothic

Other Text Improvements

• Can’t edit SmartField value if it’s in a Repeating Object. Fixed.

• Graphical numbered lists: numbers not updated when first pasting a graphical number to the list. 

Fixed.

Other Fixes & Improvements

Document Color Profile - None

Designer+ allows a Color Profile to be set on every document (Utilities > Options > View tab). This 

determines how CMYK colors appear on screen, because the color profile controls how each CMYK color is 

converted to RGB for screen display. With this update, the color profile is now optional, so you can select 

None as one of the profile options. When this is selected, CMYK colors will look the same on screen as 

when using older versions of Designer which did not have the color profile support.

PDF Import

• Some PDFs with ICC based images failed to import properly. Fixed.
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Bitmap Export Dialog

• Zoom tool no longer working. Fixed.

• Transparent option now always enabled and it automatically selects True Color + Alpha for the 

export when activated.

Other

• Stacking order changes not working properly with multi-selection. Fixed.

• SmartShape unexpectedly removed from document after intersect operation. Fixed.

• Help > Check for updates doesn’t always report when the program is up to date. Fixed.

• File extension registration messages now clearer, when shown on program startup.

• On-screen color separation preview incorrect when transparency is used. Fixed.

New Web Content (18 Jan 2023)
We’ve added another very significant boost to the web block and website templates, to give you an almost 

infinite variety of designs to inspire your new site. You can find all this great new content in Xara Elements 

(formerly Online Content Catalog) and the Designs Gallery under Modular Websites:

• 5 new Website Templates created with Web Blocks in Modular Websites > Website Templates

• 280+ new Web Blocks in Modular Websites > Web Blocks

Design the perfect fit for your brand with our fully customizable web templates 

TIP: Check out our Modular Websites playlist for help on making the most of Web Blocks and Modular 

sites, and don’t forget there’s also a new Introduction to Blocks 2 document in the Designs Gallery First 

Look >  Introduction.

The WebBlocks Playlist

https://www.youtube.com/playlist?list=PLGjVfxtAZwixFUrpxKjykyW5rWlxeoLcf

