Welcome to TalkGraphics.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1

    Default Damaged "printscreen"paste in v8...a bug?

    Hi,

    I'm having problems pasting a printscreen content into v8. When I do, Xara inserts the image but with missing information, like if it transparented it...I tested in v7 and that doesnt happens. I wonder what's wrong with this? Please see the attachment. In the left I put what I see in v8 and in the right, what v7 shows.

    Any ideas?

    Aram

    Click image for larger version. 

Name:	1.jpg 
Views:	78 
Size:	87.8 KB 
ID:	89900

  2. #2
    Join Date
    Aug 2000
    Location
    Placitas, New Mexico, USA
    Posts
    26,833

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Hello Aram

    I just tried it and had no problems. I wonder if it might have something to do with graphics cards?

  3. #3

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Works fine for me too..

    Looks somehwat like the OP has pasted the URL rather than used PrtScrn.

    Other things to consider are 3rd party clipboard managers, it has been demonstrated that these utilities can and do have adverse affects and consequences.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2012-05-30_121340.jpg 
Views:	27 
Size:	113.9 KB 
ID:	89901  
    Last edited by steve.ledger; 30 May 2012 at 03:14 AM.

  4. #4

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Hum, I just reset my PC and still having the problem. I don't have a clipboard manager, in fact, I don't have any funky utilities installed since I don't need much for what I do (web design, PHP coding)...and still works ok with v7

    PS CS5 works ok too...even Word
    Last edited by lithium258; 30 May 2012 at 04:33 AM.

  5. #5

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Someone else has just reported a similar issue here: http://www.talkgraphics.com/showthre...ency-(feature)

    Which build of DPX do you have installed?
    The version I have is 8.1.0.22207 May 11 2012
    If your version is older, go to Help>>Check to updates.

  6. #6
    Join Date
    Oct 2006
    Location
    StPeters, MO USA
    Posts
    6,167

    Default Re: Damaged "printscreen"paste in v8...a bug?

    I just checked this out and I seem to have the same problem as lithium258. For instance I did a Print Scrn of my desktop, and it pasted most everything except my wallpaper. and the text was black and not white. Version 7 did it perfectly.
    Larry a.k.a wizard509

    Never give up. You will never fail, you'll just find a whole lot of ways that don't work.

  7. #7

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Quote Originally Posted by sledger View Post
    Someone else has just reported a similar issue here: http://www.talkgraphics.com/showthre...ency-(feature)

    Which build of DPX do you have installed?
    The version I have is 8.1.0.22207 May 11 2012
    If your version is older, go to Help>>Check to updates.
    Yes thats the version I got from last night download...

    Also, correct as with the other user test: screen capture -> ctrl q pastes the bitmap ok
    Last edited by lithium258; 30 May 2012 at 04:40 AM.

  8. #8
    Join Date
    May 2004
    Location
    Xara Group Ltd
    Posts
    415

    Default Re: Damaged "printscreen"paste in v8...a bug?

    The pasting of alpha channel 32bpp bmps has been changed to preserve the alpha data in the bitmap to improve workflow with various other programs.

    We have seen this issue on a number of machines during testing but it hasn't yet been possible to draw many conclusions as to the root cause. It is presumably something to do with whether the video card drivers blank the alpha channel when in 32 bpp mode but we haven't isolated any particular video card/video driver/OS/other machine specs combination because the number of occurences has been too small.

    There is a registry entry that can be changed to disable this behaviour. Just set Options/Clipboard/PasteAlpha to 0 and it should return to the v7 behaviour. Usual disclaimers about editing the registry apply...

    Gerry

  9. #9

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Yes! that registry tweak fixed it. Thank you!

    I wonder if that switch should be in the Xara's Options box...

  10. #10
    Join Date
    Oct 2008
    Location
    Sundern, Germany
    Posts
    352

    Default Re: Damaged "printscreen"paste in v8...a bug?

    Quote Originally Posted by GerryI View Post
    The pasting of alpha channel 32bpp bmps has been changed to preserve the alpha data in the bitmap to improve workflow with various other programs.
    Woah, that's actually a very welcome change. Why isn't that anywhere in the change logs? Or maybe I've overlooked it...

    I've always screamed at Xara for not preserving alpha information when importing PNGs via the clipboard. Thanks for the fix!
    Alexander Ewering
    instinctive mediaworks

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •