Welcome to TalkGraphics.com
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39
  1. #21

    Default Re: Bug list for WD8?

    Are you sure you following my directions carefully to remove the viewport meta?
    Because it is still present in http://billybirddesigns.com/

    And adding your custom meta gives you conflicting viewports

    <head>
    <meta name="XAR Files" content="index_htm_files/xr_files.txt"/>
    <title>index</title>
    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
    <meta http-equiv="Content-Type" content="text/html; charset=Windows-1252"/>
    <meta name="Generator" content="Xara HTML filter v.5.0.0.939"/>
    <link rel="stylesheet" type="text/css" href="index_htm_files/xr_main.css"/>
    <link rel="stylesheet" type="text/css" href="index_htm_files/xr_text.css"/>
    <script type="text/javascript" src="index_htm_files/roe.js"></script>
    <meta name="viewport" content="width=device-width, initial-scale=0.33"/>

    </head>


    EDIT: Ah I see you are not using the most recent WD MX update.

    I thought we covered this earlier.
    Your filter shows an earlier version Xara HTML filter v.5.0.0.939
    You must have Xara HTML filter v.5.0.0.947 for the hack to work.
    Please update your MX immediately and try again.

    Disable the viewport metatag, add following name to any object in the document:

    NoViewportMeta
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	NoViewportMeta.jpg 
Views:	37 
Size:	17.8 KB 
ID:	89137  

  2. #22
    Join Date
    Sep 2011
    Location
    Perth, Australia
    Posts
    155

    Default Re: Bug list for WD8?

    Hi Sledger. I check for updates every few days, and the last update I got was on April 16 I think. I just checked again and it is telling me the programme is up to date. I did the NoViewportMeta as instructed but the picture disappeared and the words NoViewportMeta displayed instead. So I undid all of that and then did the stuff in the HTML head under website properties and on my ios devices it is now displaying in the browser. When I view the page info on billybird I get :

    index_htm_files/xr_files.txt
    width=device-width, initial-scale=1.0
    text/html; charset=Windows-1252
    Xara HTML filter v.5.0.0.939
    width=device-width, initial-scale=0.33

    and I can see the viewport value at 1.0 and the one at the bottom at 0.33. However, the sites seem to be displaying on all browsers, so does one value make the other value obsolete? Should I edit this in notepad instead, as previously, and change the 1.0 value to .33 and then delete the code in the HTML head? I can see that it is showing that I do not have MX .947, but I update regularly. How come I am being told that I have the latest update whenever I do this?
    Last edited by Abikadabra; 30 April 2012 at 06:17 AM.
    Live your life in such a way that when your feet hit the floor in the morning, Satan shudders and says, 'Oh s$%#t....she's awake!'

  3. #23

    Default Re: Bug list for WD8?

    Are you using Web Designer MX or Web Designer MX Premium?

  4. #24
    Join Date
    Sep 2011
    Location
    Perth, Australia
    Posts
    155

    Default Re: Bug list for WD8?

    I am using Premium and it tells me that the programme is up to date. I have just seen that my code thingy only works for iphones in portrait orientation, and leaves a bit to be desired in landscape orientation. Also, on my android and ipad the index page of any site is pushed out of view into the right hand side of the browser (off the browser actually) when in landscape mode. It is only the index page. The other pages are fine. I will continue to have a play around tonight when I get home.
    Live your life in such a way that when your feet hit the floor in the morning, Satan shudders and says, 'Oh s$%#t....she's awake!'

  5. #25

    Default Re: Bug list for WD8?

    Quote Originally Posted by Abikadabra View Post
    Also, on my android and ipad the index page of any site is pushed out of view into the right hand side of the browser (off the browser actually) when in landscape mode. It is only the index page.
    I do not get this on either of my Android devices as shown in my screenshots earlier, but this doesn't help you much - though it does indicate that there may be some differences with the mobile device or browser used which is causing this.
    I'm not sure why you aren't getting the most recent update. I shall install MX Premium on a spare machine and test the update process again from here

  6. #26
    Join Date
    Nov 2011
    Posts
    12

    Default Re: Bug list for WD8?

    Hi Sledger - thanks to you and others who have looked at this.

    I am running MX and still have issues - do we have a definitive fix for this I can try. I have tried a site on Samsung Galaxy Note and Samsung Galaxy S2 and both are displaying 'zoomed in' top left. I would assume that Xara will be looking at this and perhaps get a fix out soon?

  7. #27

    Default Re: Bug list for WD8?

    OK, I have tested one of my own WD7 sites and can see what you mean when exported by MX, I can also confirm that disabling the viewport metatag by add following name to any object in the document: NoViewportMeta works perfectly by returning to the viewport zoom level you were used too before Xara added this meta.

    I'll find out what's going on, however I do know that the viewport meta was added to fix display issues with iOS.

    Stay tuned

  8. #28
    Join Date
    Nov 2011
    Posts
    12

    Default Re: Bug list for WD8?

    Well I just had the following reply from Xara;


    Hi,

    This is not a bug, but an improvement over version 7 in it's compatibility to display on mobile devices.
    In version 7 how a web page was displayed on a mobile device was dependent on the mobile device and it's browser. In MX it now includes a viewport tag by default which means that the page is displayed at an optimum resolution for the devices resolution, which will vary by device. Currently there is no was to disable this from being included in the export, but in future patch updates this will be provided for those that do not want this enhanced functionality. This viewport tag does not stop you from 'zooming out' on the page, all it does is set the intial viewport to the resolution of the device.

  9. #29
    Join Date
    Apr 2012
    Posts
    2

    Default Re: Bug list for WD8?

    Hi Everyone,

    I have been experiencing this same problem. What I did is I opened my web page (which is 955px wide) in notepad and changed <meta name="viewport" content="width=device-width, initial-scale=1.0"/> to <meta name="viewport" content="width=955">. Essentially, setting the content width to whatever the page width is.

    Now when I view the page on my Motorola Droid X, it displays the whole page fitted correctly to my phones display. The page fits correctly in either landscape or portrait orientation. The zoom is all the way out, but I actually prefer having the page zoomed out giving me the option to zoom in and out as I deem necessary rather than the page displaying zoomed all the way in to match the mobile devices resolution. With the former, I can see immediately where I want to zoom to, with the latter I have to first zoom out or scroll around and than focus on the area of the page that interests me. To me...that's just an extra step.

    Anyway, I don't have an ipad or iphone, so I don't know how this works on those devices. Can someone please try this out and post back here regarding Apple devices? Also, while this method worked, I'm not 100% sure if this is really a good fix or not. Does this work well on other devices? Are there other things to consider long term? Please try this and critique it and post your thoughts.

    Thanks!

  10. #30
    Join Date
    Sep 2011
    Location
    Inveraray - Argyll
    Posts
    4

    Default Re: Bug list for WD8?

    I also have the same problem with sites which worked perfectly on mobiles which were produced using 7 premium and on upgrading to MX premium the pages are no longer viewable on my Samsung Galaxy S2 as only the top left of the page appears and cannot be reduced to view the page. I have now reverted my updated sites back to version 7 and will not be using MX until this is fixed, which I hope will be soon as I can't afford to throw my money away on something which is not an improvement over that which I already had.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •