Welcome to TalkGraphics.com
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Join Date
    Apr 2007
    Location
    USA
    Posts
    280

    Default Flash Will Not Play

    I am having problems getting a Flash (.swf) file to play when the page loads. I do not get any type of error messages, it just does not play.

    Let me explain what is going on. I am running Microsoft IIS on my localhost for testing pages I design for our company. I use Microsoft VWD 2008 Express Edition and Micorsoft Expressions for developing web pages. I am using XX to develop the .swf files.

    When I load a page that contains the .swf file using either of the development tools, the file plays as it should. If I load the file by navigating to it through IIS, the .swf file does not play.

    Can someone help me with this?

  2. #2
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,209

    Default Re: Flash Will Not Play

    Try using another browser. Internet Explorer will not play a swf file without it being in a web page.
    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

  3. #3

    Default Re: Flash Will Not Play

    IE7 does Bill.
    You will get a blocked ActiveX security message, but it will play fine without being embedded.

  4. #4
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,209

    Default Re: Flash Will Not Play

    Ah-ha...I had the flash plug in disabled in my IE7 settings. I don't recall making that change but I must have at one point.

    The ActiveX warning doesn't pop up when the .swf is in my IIS home directory.
    Last edited by Soquili; 09 October 2008 at 11:07 PM.
    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

  5. #5
    Join Date
    Apr 2007
    Location
    USA
    Posts
    280

    Default Re: Flash Will Not Play

    The .swf file is embeded as a flas object on a web page. When I view the page from either of the development enviroments, it plays just fine. Both of these environments have the MS developer server running.

    When I display the page via IIS, the .swf file does not play. Same page, just being launched differently. I have also double clicked on the .swf tile then told the system to use IE7 to view the file and it plays fine then also.

    I have checked several things on IIS (made sure it was set to run both scripts and executables) and even went in and made sure that .swf was set up as a MIME type and still no luck. I have talked to others who said they had problems with Flash file and the uninstalling and then reinstalling the Flash Player solved their problem. I tried that as well. Still no luck. The darn files just will not play when I have them inside a web site and launch the web site as localhost using IIS.

    I have given the same files to one of our developers and they have embeded them on a web page (using the same exact code I am using) and the page is on a hosted server that is also running IIS and the darn thing works there. I am sure I must have missed some kind of setting on IIS but I am stumped.

    It should not have anything to do with the browser because I am using the same browser to look at the web page in all of these instances.

  6. #6
    Join Date
    Aug 2000
    Location
    Harwich, Essex, England
    Posts
    11,386

    Default Re: Flash Will Not Play

    dcahall,

    Flash has some security set ups that stop running certain swf's from the local computer. If they're created in Flash it redirects you to an Adobe page were you can select to overide / trust this file on your local computer. This could be your problem. If it is then it's a problem only you should encounter not visitors, so perhaps your chasing your own tail here a bit.

    Not sure if this is your problem but worth mentioning.
    Egg
    Endangered Species
    HP xw9400 W/S / 2 x Dual Core AMD / RAM 32 GB / 120 GB Kingston SSD / 500 GB HDD / ATI Radeon HD 5450 / Windows 7 / 64 Bit /

  7. #7
    Join Date
    Apr 2007
    Location
    USA
    Posts
    280

    Default Re: Flash Will Not Play

    The .swf files were created with XX. I have checked the security settings and can not find any that would appear to block the files. I do not get any type of error messages, warnings, and any mention of needing to go to Adobe or anything of that nature.

    I just get an empty block where the .swf file should be playing. I have discussed this with several people who are also familiar with both Flash and IIS (which BTW is version 5.1 becuase I am running Windows XP) and no one seems to have a clue of why this is happening. There has to be a reason

    When I put the exact same code and files on a production or test system the pages display fine and the .swf files play. It is just from my localhost that I am having problems. I have been "living" with it by loading the files on my local machine via the development server (which is a pain when I am trying to get feedback from users). At this point I am trying to understand why this happens.

    I do appreciate all of the feedback I have gotten and I am willing to explore all suggestions - I want to understand why it happens so I can eliminate the problem on future projects.

  8. #8
    Join Date
    Nov 2000
    Location
    Red Boiling Springs TN USA
    Posts
    19,209

    Default Re: Flash Will Not Play

    Which version of IIS are you running and which version of Windows?

    It may be a setting within IIS Manager. Knowing the version will aid in tracking down a possible solution.
    Soquili
    a.k.a. Bill Taylor
    Bill is no longer with us. He died on 10 Dec 2012. We remember him always.
    My TG Album
    Last XaReg update

  9. #9
    Join Date
    Apr 2007
    Location
    USA
    Posts
    280

    Default Re: Flash Will Not Play

    IIS Version 5.1

    Windows XP

  10. #10
    Join Date
    Apr 2007
    Location
    USA
    Posts
    280

    Default Re: Flash Will Not Play

    Interesting that no one has ever come up with a solution. I also posted to an Adobe forum and no one has answered that one either. I have tried modifying all kinds of settings on both IIS and my browser and nothing has solved the problem.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •